Wasp.Cloud.Inventory.Example Namespace

Classes
 | Class | Description
Public class | CSharpPublicApiExampleProgram |
Public class | CSharpPublicApiExampleProgramApiItemsPublicApiClients |
Public class | CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel |
Public class | CSharpPublicApiExampleProgramAttachmentUploadAttributes |
Private class | CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient |
Public class | CSharpPublicApiExampleProgramItemAttachmentInfo |
Public class | CSharpPublicApiExampleProgramItemDimensionInfos |
Public class | CSharpPublicApiExampleProgramItemInventorysInfo |
Public class | CSharpPublicApiExampleProgramItemLocationSettings |
Public class | CSharpPublicApiExampleProgramItemNonInventoryInfos |
Public class | CSharpPublicApiExampleProgramItemPrices |
Public class | CSharpPublicApiExampleProgramItemTrackbyInfos |
Public class | CSharpPublicApiExampleProgramItemVendorInfo |
Private class | CSharpPublicApiExampleProgramMyItemMoveTransactionModel |
Public class | CSharpPublicApiExampleProgramPurchaseOrderColumnOrder |
Public class | CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo |
Public class | Filter |
Public class | HttpClientInitializers |
Public class | PublicApiClientBase |
Public class | TConverter |
Enumerations
 | Enumeration | Description
Public enumeration | CSharpPublicApiExampleProgramCostMethodEnums |
Public enumeration | CSharpPublicApiExampleProgramItemTypeEnums |
Public enumeration | CSharpPublicApiExampleProgramUploadFileType |
Public enumeration | CSharpPublicApiExampleProgramWtFormId |


CSharpPublicApiExampleProgram Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgram

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class CSharpPublicApiExampleProgram
Public Class CSharpPublicApiExampleProgram
public ref class CSharpPublicApiExampleProgram
type CSharpPublicApiExampleProgram =  class end
public class CSharpPublicApiExampleProgram
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram');

The CSharpPublicApiExampleProgram type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgram | Initializes a new instance of the CSharpPublicApiExampleProgram class
Top
Methods
 | Name | Description
Public method | AdvancedInfoSearchItem |
Public method | AdvancedInfoSearchLocation |
Public method | AdvancedInfoSearchPickOrder |
Public method | AdvancedInfoSearchSite |
Public method | AdvancedInfoSearchTransactionHistory |
Public method | AdvancedInfoSearchTransactionHistoryV2 |
 | AssertFalse |
 | AssertTrue |
Private method | AutomatedUploadSample |
Private method | AutoUploadPurchaseOrders |
Private method | AutoUploadSites |
Public method | CalloutSignatureCalculated |
Public method | CheckForDemoDataAsync |
Public method | CheckForEmptyDatabaseAsync |
 | ComputeSHA256Hash |
Public method | CreateAndUpdateInventoryItemWithAttachment |
Public method | CreateInventoryItem |
Public method | CreateInventoryItemSample |
Private method | CreateInventoryItemSampleOLD |
Public method | CreateNonInventoryItemSample |
Private method | CreateNonInventoryItemSampleOLD |
Public method | CreatePickOrder |
Private method | CreatePickOrderSample |
Private method | CreatePurchaseOrderAsync |
Private method | CreatePurchaseOrderFailureSample |
Public method | CreatePurchaseOrderSample |
Public method | CreateServiceItemSample |
Private method | CreateServiceItemSampleOLD |
Private method | CreateTaxCodesSampleBadlyFormedJson |
Public method | CreateTaxCodesSampleBadlyFormedJsonLatest |
 | CsvConfiguration |
Public method | Customers |
Private method | CustomersSample |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExactSearchSite |
Public method | ExamplesThatRequireOnlyReadAccess |
Public method | ExamplesThatRequireWriteAccess |
 | ExceptionString |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateHelpExamples |
Public method | GetAssemblyItemSample |
Public method | GetCalloutHeaderPrivateKeyHash |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Private method | GetInventoryAdvanced |
Public method | GetInventoryAdvancedlatest |
Public method | GetInventoryItemSample |
Private method | GetInventoryItemSampleOLD |
Public method | GetInventoryItemsSearch |
Private method | GetInventorySample |
Private method | GetItemInfoAdvanced |
Public method | GetItemTransaction |
Private method | GetItemTransactions |
Public method | GetKitItemSample |
Public method | GetNonInventoryItems |
Public method | GetServerInfo |
Public method | GetServiceItemSample |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueT |
 | Main |
Public method | Manufacturers |
Private method | ManufacturersSample |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveAllItemsInFile |
Public method | POSTApi(String, ListCustomerModelInfo) |
Public method | POSTApi(String, ListManufacturerModelInfo) |
Public method | POSTApi(String, ListVendorModelInfo) |
Public method | PurchaseOrderAdvancedInfoSearchItem |
Public method | RunAllExamples |
Private method | RunSitesLocationsDemo |
Private method | SaveCustomerTest |
Private method | SaveManufacturerTest |
Private method | SaveSupplierTest |
Private method | SimpleCodeTaxCodeCRUDTest |
Public method | SimpleCodeTaxCodeCRUDTestLatest |
Private method | SimpleCreateReadUpdateDeleteLocationSample |
Public method | SimpleCreateReadUpdateDeleteSearchLocation |
Public method | SimpleCreateReadUpdateDeleteSearchSite |
Private method | SimpleCreateReadUpdateDeleteSiteSample |
Private method | SimpleTransactionsTest |
Private method | SimpleTransactionsTestLatest |
Private method | SiteCustomFieldSample |
Private method | StreamInventoryAdvanced |
Public method | Suppliers |
Private method | SuppliersSample |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Private method | TrackbyTransactionsTest |
Public method | TrackbyTransactionTest |
Private method | TransactionHistoryNotesAsync |
Private method | UpdateCustomersSample |
Private method | UpdateManufacturersSample |
Public method | UpdatePurchaseOrderSample |
Private method | UpdateSuppliersSample |
Private method | UploadAttachmentForDifferentFormsSample |
Public method | UploadAttachmentForDifferentFormsSampleLatest |
Private method | UploadAttachmentOnServerSample |
Public method | UploadAttachmentOnServerSampleLatest |
Private method | UploadFile |
Private method | UploadFileLatest |
 | Usage |
Private method | WriteInputData |
Private method | WriteOutputLine |
Top
Fields
 | Name | Description
Private field | _guidString |
Private field | _initializer |
Private field | bWriteOutputHeader |
 | DCF_SHIPMENT_NOT_RECEIVED |
 | DCF_SHIPMENT_SHIPPED |
Private field | Writer |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram Constructor

Initializes a new instance of the CSharpPublicApiExampleProgram class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgram()
Public Sub New
public:
CSharpPublicApiExampleProgram()
new : unit -> CSharpPublicApiExampleProgram
public CSharpPublicApiExampleProgram()
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram = function();
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram Methods

The CSharpPublicApiExampleProgram type exposes the following members.

Methods
 | Name | Description
Public method | AdvancedInfoSearchItem |
Public method | AdvancedInfoSearchLocation |
Public method | AdvancedInfoSearchPickOrder |
Public method | AdvancedInfoSearchSite |
Public method | AdvancedInfoSearchTransactionHistory |
Public method | AdvancedInfoSearchTransactionHistoryV2 |
 | AssertFalse |
 | AssertTrue |
Private method | AutomatedUploadSample |
Private method | AutoUploadPurchaseOrders |
Private method | AutoUploadSites |
Public method | CalloutSignatureCalculated |
Public method | CheckForDemoDataAsync |
Public method | CheckForEmptyDatabaseAsync |
 | ComputeSHA256Hash |
Public method | CreateAndUpdateInventoryItemWithAttachment |
Public method | CreateInventoryItem |
Public method | CreateInventoryItemSample |
Private method | CreateInventoryItemSampleOLD |
Public method | CreateNonInventoryItemSample |
Private method | CreateNonInventoryItemSampleOLD |
Public method | CreatePickOrder |
Private method | CreatePickOrderSample |
Private method | CreatePurchaseOrderAsync |
Private method | CreatePurchaseOrderFailureSample |
Public method | CreatePurchaseOrderSample |
Public method | CreateServiceItemSample |
Private method | CreateServiceItemSampleOLD |
Private method | CreateTaxCodesSampleBadlyFormedJson |
Public method | CreateTaxCodesSampleBadlyFormedJsonLatest |
 | CsvConfiguration |
Public method | Customers |
Private method | CustomersSample |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExactSearchSite |
Public method | ExamplesThatRequireOnlyReadAccess |
Public method | ExamplesThatRequireWriteAccess |
 | ExceptionString |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateHelpExamples |
Public method | GetAssemblyItemSample |
Public method | GetCalloutHeaderPrivateKeyHash |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Private method | GetInventoryAdvanced |
Public method | GetInventoryAdvancedlatest |
Public method | GetInventoryItemSample |
Private method | GetInventoryItemSampleOLD |
Public method | GetInventoryItemsSearch |
Private method | GetInventorySample |
Private method | GetItemInfoAdvanced |
Public method | GetItemTransaction |
Private method | GetItemTransactions |
Public method | GetKitItemSample |
Public method | GetNonInventoryItems |
Public method | GetServerInfo |
Public method | GetServiceItemSample |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueT |
 | Main |
Public method | Manufacturers |
Private method | ManufacturersSample |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveAllItemsInFile |
Public method | POSTApi(String, ListCustomerModelInfo) |
Public method | POSTApi(String, ListManufacturerModelInfo) |
Public method | POSTApi(String, ListVendorModelInfo) |
Public method | PurchaseOrderAdvancedInfoSearchItem |
Public method | RunAllExamples |
Private method | RunSitesLocationsDemo |
Private method | SaveCustomerTest |
Private method | SaveManufacturerTest |
Private method | SaveSupplierTest |
Private method | SimpleCodeTaxCodeCRUDTest |
Public method | SimpleCodeTaxCodeCRUDTestLatest |
Private method | SimpleCreateReadUpdateDeleteLocationSample |
Public method | SimpleCreateReadUpdateDeleteSearchLocation |
Public method | SimpleCreateReadUpdateDeleteSearchSite |
Private method | SimpleCreateReadUpdateDeleteSiteSample |
Private method | SimpleTransactionsTest |
Private method | SimpleTransactionsTestLatest |
Private method | SiteCustomFieldSample |
Private method | StreamInventoryAdvanced |
Public method | Suppliers |
Private method | SuppliersSample |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Private method | TrackbyTransactionsTest |
Public method | TrackbyTransactionTest |
Private method | TransactionHistoryNotesAsync |
Private method | UpdateCustomersSample |
Private method | UpdateManufacturersSample |
Public method | UpdatePurchaseOrderSample |
Private method | UpdateSuppliersSample |
Private method | UploadAttachmentForDifferentFormsSample |
Public method | UploadAttachmentForDifferentFormsSampleLatest |
Private method | UploadAttachmentOnServerSample |
Public method | UploadAttachmentOnServerSampleLatest |
Private method | UploadFile |
Private method | UploadFileLatest |
 | Usage |
Private method | WriteInputData |
Private method | WriteOutputLine |
Top
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AdvancedInfoSearchItem Method

A Sandcastle Documented Class Library

CSharpPublicApiExampleProgramAdvancedInfoSearchItem Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AdvancedInfoSearchItem(
    string[] item
)
Public Function AdvancedInfoSearchItem (
    item As String()
) As Task(Of Integer)
public:
Task<int>^ AdvancedInfoSearchItem(
    array<String^>^ item
)
member AdvancedInfoSearchItem :
        item : string[] -> Task<int>

public Task<int> AdvancedInfoSearchItem(
    String[] item
)
function AdvancedInfoSearchItem(item);

Parameters

item
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AdvancedInfoSearchLocation Method

CSharpPublicApiExampleProgramAdvancedInfoSearchLocation Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AdvancedInfoSearchLocation(
    string[] assetTagsToFind
)
Public Function AdvancedInfoSearchLocation (
    assetTagsToFind As String()
) As Task(Of Integer)
public:
Task<int>^ AdvancedInfoSearchLocation(
    array<String^>^ assetTagsToFind
)
member AdvancedInfoSearchLocation :
        assetTagsToFind : string[] -> Task<int>

public Task<int> AdvancedInfoSearchLocation(
    String[] assetTagsToFind
)
function AdvancedInfoSearchLocation(assetTagsToFind);

Parameters

assetTagsToFind
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AdvancedInfoSearchPickOrder Method

CSharpPublicApiExampleProgramAdvancedInfoSearchPickOrder Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AdvancedInfoSearchPickOrder(
    string[] assetTagsToFind = null
)
Public Function AdvancedInfoSearchPickOrder (
    Optional assetTagsToFind As String() = Nothing
) As Task(Of Integer)
public:
Task<int>^ AdvancedInfoSearchPickOrder(
    array<String^>^ assetTagsToFind = nullptr
)
member AdvancedInfoSearchPickOrder :
        ?assetTagsToFind : string[]
(* Defaults:
        let _assetTagsToFind = defaultArg assetTagsToFind null
*)
-> Task<int>

public Task<int> AdvancedInfoSearchPickOrder(
    String[] assetTagsToFind = null
)
function AdvancedInfoSearchPickOrder(assetTagsToFind);

Parameters

assetTagsToFind (Optional)
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AdvancedInfoSearchSite Method

CSharpPublicApiExampleProgramAdvancedInfoSearchSite Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AdvancedInfoSearchSite(
    string[] assetTagsToFind
)
Public Function AdvancedInfoSearchSite (
    assetTagsToFind As String()
) As Task(Of Integer)
public:
Task<int>^ AdvancedInfoSearchSite(
    array<String^>^ assetTagsToFind
)
member AdvancedInfoSearchSite :
        assetTagsToFind : string[] -> Task<int>

public Task<int> AdvancedInfoSearchSite(
    String[] assetTagsToFind
)
function AdvancedInfoSearchSite(assetTagsToFind);

Parameters

assetTagsToFind
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AdvancedInfoSearchTransactionHistory Method

CSharpPublicApiExampleProgramAdvancedInfoSearchTransactionHistory Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AdvancedInfoSearchTransactionHistory(
    string[] assetTagsToFind
)
Public Function AdvancedInfoSearchTransactionHistory (
    assetTagsToFind As String()
) As Task(Of Integer)
public:
Task<int>^ AdvancedInfoSearchTransactionHistory(
    array<String^>^ assetTagsToFind
)
member AdvancedInfoSearchTransactionHistory :
        assetTagsToFind : string[] -> Task<int>

public Task<int> AdvancedInfoSearchTransactionHistory(
    String[] assetTagsToFind
)
function AdvancedInfoSearchTransactionHistory(assetTagsToFind);

Parameters

assetTagsToFind
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AdvancedInfoSearchTransactionHistoryV2 Method

CSharpPublicApiExampleProgramAdvancedInfoSearchTransactionHistoryV2 Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AdvancedInfoSearchTransactionHistoryV2(
    string[] assetTagsToFind
)
Public Function AdvancedInfoSearchTransactionHistoryV2 (
    assetTagsToFind As String()
) As Task(Of Integer)
public:
Task<int>^ AdvancedInfoSearchTransactionHistoryV2(
    array<String^>^ assetTagsToFind
)
member AdvancedInfoSearchTransactionHistoryV2 :
        assetTagsToFind : string[] -> Task<int>

public Task<int> AdvancedInfoSearchTransactionHistoryV2(
    String[] assetTagsToFind
)
function AdvancedInfoSearchTransactionHistoryV2(assetTagsToFind);

Parameters

assetTagsToFind
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AssertFalse Method

CSharpPublicApiExampleProgramAssertFalse Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static void AssertFalse(
    bool flag,
    string msg = null
)
Private Shared Sub AssertFalse (
    flag As Boolean,
    Optional msg As String = Nothing
)
private:
static void AssertFalse(
    bool flag,
    String^ msg = nullptr
)
private static member AssertFalse :
        flag : bool *
        ?msg : string
(* Defaults:
        let _msg = defaultArg msg null
*)
-> unit

private static void AssertFalse(
    boolean flag,
    String msg = null
)
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.AssertFalse = function(flag, msg);

Parameters

flag
Type: SystemBoolean
msg (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AssertTrue Method

CSharpPublicApiExampleProgramAssertTrue Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static void AssertTrue(
    bool flag,
    string msg = null
)
Private Shared Sub AssertTrue (
    flag As Boolean,
    Optional msg As String = Nothing
)
private:
static void AssertTrue(
    bool flag,
    String^ msg = nullptr
)
private static member AssertTrue :
        flag : bool *
        ?msg : string
(* Defaults:
        let _msg = defaultArg msg null
*)
-> unit

private static void AssertTrue(
    boolean flag,
    String msg = null
)
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.AssertTrue = function(flag, msg);

Parameters

flag
Type: SystemBoolean
msg (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AutomatedUploadSample Method

CSharpPublicApiExampleProgramAutomatedUploadSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AutomatedUploadSample()
Private Function AutomatedUploadSample As Task(Of Integer)
private:
Task<int>^ AutomatedUploadSample()
private member AutomatedUploadSample : unit -> Task<int>

private Task<int> AutomatedUploadSample()
function AutomatedUploadSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AutoUploadPurchaseOrders Method

CSharpPublicApiExampleProgramAutoUploadPurchaseOrders Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AutoUploadPurchaseOrders(
    string fileName
)
Private Function AutoUploadPurchaseOrders (
    fileName As String
) As Task(Of Integer)
private:
Task<int>^ AutoUploadPurchaseOrders(
    String^ fileName
)
private member AutoUploadPurchaseOrders :
        fileName : string -> Task<int>

private Task<int> AutoUploadPurchaseOrders(
    String fileName
)
function AutoUploadPurchaseOrders(fileName);

Parameters

fileName
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.AutoUploadSites Method

CSharpPublicApiExampleProgramAutoUploadSites Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AutoUploadSites(
    string fileName
)
Private Function AutoUploadSites (
    fileName As String
) As Task(Of Integer)
private:
Task<int>^ AutoUploadSites(
    String^ fileName
)
private member AutoUploadSites :
        fileName : string -> Task<int>

private Task<int> AutoUploadSites(
    String fileName
)
function AutoUploadSites(fileName);

Parameters

fileName
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CalloutSignatureCalculated Method

CSharpPublicApiExampleProgramCalloutSignatureCalculated Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string CalloutSignatureCalculated(
    string Wasp_Callout_Name,
    string Wasp_Callout_Timestamp
)
Public Function CalloutSignatureCalculated (
    Wasp_Callout_Name As String,
    Wasp_Callout_Timestamp As String
) As String
public:
String^ CalloutSignatureCalculated(
    String^ Wasp_Callout_Name,
    String^ Wasp_Callout_Timestamp
)
member CalloutSignatureCalculated :
        Wasp_Callout_Name : string *
        Wasp_Callout_Timestamp : string -> string

public String CalloutSignatureCalculated(
    String Wasp_Callout_Name,
    String Wasp_Callout_Timestamp
)
function CalloutSignatureCalculated(Wasp_Callout_Name, Wasp_Callout_Timestamp);

Parameters

Wasp_Callout_Name
Type: SystemString
Wasp_Callout_Timestamp
Type: SystemString

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CheckForDemoDataAsync Method

CSharpPublicApiExampleProgramCheckForDemoDataAsync Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<bool> CheckForDemoDataAsync()
Public Function CheckForDemoDataAsync As Task(Of Boolean)
public:
Task<bool>^ CheckForDemoDataAsync()
member CheckForDemoDataAsync : unit -> Task<bool>

public Task<boolean> CheckForDemoDataAsync()
function CheckForDemoDataAsync();

Return Value

Type: Task Boolean
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CheckForEmptyDatabaseAsync Method

CSharpPublicApiExampleProgramCheckForEmptyDatabaseAsync Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<bool> CheckForEmptyDatabaseAsync()
Public Function CheckForEmptyDatabaseAsync As Task(Of Boolean)
public:
Task<bool>^ CheckForEmptyDatabaseAsync()
member CheckForEmptyDatabaseAsync : unit -> Task<bool>

public Task<boolean> CheckForEmptyDatabaseAsync()
function CheckForEmptyDatabaseAsync();

Return Value

Type: Task Boolean
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.ComputeSHA256Hash Method

CSharpPublicApiExampleProgramComputeSHA256Hash Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static byte[] ComputeSHA256Hash(
    Encoding encoding,
    string secret,
    params string[] texts
)
Private Shared Function ComputeSHA256Hash (
    encoding As Encoding,
    secret As String,
    ParamArray texts As String()
) As Byte()
private:
static array<unsigned char>^ ComputeSHA256Hash(
    Encoding^ encoding,
    String^ secret,
    ... array<String^>^ texts
)
private static member ComputeSHA256Hash :
        encoding : Encoding *
        secret : string *
        texts : string[] -> byte[]

private static byte[] ComputeSHA256Hash(
    Encoding encoding,
    String secret,
    String[] texts
)
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.ComputeSHA256Hash = function(encoding, secret, ... texts);

Parameters

encoding
Type: System.TextEncoding
secret
Type: SystemString
texts
Type: SystemString

Return Value

Type: Byte
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateAndUpdateInventoryItemWithAttachment Method

CSharpPublicApiExampleProgramCreateAndUpdateInventoryItemWithAttachment Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task CreateAndUpdateInventoryItemWithAttachment()
Public Function CreateAndUpdateInventoryItemWithAttachment As Task
public:
Task^ CreateAndUpdateInventoryItemWithAttachment()
member CreateAndUpdateInventoryItemWithAttachment : unit -> Task

public Task CreateAndUpdateInventoryItemWithAttachment()
function CreateAndUpdateInventoryItemWithAttachment();

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateInventoryItem Method

CSharpPublicApiExampleProgramCreateInventoryItem Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreateInventoryItem()
Public Function CreateInventoryItem As Task(Of Integer)
public:
Task<int>^ CreateInventoryItem()
member CreateInventoryItem : unit -> Task<int>

public Task<int> CreateInventoryItem()
function CreateInventoryItem();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateInventoryItemSample Method

CSharpPublicApiExampleProgramCreateInventoryItemSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreateInventoryItemSample()
Public Function CreateInventoryItemSample As Task(Of Integer)
public:
Task<int>^ CreateInventoryItemSample()
member CreateInventoryItemSample : unit -> Task<int>

public Task<int> CreateInventoryItemSample()
function CreateInventoryItemSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateInventoryItemSampleOLD Method

CSharpPublicApiExampleProgramCreateInventoryItemSampleOLD Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreateInventoryItemSampleOLD()
Private Function CreateInventoryItemSampleOLD As Task(Of Integer)
private:
Task<int>^ CreateInventoryItemSampleOLD()
private member CreateInventoryItemSampleOLD : unit -> Task<int>

private Task<int> CreateInventoryItemSampleOLD()
function CreateInventoryItemSampleOLD();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateNonInventoryItemSample Method

CSharpPublicApiExampleProgramCreateNonInventoryItemSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreateNonInventoryItemSample()
Public Function CreateNonInventoryItemSample As Task(Of Integer)
public:
Task<int>^ CreateNonInventoryItemSample()
member CreateNonInventoryItemSample : unit -> Task<int>

public Task<int> CreateNonInventoryItemSample()
function CreateNonInventoryItemSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateNonInventoryItemSampleOLD Method

CSharpPublicApiExampleProgramCreateNonInventoryItemSampleOLD Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreateNonInventoryItemSampleOLD()
Private Function CreateNonInventoryItemSampleOLD As Task(Of Integer)
private:
Task<int>^ CreateNonInventoryItemSampleOLD()
private member CreateNonInventoryItemSampleOLD : unit -> Task<int>

private Task<int> CreateNonInventoryItemSampleOLD()
function CreateNonInventoryItemSampleOLD();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreatePickOrder Method

CSharpPublicApiExampleProgramCreatePickOrder Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreatePickOrder()
Public Function CreatePickOrder As Task(Of Integer)
public:
Task<int>^ CreatePickOrder()
member CreatePickOrder : unit -> Task<int>

public Task<int> CreatePickOrder()
function CreatePickOrder();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreatePickOrderSample Method

CSharpPublicApiExampleProgramCreatePickOrderSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreatePickOrderSample()
Private Function CreatePickOrderSample As Task(Of Integer)
private:
Task<int>^ CreatePickOrderSample()
private member CreatePickOrderSample : unit -> Task<int>

private Task<int> CreatePickOrderSample()
function CreatePickOrderSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreatePurchaseOrderAsync Method

CSharpPublicApiExampleProgramCreatePurchaseOrderAsync Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<PurchaseOrderInfo> CreatePurchaseOrderAsync()
Private Function CreatePurchaseOrderAsync As Task(Of PurchaseOrderInfo)
private:
Task<PurchaseOrderInfo^>^ CreatePurchaseOrderAsync()
private member CreatePurchaseOrderAsync : unit -> Task<PurchaseOrderInfo>

private Task<PurchaseOrderInfo> CreatePurchaseOrderAsync()
function CreatePurchaseOrderAsync();

Return Value

Type: Task PurchaseOrderInfo
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreatePurchaseOrderFailureSample Method

CSharpPublicApiExampleProgramCreatePurchaseOrderFailureSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreatePurchaseOrderFailureSample()
Private Function CreatePurchaseOrderFailureSample As Task(Of Integer)
private:
Task<int>^ CreatePurchaseOrderFailureSample()
private member CreatePurchaseOrderFailureSample : unit -> Task<int>

private Task<int> CreatePurchaseOrderFailureSample()
function CreatePurchaseOrderFailureSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreatePurchaseOrderSample Method

CSharpPublicApiExampleProgramCreatePurchaseOrderSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreatePurchaseOrderSample()
Public Function CreatePurchaseOrderSample As Task(Of Integer)
public:
Task<int>^ CreatePurchaseOrderSample()
member CreatePurchaseOrderSample : unit -> Task<int>

public Task<int> CreatePurchaseOrderSample()
function CreatePurchaseOrderSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateServiceItemSample Method

CSharpPublicApiExampleProgramCreateServiceItemSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreateServiceItemSample()
Public Function CreateServiceItemSample As Task(Of Integer)
public:
Task<int>^ CreateServiceItemSample()
member CreateServiceItemSample : unit -> Task<int>

public Task<int> CreateServiceItemSample()
function CreateServiceItemSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateServiceItemSampleOLD Method

CSharpPublicApiExampleProgramCreateServiceItemSampleOLD Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreateServiceItemSampleOLD()
Private Function CreateServiceItemSampleOLD As Task(Of Integer)
private:
Task<int>^ CreateServiceItemSampleOLD()
private member CreateServiceItemSampleOLD : unit -> Task<int>

private Task<int> CreateServiceItemSampleOLD()
function CreateServiceItemSampleOLD();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateTaxCodesSampleBadlyFormedJson Method

CSharpPublicApiExampleProgramCreateTaxCodesSampleBadlyFormedJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreateTaxCodesSampleBadlyFormedJson()
Private Function CreateTaxCodesSampleBadlyFormedJson As Task(Of Integer)
private:
Task<int>^ CreateTaxCodesSampleBadlyFormedJson()
private member CreateTaxCodesSampleBadlyFormedJson : unit -> Task<int>

private Task<int> CreateTaxCodesSampleBadlyFormedJson()
function CreateTaxCodesSampleBadlyFormedJson();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CreateTaxCodesSampleBadlyFormedJsonLatest Method

CSharpPublicApiExampleProgramCreateTaxCodesSampleBadlyFormedJsonLatest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreateTaxCodesSampleBadlyFormedJsonLatest()
Public Function CreateTaxCodesSampleBadlyFormedJsonLatest As Task(Of Integer)
public:
Task<int>^ CreateTaxCodesSampleBadlyFormedJsonLatest()
member CreateTaxCodesSampleBadlyFormedJsonLatest : unit -> Task<int>

public Task<int> CreateTaxCodesSampleBadlyFormedJsonLatest()
function CreateTaxCodesSampleBadlyFormedJsonLatest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CsvConfiguration Method

CSharpPublicApiExampleProgramCsvConfiguration Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CsvReader CsvConfiguration(
    CsvReader csv
)
Public Shared Function CsvConfiguration (
    csv As CsvReader
) As CsvReader
public:
static CsvReader^ CsvConfiguration(
    CsvReader^ csv
)
static member CsvConfiguration :
        csv : CsvReader -> CsvReader

public static CsvReader CsvConfiguration(
    CsvReader csv
)
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.CsvConfiguration = function(csv);

Parameters

csv
Type: CsvReader

Return Value

Type: CsvReader
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.Customers Method

CSharpPublicApiExampleProgramCustomers Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> Customers()
Public Function Customers As Task(Of Integer)
public:
Task<int>^ Customers()
member Customers : unit -> Task<int>

public Task<int> Customers()
function Customers();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.CustomersSample Method

CSharpPublicApiExampleProgramCustomersSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CustomersSample()
Private Function CustomersSample As Task(Of Integer)
private:
Task<int>^ CustomersSample()
private member CustomersSample : unit -> Task<int>

private Task<int> CustomersSample()
function CustomersSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.ExactSearchSite Method

CSharpPublicApiExampleProgramExactSearchSite Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static Task ExactSearchSite(
    ApiSitesPublicApiClient siteClient
)
Private Shared Function ExactSearchSite (
    siteClient As ApiSitesPublicApiClient
) As Task
private:
static Task^ ExactSearchSite(
    ApiSitesPublicApiClient^ siteClient
)
private static member ExactSearchSite :
        siteClient : ApiSitesPublicApiClient -> Task

private static Task ExactSearchSite(
    ApiSitesPublicApiClient siteClient
)
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.ExactSearchSite = function(siteClient);

Parameters

siteClient
Type: ApiSitesPublicApiClient

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.ExamplesThatRequireOnlyReadAccess Method

CSharpPublicApiExampleProgramExamplesThatRequireOnlyReadAccess Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task ExamplesThatRequireOnlyReadAccess(
    bool DemoDataExists
)
Public Function ExamplesThatRequireOnlyReadAccess (
    DemoDataExists As Boolean
) As Task
public:
Task^ ExamplesThatRequireOnlyReadAccess(
    bool DemoDataExists
)
member ExamplesThatRequireOnlyReadAccess :
        DemoDataExists : bool -> Task

public Task ExamplesThatRequireOnlyReadAccess(
    boolean DemoDataExists
)
function ExamplesThatRequireOnlyReadAccess(DemoDataExists);

Parameters

DemoDataExists
Type: SystemBoolean

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.ExamplesThatRequireWriteAccess Method

CSharpPublicApiExampleProgramExamplesThatRequireWriteAccess Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task ExamplesThatRequireWriteAccess(
    bool DemoDataExists
)
Public Function ExamplesThatRequireWriteAccess (
    DemoDataExists As Boolean
) As Task
public:
Task^ ExamplesThatRequireWriteAccess(
    bool DemoDataExists
)
member ExamplesThatRequireWriteAccess :
        DemoDataExists : bool -> Task

public Task ExamplesThatRequireWriteAccess(
    boolean DemoDataExists
)
function ExamplesThatRequireWriteAccess(DemoDataExists);

Parameters

DemoDataExists
Type: SystemBoolean

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.ExceptionString Method

CSharpPublicApiExampleProgramExceptionString Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static string ExceptionString(
    Exception exp,
    string callerMethod = null,
    string filePath = null,
    int lineNumber = 0
)
Public Shared Function ExceptionString (
    exp As Exception,
    Optional callerMethod As String = Nothing,
    Optional filePath As String = Nothing,
    Optional lineNumber As Integer = 0
) As String
public:
static String^ ExceptionString(
    Exception^ exp,
    String^ callerMethod = nullptr,
    String^ filePath = nullptr,
    int lineNumber = 0
)
static member ExceptionString :
        exp : Exception *
        ?callerMethod : string *
        ?filePath : string *
        ?lineNumber : int
(* Defaults:
        let _callerMethod = defaultArg callerMethod null
        let _filePath = defaultArg filePath null
        let _lineNumber = defaultArg lineNumber 0
*)
-> string

public static String ExceptionString(
    Exception exp,
    String callerMethod = null,
    String filePath = null,
    int lineNumber = 0
)
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.ExceptionString = function(exp, callerMethod, filePath, lineNumber);

Parameters

exp
Type: SystemException
callerMethod (Optional)
Type: SystemString
filePath (Optional)
Type: SystemString
lineNumber (Optional)
Type: SystemInt32

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GenerateHelpExamples Method

CSharpPublicApiExampleProgramGenerateHelpExamples Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task GenerateHelpExamples()
Public Function GenerateHelpExamples As Task
public:
Task^ GenerateHelpExamples()
member GenerateHelpExamples : unit -> Task

public Task GenerateHelpExamples()
function GenerateHelpExamples();

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetAssemblyItemSample Method

CSharpPublicApiExampleProgramGetAssemblyItemSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetAssemblyItemSample()
Public Function GetAssemblyItemSample As Task(Of Integer)
public:
Task<int>^ GetAssemblyItemSample()
member GetAssemblyItemSample : unit -> Task<int>

public Task<int> GetAssemblyItemSample()
function GetAssemblyItemSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetCalloutHeaderPrivateKeyHash Method

CSharpPublicApiExampleProgramGetCalloutHeaderPrivateKeyHash Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string GetCalloutHeaderPrivateKeyHash(
    string Wasp_Callout_Name,
    string Wasp_Callout_Timestamp,
    string calloutPrivateKey
)
Public Function GetCalloutHeaderPrivateKeyHash (
    Wasp_Callout_Name As String,
    Wasp_Callout_Timestamp As String,
    calloutPrivateKey As String
) As String
public:
String^ GetCalloutHeaderPrivateKeyHash(
    String^ Wasp_Callout_Name,
    String^ Wasp_Callout_Timestamp,
    String^ calloutPrivateKey
)
member GetCalloutHeaderPrivateKeyHash :
        Wasp_Callout_Name : string *
        Wasp_Callout_Timestamp : string *
        calloutPrivateKey : string -> string

public String GetCalloutHeaderPrivateKeyHash(
    String Wasp_Callout_Name,
    String Wasp_Callout_Timestamp,
    String calloutPrivateKey
)
function GetCalloutHeaderPrivateKeyHash(Wasp_Callout_Name, Wasp_Callout_Timestamp, calloutPrivateKey);

Parameters

Wasp_Callout_Name
Type: SystemString
Wasp_Callout_Timestamp
Type: SystemString
calloutPrivateKey
Type: SystemString

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetInventoryAdvanced Method

CSharpPublicApiExampleProgramGetInventoryAdvanced Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> GetInventoryAdvanced()
Private Function GetInventoryAdvanced As Task(Of Integer)
private:
Task<int>^ GetInventoryAdvanced()
private member GetInventoryAdvanced : unit -> Task<int>

private Task<int> GetInventoryAdvanced()
function GetInventoryAdvanced();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetInventoryAdvancedlatest Method

CSharpPublicApiExampleProgramGetInventoryAdvancedlatest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetInventoryAdvancedlatest()
Public Function GetInventoryAdvancedlatest As Task(Of Integer)
public:
Task<int>^ GetInventoryAdvancedlatest()
member GetInventoryAdvancedlatest : unit -> Task<int>

public Task<int> GetInventoryAdvancedlatest()
function GetInventoryAdvancedlatest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetInventoryItemSample Method

CSharpPublicApiExampleProgramGetInventoryItemSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetInventoryItemSample()
Public Function GetInventoryItemSample As Task(Of Integer)
public:
Task<int>^ GetInventoryItemSample()
member GetInventoryItemSample : unit -> Task<int>

public Task<int> GetInventoryItemSample()
function GetInventoryItemSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetInventoryItemSampleOLD Method

CSharpPublicApiExampleProgramGetInventoryItemSampleOLD Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> GetInventoryItemSampleOLD()
Private Function GetInventoryItemSampleOLD As Task(Of Integer)
private:
Task<int>^ GetInventoryItemSampleOLD()
private member GetInventoryItemSampleOLD : unit -> Task<int>

private Task<int> GetInventoryItemSampleOLD()
function GetInventoryItemSampleOLD();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetInventoryItemsSearch Method

CSharpPublicApiExampleProgramGetInventoryItemsSearch Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetInventoryItemsSearch()
Public Function GetInventoryItemsSearch As Task(Of Integer)
public:
Task<int>^ GetInventoryItemsSearch()
member GetInventoryItemsSearch : unit -> Task<int>

public Task<int> GetInventoryItemsSearch()
function GetInventoryItemsSearch();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetInventorySample Method

CSharpPublicApiExampleProgramGetInventorySample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> GetInventorySample()
Private Function GetInventorySample As Task(Of Integer)
private:
Task<int>^ GetInventorySample()
private member GetInventorySample : unit -> Task<int>

private Task<int> GetInventorySample()
function GetInventorySample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetItemInfoAdvanced Method

CSharpPublicApiExampleProgramGetItemInfoAdvanced Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> GetItemInfoAdvanced()
Private Function GetItemInfoAdvanced As Task(Of Integer)
private:
Task<int>^ GetItemInfoAdvanced()
private member GetItemInfoAdvanced : unit -> Task<int>

private Task<int> GetItemInfoAdvanced()
function GetItemInfoAdvanced();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetItemTransaction Method

CSharpPublicApiExampleProgramGetItemTransaction Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetItemTransaction()
Public Function GetItemTransaction As Task(Of Integer)
public:
Task<int>^ GetItemTransaction()
member GetItemTransaction : unit -> Task<int>

public Task<int> GetItemTransaction()
function GetItemTransaction();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetItemTransactions Method

CSharpPublicApiExampleProgramGetItemTransactions Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> GetItemTransactions()
Private Function GetItemTransactions As Task(Of Integer)
private:
Task<int>^ GetItemTransactions()
private member GetItemTransactions : unit -> Task<int>

private Task<int> GetItemTransactions()
function GetItemTransactions();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetKitItemSample Method

CSharpPublicApiExampleProgramGetKitItemSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetKitItemSample()
Public Function GetKitItemSample As Task(Of Integer)
public:
Task<int>^ GetKitItemSample()
member GetKitItemSample : unit -> Task<int>

public Task<int> GetKitItemSample()
function GetKitItemSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetNonInventoryItems Method

CSharpPublicApiExampleProgramGetNonInventoryItems Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetNonInventoryItems(
    string searchItem
)
Public Function GetNonInventoryItems (
    searchItem As String
) As Task(Of Integer)
public:
Task<int>^ GetNonInventoryItems(
    String^ searchItem
)
member GetNonInventoryItems :
        searchItem : string -> Task<int>

public Task<int> GetNonInventoryItems(
    String searchItem
)
function GetNonInventoryItems(searchItem);

Parameters

searchItem
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetServerInfo Method

CSharpPublicApiExampleProgramGetServerInfo Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<string> GetServerInfo()
Public Function GetServerInfo As Task(Of String)
public:
Task<String^>^ GetServerInfo()
member GetServerInfo : unit -> Task<string>

public Task<String> GetServerInfo()
function GetServerInfo();

Return Value

Type: Task String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetServiceItemSample Method

CSharpPublicApiExampleProgramGetServiceItemSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> GetServiceItemSample(
    string searchItem
)
Public Function GetServiceItemSample (
    searchItem As String
) As Task(Of Integer)
public:
Task<int>^ GetServiceItemSample(
    String^ searchItem
)
member GetServiceItemSample :
        searchItem : string -> Task<int>

public Task<int> GetServiceItemSample(
    String searchItem
)
function GetServiceItemSample(searchItem);

Parameters

searchItem
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.GetValue(T) Method

CSharpPublicApiExampleProgramGetValueT Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public T GetValue<T>(
    string[] values,
    int column
)

Public Function GetValue(Of T) (
    values As String(),
    column As Integer
) As T
public:
generic<typename T>
T GetValue(
    array<String^>^ values,
    int column
)
member GetValue :
        values : string[] *
        column : int -> 'T

J# supports the use of generic APIs, but not the declaration of new ones.
JavaScript does not support generic types or methods.

Parameters

values
Type: SystemString
column
Type: SystemInt32

Type Parameters

T

Return Value

Type: T
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.Main Method

CSharpPublicApiExampleProgramMain Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static int Main(
    string[] args
)
Private Shared Function Main (
    args As String()
) As Integer
private:
static int Main(
    array<String^>^ args
)
private static member Main :
        args : string[] -> int

private static int Main(
    String[] args
)
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.Main = function(args);

Parameters

args
Type: SystemString

Return Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.Manufacturers Method

CSharpPublicApiExampleProgramManufacturers Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> Manufacturers()
Public Function Manufacturers As Task(Of Integer)
public:
Task<int>^ Manufacturers()
member Manufacturers : unit -> Task<int>

public Task<int> Manufacturers()
function Manufacturers();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.ManufacturersSample Method

CSharpPublicApiExampleProgramManufacturersSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> ManufacturersSample()
Private Function ManufacturersSample As Task(Of Integer)
private:
Task<int>^ ManufacturersSample()
private member ManufacturersSample : unit -> Task<int>

private Task<int> ManufacturersSample()
function ManufacturersSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.MoveAllItemsInFile Method

CSharpPublicApiExampleProgramMoveAllItemsInFile Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> MoveAllItemsInFile(
    string csvFilePath
)
Public Function MoveAllItemsInFile (
    csvFilePath As String
) As Task(Of Integer)
public:
Task<int>^ MoveAllItemsInFile(
    String^ csvFilePath
)
member MoveAllItemsInFile :
        csvFilePath : string -> Task<int>

public Task<int> MoveAllItemsInFile(
    String csvFilePath
)
function MoveAllItemsInFile(csvFilePath);

Parameters

csvFilePath
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.POSTApi Method

CSharpPublicApiExampleProgramPOSTApi Method

Overload List
 | Name | Description
Public method | POSTApi(String, ListCustomerModelInfo) |
Public method | POSTApi(String, ListManufacturerModelInfo) |
Public method | POSTApi(String, ListVendorModelInfo) |
Top
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.POSTApi Method (String, List(CustomerModelInfo))

CSharpPublicApiExampleProgramPOSTApi Method (String, ListCustomerModelInfo)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public HttpResponseMessage POSTApi(
    string url,
    List<CustomerModelInfo> data
)
Public Function POSTApi (
    url As String,
    data As List(Of CustomerModelInfo)
) As HttpResponseMessage
public:
HttpResponseMessage^ POSTApi(
    String^ url,
    List<CustomerModelInfo^>^ data
)
member POSTApi :
        url : string *
        data : List<CustomerModelInfo> -> HttpResponseMessage

public HttpResponseMessage POSTApi(
    String url,
    List<CustomerModelInfo> data
)
function POSTApi(url, data);

Parameters

url
Type: SystemString
data
Type: System.Collections.GenericList CustomerModelInfo

Return Value

Type: HttpResponseMessage
See Also

Reference

CSharpPublicApiExampleProgram Class
POSTApi Overload


CSharpPublicApiExampleProgram.POSTApi Method (String, List(ManufacturerModelInfo))

CSharpPublicApiExampleProgramPOSTApi Method (String, ListManufacturerModelInfo)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public HttpResponseMessage POSTApi(
    string url,
    List<ManufacturerModelInfo> data
)
Public Function POSTApi (
    url As String,
    data As List(Of ManufacturerModelInfo)
) As HttpResponseMessage
public:
HttpResponseMessage^ POSTApi(
    String^ url,
    List<ManufacturerModelInfo^>^ data
)
member POSTApi :
        url : string *
        data : List<ManufacturerModelInfo> -> HttpResponseMessage

public HttpResponseMessage POSTApi(
    String url,
    List<ManufacturerModelInfo> data
)
function POSTApi(url, data);

Parameters

url
Type: SystemString
data
Type: System.Collections.GenericList ManufacturerModelInfo

Return Value

Type: HttpResponseMessage
See Also

Reference

CSharpPublicApiExampleProgram Class
POSTApi Overload


CSharpPublicApiExampleProgram.POSTApi Method (String, List(VendorModelInfo))

CSharpPublicApiExampleProgramPOSTApi Method (String, ListVendorModelInfo)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public HttpResponseMessage POSTApi(
    string url,
    List<VendorModelInfo> data
)
Public Function POSTApi (
    url As String,
    data As List(Of VendorModelInfo)
) As HttpResponseMessage
public:
HttpResponseMessage^ POSTApi(
    String^ url,
    List<VendorModelInfo^>^ data
)
member POSTApi :
        url : string *
        data : List<VendorModelInfo> -> HttpResponseMessage

public HttpResponseMessage POSTApi(
    String url,
    List<VendorModelInfo> data
)
function POSTApi(url, data);

Parameters

url
Type: SystemString
data
Type: System.Collections.GenericList VendorModelInfo

Return Value

Type: HttpResponseMessage
See Also

Reference

CSharpPublicApiExampleProgram Class
POSTApi Overload


CSharpPublicApiExampleProgram.PurchaseOrderAdvancedInfoSearchItem Method

CSharpPublicApiExampleProgramPurchaseOrderAdvancedInfoSearchItem Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> PurchaseOrderAdvancedInfoSearchItem(
    string[] item
)
Public Function PurchaseOrderAdvancedInfoSearchItem (
    item As String()
) As Task(Of Integer)
public:
Task<int>^ PurchaseOrderAdvancedInfoSearchItem(
    array<String^>^ item
)
member PurchaseOrderAdvancedInfoSearchItem :
        item : string[] -> Task<int>

public Task<int> PurchaseOrderAdvancedInfoSearchItem(
    String[] item
)
function PurchaseOrderAdvancedInfoSearchItem(item);

Parameters

item
Type: SystemString

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.RunAllExamples Method

CSharpPublicApiExampleProgramRunAllExamples Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task RunAllExamples()
Public Function RunAllExamples As Task
public:
Task^ RunAllExamples()
member RunAllExamples : unit -> Task

public Task RunAllExamples()
function RunAllExamples();

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.RunSitesLocationsDemo Method

CSharpPublicApiExampleProgramRunSitesLocationsDemo Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> RunSitesLocationsDemo()
Private Function RunSitesLocationsDemo As Task(Of Integer)
private:
Task<int>^ RunSitesLocationsDemo()
private member RunSitesLocationsDemo : unit -> Task<int>

private Task<int> RunSitesLocationsDemo()
function RunSitesLocationsDemo();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SaveCustomerTest Method

CSharpPublicApiExampleProgramSaveCustomerTest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task SaveCustomerTest()
Private Function SaveCustomerTest As Task
private:
Task^ SaveCustomerTest()
private member SaveCustomerTest : unit -> Task

private Task SaveCustomerTest()
function SaveCustomerTest();

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SaveManufacturerTest Method

CSharpPublicApiExampleProgramSaveManufacturerTest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task SaveManufacturerTest()
Private Function SaveManufacturerTest As Task
private:
Task^ SaveManufacturerTest()
private member SaveManufacturerTest : unit -> Task

private Task SaveManufacturerTest()
function SaveManufacturerTest();

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SaveSupplierTest Method

CSharpPublicApiExampleProgramSaveSupplierTest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task SaveSupplierTest()
Private Function SaveSupplierTest As Task
private:
Task^ SaveSupplierTest()
private member SaveSupplierTest : unit -> Task

private Task SaveSupplierTest()
function SaveSupplierTest();

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleCodeTaxCodeCRUDTest Method

CSharpPublicApiExampleProgramSimpleCodeTaxCodeCRUDTest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SimpleCodeTaxCodeCRUDTest()
Private Function SimpleCodeTaxCodeCRUDTest As Task(Of Integer)
private:
Task<int>^ SimpleCodeTaxCodeCRUDTest()
private member SimpleCodeTaxCodeCRUDTest : unit -> Task<int>

private Task<int> SimpleCodeTaxCodeCRUDTest()
function SimpleCodeTaxCodeCRUDTest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleCodeTaxCodeCRUDTestLatest Method

CSharpPublicApiExampleProgramSimpleCodeTaxCodeCRUDTestLatest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> SimpleCodeTaxCodeCRUDTestLatest()
Public Function SimpleCodeTaxCodeCRUDTestLatest As Task(Of Integer)
public:
Task<int>^ SimpleCodeTaxCodeCRUDTestLatest()
member SimpleCodeTaxCodeCRUDTestLatest : unit -> Task<int>

public Task<int> SimpleCodeTaxCodeCRUDTestLatest()
function SimpleCodeTaxCodeCRUDTestLatest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteLocationSample Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteLocationSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SimpleCreateReadUpdateDeleteLocationSample()
Private Function SimpleCreateReadUpdateDeleteLocationSample As Task(Of Integer)
private:
Task<int>^ SimpleCreateReadUpdateDeleteLocationSample()
private member SimpleCreateReadUpdateDeleteLocationSample : unit -> Task<int>

private Task<int> SimpleCreateReadUpdateDeleteLocationSample()
function SimpleCreateReadUpdateDeleteLocationSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteSearchLocation Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteSearchLocation Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> SimpleCreateReadUpdateDeleteSearchLocation()
Public Function SimpleCreateReadUpdateDeleteSearchLocation As Task(Of Integer)
public:
Task<int>^ SimpleCreateReadUpdateDeleteSearchLocation()
member SimpleCreateReadUpdateDeleteSearchLocation : unit -> Task<int>

public Task<int> SimpleCreateReadUpdateDeleteSearchLocation()
function SimpleCreateReadUpdateDeleteSearchLocation();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteSearchSite Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteSearchSite Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> SimpleCreateReadUpdateDeleteSearchSite()
Public Function SimpleCreateReadUpdateDeleteSearchSite As Task(Of Integer)
public:
Task<int>^ SimpleCreateReadUpdateDeleteSearchSite()
member SimpleCreateReadUpdateDeleteSearchSite : unit -> Task<int>

public Task<int> SimpleCreateReadUpdateDeleteSearchSite()
function SimpleCreateReadUpdateDeleteSearchSite();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteSiteSample Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteSiteSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SimpleCreateReadUpdateDeleteSiteSample()
Private Function SimpleCreateReadUpdateDeleteSiteSample As Task(Of Integer)
private:
Task<int>^ SimpleCreateReadUpdateDeleteSiteSample()
private member SimpleCreateReadUpdateDeleteSiteSample : unit -> Task<int>

private Task<int> SimpleCreateReadUpdateDeleteSiteSample()
function SimpleCreateReadUpdateDeleteSiteSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleTransactionsTest Method

CSharpPublicApiExampleProgramSimpleTransactionsTest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SimpleTransactionsTest()
Private Function SimpleTransactionsTest As Task(Of Integer)
private:
Task<int>^ SimpleTransactionsTest()
private member SimpleTransactionsTest : unit -> Task<int>

private Task<int> SimpleTransactionsTest()
function SimpleTransactionsTest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SimpleTransactionsTestLatest Method

CSharpPublicApiExampleProgramSimpleTransactionsTestLatest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SimpleTransactionsTestLatest()
Private Function SimpleTransactionsTestLatest As Task(Of Integer)
private:
Task<int>^ SimpleTransactionsTestLatest()
private member SimpleTransactionsTestLatest : unit -> Task<int>

private Task<int> SimpleTransactionsTestLatest()
function SimpleTransactionsTestLatest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SiteCustomFieldSample Method

CSharpPublicApiExampleProgramSiteCustomFieldSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SiteCustomFieldSample()
Private Function SiteCustomFieldSample As Task(Of Integer)
private:
Task<int>^ SiteCustomFieldSample()
private member SiteCustomFieldSample : unit -> Task<int>

private Task<int> SiteCustomFieldSample()
function SiteCustomFieldSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.StreamInventoryAdvanced Method

CSharpPublicApiExampleProgramStreamInventoryAdvanced Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> StreamInventoryAdvanced()
Private Function StreamInventoryAdvanced As Task(Of Integer)
private:
Task<int>^ StreamInventoryAdvanced()
private member StreamInventoryAdvanced : unit -> Task<int>

private Task<int> StreamInventoryAdvanced()
function StreamInventoryAdvanced();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.Suppliers Method

CSharpPublicApiExampleProgramSuppliers Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> Suppliers()
Public Function Suppliers As Task(Of Integer)
public:
Task<int>^ Suppliers()
member Suppliers : unit -> Task<int>

public Task<int> Suppliers()
function Suppliers();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.SuppliersSample Method

CSharpPublicApiExampleProgramSuppliersSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SuppliersSample()
Private Function SuppliersSample As Task(Of Integer)
private:
Task<int>^ SuppliersSample()
private member SuppliersSample : unit -> Task<int>

private Task<int> SuppliersSample()
function SuppliersSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.TrackbyTransactionsTest Method

CSharpPublicApiExampleProgramTrackbyTransactionsTest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> TrackbyTransactionsTest()
Private Function TrackbyTransactionsTest As Task(Of Integer)
private:
Task<int>^ TrackbyTransactionsTest()
private member TrackbyTransactionsTest : unit -> Task<int>

private Task<int> TrackbyTransactionsTest()
function TrackbyTransactionsTest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.TrackbyTransactionTest Method

CSharpPublicApiExampleProgramTrackbyTransactionTest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> TrackbyTransactionTest()
Public Function TrackbyTransactionTest As Task(Of Integer)
public:
Task<int>^ TrackbyTransactionTest()
member TrackbyTransactionTest : unit -> Task<int>

public Task<int> TrackbyTransactionTest()
function TrackbyTransactionTest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.TransactionHistoryNotesAsync Method

CSharpPublicApiExampleProgramTransactionHistoryNotesAsync Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> TransactionHistoryNotesAsync()
Private Function TransactionHistoryNotesAsync As Task(Of Integer)
private:
Task<int>^ TransactionHistoryNotesAsync()
private member TransactionHistoryNotesAsync : unit -> Task<int>

private Task<int> TransactionHistoryNotesAsync()
function TransactionHistoryNotesAsync();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UpdateCustomersSample Method

CSharpPublicApiExampleProgramUpdateCustomersSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UpdateCustomersSample()
Private Function UpdateCustomersSample As Task(Of Integer)
private:
Task<int>^ UpdateCustomersSample()
private member UpdateCustomersSample : unit -> Task<int>

private Task<int> UpdateCustomersSample()
function UpdateCustomersSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UpdateManufacturersSample Method

CSharpPublicApiExampleProgramUpdateManufacturersSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UpdateManufacturersSample()
Private Function UpdateManufacturersSample As Task(Of Integer)
private:
Task<int>^ UpdateManufacturersSample()
private member UpdateManufacturersSample : unit -> Task<int>

private Task<int> UpdateManufacturersSample()
function UpdateManufacturersSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UpdatePurchaseOrderSample Method

CSharpPublicApiExampleProgramUpdatePurchaseOrderSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> UpdatePurchaseOrderSample()
Public Function UpdatePurchaseOrderSample As Task(Of Integer)
public:
Task<int>^ UpdatePurchaseOrderSample()
member UpdatePurchaseOrderSample : unit -> Task<int>

public Task<int> UpdatePurchaseOrderSample()
function UpdatePurchaseOrderSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UpdateSuppliersSample Method

CSharpPublicApiExampleProgramUpdateSuppliersSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UpdateSuppliersSample()
Private Function UpdateSuppliersSample As Task(Of Integer)
private:
Task<int>^ UpdateSuppliersSample()
private member UpdateSuppliersSample : unit -> Task<int>

private Task<int> UpdateSuppliersSample()
function UpdateSuppliersSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UploadAttachmentForDifferentFormsSample Method

CSharpPublicApiExampleProgramUploadAttachmentForDifferentFormsSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UploadAttachmentForDifferentFormsSample()
Private Function UploadAttachmentForDifferentFormsSample As Task(Of Integer)
private:
Task<int>^ UploadAttachmentForDifferentFormsSample()
private member UploadAttachmentForDifferentFormsSample : unit -> Task<int>

private Task<int> UploadAttachmentForDifferentFormsSample()
function UploadAttachmentForDifferentFormsSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UploadAttachmentForDifferentFormsSampleLatest Method

CSharpPublicApiExampleProgramUploadAttachmentForDifferentFormsSampleLatest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> UploadAttachmentForDifferentFormsSampleLatest()
Public Function UploadAttachmentForDifferentFormsSampleLatest As Task(Of Integer)
public:
Task<int>^ UploadAttachmentForDifferentFormsSampleLatest()
member UploadAttachmentForDifferentFormsSampleLatest : unit -> Task<int>

public Task<int> UploadAttachmentForDifferentFormsSampleLatest()
function UploadAttachmentForDifferentFormsSampleLatest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UploadAttachmentOnServerSample Method

CSharpPublicApiExampleProgramUploadAttachmentOnServerSample Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UploadAttachmentOnServerSample()
Private Function UploadAttachmentOnServerSample As Task(Of Integer)
private:
Task<int>^ UploadAttachmentOnServerSample()
private member UploadAttachmentOnServerSample : unit -> Task<int>

private Task<int> UploadAttachmentOnServerSample()
function UploadAttachmentOnServerSample();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UploadAttachmentOnServerSampleLatest Method

CSharpPublicApiExampleProgramUploadAttachmentOnServerSampleLatest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> UploadAttachmentOnServerSampleLatest()
Public Function UploadAttachmentOnServerSampleLatest As Task(Of Integer)
public:
Task<int>^ UploadAttachmentOnServerSampleLatest()
member UploadAttachmentOnServerSampleLatest : unit -> Task<int>

public Task<int> UploadAttachmentOnServerSampleLatest()
function UploadAttachmentOnServerSampleLatest();

Return Value

Type: Task Int32
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UploadFile Method

CSharpPublicApiExampleProgramUploadFile Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task UploadFile(
    string urlString,
    string fileToUpload
)
Private Function UploadFile (
    urlString As String,
    fileToUpload As String
) As Task
private:
Task^ UploadFile(
    String^ urlString,
    String^ fileToUpload
)
private member UploadFile :
        urlString : string *
        fileToUpload : string -> Task

private Task UploadFile(
    String urlString,
    String fileToUpload
)
function UploadFile(urlString, fileToUpload);

Parameters

urlString
Type: SystemString
fileToUpload
Type: SystemString

Return Value

Type: Task
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.UploadFileLatest Method

CSharpPublicApiExampleProgramUploadFileLatest Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<List<string>> UploadFileLatest(
    string urlString,
    string fileToUpload
)
Private Function UploadFileLatest (
    urlString As String,
    fileToUpload As String
) As Task(Of List(Of String))
private:
Task<List<String^>^>^ UploadFileLatest(
    String^ urlString,
    String^ fileToUpload
)
private member UploadFileLatest :
        urlString : string *
        fileToUpload : string -> Task<List<string>>

private Task<List<String>> UploadFileLatest(
    String urlString,
    String fileToUpload
)
function UploadFileLatest(urlString, fileToUpload);

Parameters

urlString
Type: SystemString
fileToUpload
Type: SystemString

Return Value

Type: Task List String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.Usage Method

CSharpPublicApiExampleProgramUsage Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static void Usage()
Private Shared Sub Usage
private:
static void Usage()
private static member Usage : unit -> unit

private static void Usage()
Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.Usage = function();
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.WriteInputData Method

CSharpPublicApiExampleProgramWriteInputData Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private void WriteInputData(
    string sStatus,
    string rawRecord,
    string sReason
)
Private Sub WriteInputData (
    sStatus As String,
    rawRecord As String,
    sReason As String
)
private:
void WriteInputData(
    String^ sStatus,
    String^ rawRecord,
    String^ sReason
)
private member WriteInputData :
        sStatus : string *
        rawRecord : string *
        sReason : string -> unit

private void WriteInputData(
    String sStatus,
    String rawRecord,
    String sReason
)
function WriteInputData(sStatus, rawRecord, sReason);

Parameters

sStatus
Type: SystemString
rawRecord
Type: SystemString
sReason
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.WriteOutputLine Method

CSharpPublicApiExampleProgramWriteOutputLine Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private void WriteOutputLine(
    string sStatus,
    ItemMoveTransactionModel re,
    string sReason
)
Private Sub WriteOutputLine (
    sStatus As String,
    re As ItemMoveTransactionModel,
    sReason As String
)
private:
void WriteOutputLine(
    String^ sStatus,
    ItemMoveTransactionModel^ re,
    String^ sReason
)
private member WriteOutputLine :
        sStatus : string *
        re : ItemMoveTransactionModel *
        sReason : string -> unit

private void WriteOutputLine(
    String sStatus,
    ItemMoveTransactionModel re,
    String sReason
)
function WriteOutputLine(sStatus, re, sReason);

Parameters

sStatus
Type: SystemString
re
Type: ItemMoveTransactionModel
sReason
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram Fields

Fields
 | Name | Description
Private field | _guidString |
Private field | _initializer |
Private field | bWriteOutputHeader |
 | DCF_SHIPMENT_NOT_RECEIVED |
 | DCF_SHIPMENT_SHIPPED |
Private field | Writer |
Top
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram._guidString Field

CSharpPublicApiExampleProgram_guidString Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _guidString
Private _guidString As String
private:
String^ _guidString
val mutable private _guidString: string
private String _guidString
var _guidString

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram._initializer Field

CSharpPublicApiExampleProgram_initializer Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private HttpClientInitializer _initializer
Private _initializer As HttpClientInitializer
private:
HttpClientInitializer^ _initializer
val mutable private _initializer: HttpClientInitializer
private HttpClientInitializer _initializer
var _initializer

Field Value

Type: HttpClientInitializer
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.bWriteOutputHeader Field

CSharpPublicApiExampleProgrambWriteOutputHeader Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool bWriteOutputHeader
Private bWriteOutputHeader As Boolean
private:
bool bWriteOutputHeader
val mutable private bWriteOutputHeader: bool
private boolean bWriteOutputHeader
var bWriteOutputHeader

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.DCF_SHIPMENT_NOT_RECEIVED Field

CSharpPublicApiExampleProgramDCF_SHIPMENT_NOT_RECEIVED Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private const string DCF_SHIPMENT_NOT_RECEIVED = "Shipment not Received"
Private Const DCF_SHIPMENT_NOT_RECEIVED As String = "Shipment not Received"
private:
literal String^ DCF_SHIPMENT_NOT_RECEIVED = "Shipment not Received"
static val mutable private DCF_SHIPMENT_NOT_RECEIVED: string
private static final String DCF_SHIPMENT_NOT_RECEIVED
var Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.DCF_SHIPMENT_NOT_RECEIVED

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.DCF_SHIPMENT_SHIPPED Field

CSharpPublicApiExampleProgramDCF_SHIPMENT_SHIPPED Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private const string DCF_SHIPMENT_SHIPPED = "Shipment Shipped"
Private Const DCF_SHIPMENT_SHIPPED As String = "Shipment Shipped"
private:
literal String^ DCF_SHIPMENT_SHIPPED = "Shipment Shipped"
static val mutable private DCF_SHIPMENT_SHIPPED: string
private static final String DCF_SHIPMENT_SHIPPED
var Wasp.Cloud.Inventory.Example.CSharpPublicApiExampleProgram.DCF_SHIPMENT_SHIPPED

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.Writer Field

CSharpPublicApiExampleProgramWriter Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private TextWriter Writer
Private Writer As TextWriter
private:
TextWriter^ Writer
val mutable private Writer: TextWriter
private TextWriter Writer
var Writer

Field Value

Type: TextWriter
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients Class

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExamplePublicApiClientBase
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramApiItemsPublicApiClients

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ApiItemsPublicApiClients : PublicApiClientBase
Public Class ApiItemsPublicApiClients
    Inherits PublicApiClientBase
public ref class ApiItemsPublicApiClients : public PublicApiClientBase
type ApiItemsPublicApiClients =
    class
        inherit PublicApiClientBase
    end
public class ApiItemsPublicApiClients extends PublicApiClientBase
Wasp.Cloud.Inventory.Example.ApiItemsPublicApiClients = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ApiItemsPublicApiClients',
    Wasp.Cloud.Inventory.Example.PublicApiClientBase);

The CSharpPublicApiExampleProgramApiItemsPublicApiClients type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramApiItemsPublicApiClients | Initializes a new instance of the CSharpPublicApiExampleProgramApiItemsPublicApiClients class
Top
Properties
 | Name | Description
Public property | BaseUrl |
Top
Methods
 | Name | Description
Protected method | CreateHttpClientAsync | (Inherited from PublicApiClientBase.)
Protected method | CreateHttpRequestMessageAsync | (Inherited from PublicApiClientBase.)
Public method | CreateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, String) |
Public method | CreateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken, String) |
Public method | CreateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, String) |
Public method | CreateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken, String) |
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, String) |
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken, String) |
Public method | DecodeAsyncT | (Inherited from PublicApiClientBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssemblyItemAsync(String) |
Public method | GetAssemblyItemAsync(String, CancellationToken) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInventoryItemAsync(String) |
Public method | GetInventoryItemAsync(String, CancellationToken) |
Public method | GetItemsByNumberAsync(IEnumerableString) |
Public method | GetItemsByNumberAsync(IEnumerableString, CancellationToken) |
Public method | GetKitItemAsync(String) |
Public method | GetKitItemAsync(String, CancellationToken) |
Public method | GetNonInventoryItemAsync(String) |
Public method | GetNonInventoryItemAsync(String, CancellationToken) |
Public method | GetServiceItemAsync(String) |
Public method | GetServiceItemAsync(String, CancellationToken) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InventorySearchAsync(InventorySearchParameters) |
Public method | InventorySearchAsync(InventorySearchParameters, CancellationToken) |
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters) |
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) |
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters) |
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters, CancellationToken) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) | (Inherited from PublicApiClientBase.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) | (Inherited from PublicApiClientBase.)
Protected method | ProcessResponse | (Inherited from PublicApiClientBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo) |
Public method | UpdateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken) |
Protected method | UpdateJsonSerializerSettings | (Inherited from PublicApiClientBase.)
Public method | UpdateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos) |
Public method | UpdateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken) |
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo) |
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken) |
Top
Fields
 | Name | Description
Private field | _baseUrl |
Private field | _settings |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients Constructor

CSharpPublicApiExampleProgramApiItemsPublicApiClients Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramApiItemsPublicApiClients class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ApiItemsPublicApiClients(
    string baseUrl
)
Public Sub New (
    baseUrl As String
)
public:
ApiItemsPublicApiClients(
    String^ baseUrl
)
new :
        baseUrl : string -> ApiItemsPublicApiClients
public ApiItemsPublicApiClients(
    String baseUrl
)
Wasp.Cloud.Inventory.Example.ApiItemsPublicApiClients = function(baseUrl);

Parameters

baseUrl
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


ApiItemsPublicApiClients Properties

The CSharpPublicApiExampleProgramApiItemsPublicApiClients type exposes the following members.

Properties
 | Name | Description
Public property | BaseUrl |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.BaseUrl Property

CSharpPublicApiExampleProgramApiItemsPublicApiClientsBaseUrl Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string BaseUrl { get; set; }
Public Property BaseUrl As String
    Get
    Set
public:
property String^ BaseUrl {
    String^ get ();
    void set (String^ value);
}
member BaseUrl : string with get, set

/** @property */
public String get_BaseUrl()
/** @property */
public void set_BaseUrl(String value)

function get_BaseUrl();
function set_BaseUrl(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


ApiItemsPublicApiClients Methods

The CSharpPublicApiExampleProgramApiItemsPublicApiClients type exposes the following members.

Methods
 | Name | Description
Protected method | CreateHttpClientAsync | (Inherited from PublicApiClientBase.)
Protected method | CreateHttpRequestMessageAsync | (Inherited from PublicApiClientBase.)
Public method | CreateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, String) |
Public method | CreateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken, String) |
Public method | CreateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, String) |
Public method | CreateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken, String) |
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, String) |
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken, String) |
Public method | DecodeAsyncT | (Inherited from PublicApiClientBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssemblyItemAsync(String) |
Public method | GetAssemblyItemAsync(String, CancellationToken) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInventoryItemAsync(String) |
Public method | GetInventoryItemAsync(String, CancellationToken) |
Public method | GetItemsByNumberAsync(IEnumerableString) |
Public method | GetItemsByNumberAsync(IEnumerableString, CancellationToken) |
Public method | GetKitItemAsync(String) |
Public method | GetKitItemAsync(String, CancellationToken) |
Public method | GetNonInventoryItemAsync(String) |
Public method | GetNonInventoryItemAsync(String, CancellationToken) |
Public method | GetServiceItemAsync(String) |
Public method | GetServiceItemAsync(String, CancellationToken) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InventorySearchAsync(InventorySearchParameters) |
Public method | InventorySearchAsync(InventorySearchParameters, CancellationToken) |
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters) |
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) |
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters) |
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters, CancellationToken) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) | (Inherited from PublicApiClientBase.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) | (Inherited from PublicApiClientBase.)
Protected method | ProcessResponse | (Inherited from PublicApiClientBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo) |
Public method | UpdateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken) |
Protected method | UpdateJsonSerializerSettings | (Inherited from PublicApiClientBase.)
Public method | UpdateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos) |
Public method | UpdateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken) |
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo) |
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


ApiItemsPublicApiClients.CreateInventoryItemAsync Method

ApiItemsPublicApiClientsCreateInventoryItemAsync Method

Overload List
 | Name | Description
Public method | CreateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, String) |
Public method | CreateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken, String) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.CreateInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemInventorysInfo), String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsCreateInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> CreateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems,
    string apiType
)
Public Function CreateInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemInventorysInfo),
    apiType As String
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ CreateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo^>^ listItems,
    String^ apiType
)
member CreateInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> *
        apiType : string -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> CreateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems,
    String apiType
)
function CreateInventoryItemAsync(listItems, apiType);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemInventorysInfo
apiType
Type: SystemString

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
CreateInventoryItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.CreateInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemInventorysInfo), CancellationToken, String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsCreateInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> CreateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems,
    CancellationToken cancellationToken,
    string apiType
)
Public Function CreateInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemInventorysInfo),
    cancellationToken As CancellationToken,
    apiType As String
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ CreateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo^>^ listItems,
    CancellationToken cancellationToken,
    String^ apiType
)
member CreateInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> *
        cancellationToken : CancellationToken *
        apiType : string -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> CreateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems,
    CancellationToken cancellationToken,
    String apiType
)
function CreateInventoryItemAsync(listItems, cancellationToken, apiType);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemInventorysInfo
cancellationToken
Type: System.ThreadingCancellationToken
apiType
Type: SystemString

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
CreateInventoryItemAsync Overload


ApiItemsPublicApiClients.CreateNonInventoryItemAsync Method

ApiItemsPublicApiClientsCreateNonInventoryItemAsync Method

Overload List
 | Name | Description
Public method | CreateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, String) |
Public method | CreateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken, String) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.CreateNonInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemNonInventoryInfos), String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsCreateNonInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> CreateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems,
    string testcaseType
)
Public Function CreateNonInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemNonInventoryInfos),
    testcaseType As String
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ CreateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos^>^ listItems,
    String^ testcaseType
)
member CreateNonInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> *
        testcaseType : string -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> CreateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems,
    String testcaseType
)
function CreateNonInventoryItemAsync(listItems, testcaseType);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemNonInventoryInfos
testcaseType
Type: SystemString

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
CreateNonInventoryItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.CreateNonInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemNonInventoryInfos), CancellationToken, String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsCreateNonInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> CreateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems,
    CancellationToken cancellationToken,
    string testcaseType
)
Public Function CreateNonInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemNonInventoryInfos),
    cancellationToken As CancellationToken,
    testcaseType As String
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ CreateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos^>^ listItems,
    CancellationToken cancellationToken,
    String^ testcaseType
)
member CreateNonInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> *
        cancellationToken : CancellationToken *
        testcaseType : string -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> CreateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems,
    CancellationToken cancellationToken,
    String testcaseType
)
function CreateNonInventoryItemAsync(listItems, cancellationToken, testcaseType);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemNonInventoryInfos
cancellationToken
Type: System.ThreadingCancellationToken
testcaseType
Type: SystemString

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
CreateNonInventoryItemAsync Overload


ApiItemsPublicApiClients.CreateServiceItemAsync Method

ApiItemsPublicApiClientsCreateServiceItemAsync Method

Overload List
 | Name | Description
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, String) |
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken, String) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.CreateServiceItemAsync Method (IEnumerable(ItemServiceInfo), String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsCreateServiceItemAsync Method (IEnumerableItemServiceInfo, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> CreateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems,
    string testcaseType
)
Public Function CreateServiceItemAsync (
    listItems As IEnumerable(Of ItemServiceInfo),
    testcaseType As String
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ CreateServiceItemAsync(
    IEnumerable<ItemServiceInfo^>^ listItems,
    String^ testcaseType
)
member CreateServiceItemAsync :
        listItems : IEnumerable<ItemServiceInfo> *
        testcaseType : string -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> CreateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems,
    String testcaseType
)
function CreateServiceItemAsync(listItems, testcaseType);

Parameters

listItems
Type: System.Collections.GenericIEnumerable ItemServiceInfo
testcaseType
Type: SystemString

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
CreateServiceItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.CreateServiceItemAsync Method (IEnumerable(ItemServiceInfo), CancellationToken, String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsCreateServiceItemAsync Method (IEnumerableItemServiceInfo, CancellationToken, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> CreateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems,
    CancellationToken cancellationToken,
    string testcaseType
)
Public Function CreateServiceItemAsync (
    listItems As IEnumerable(Of ItemServiceInfo),
    cancellationToken As CancellationToken,
    testcaseType As String
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ CreateServiceItemAsync(
    IEnumerable<ItemServiceInfo^>^ listItems,
    CancellationToken cancellationToken,
    String^ testcaseType
)
member CreateServiceItemAsync :
        listItems : IEnumerable<ItemServiceInfo> *
        cancellationToken : CancellationToken *
        testcaseType : string -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> CreateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems,
    CancellationToken cancellationToken,
    String testcaseType
)
function CreateServiceItemAsync(listItems, cancellationToken, testcaseType);

Parameters

listItems
Type: System.Collections.GenericIEnumerable ItemServiceInfo
cancellationToken
Type: System.ThreadingCancellationToken
testcaseType
Type: SystemString

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
CreateServiceItemAsync Overload


ApiItemsPublicApiClients.GetAssemblyItemAsync Method

ApiItemsPublicApiClientsGetAssemblyItemAsync Method

Overload List
 | Name | Description
Public method | GetAssemblyItemAsync(String) |
Public method | GetAssemblyItemAsync(String, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetAssemblyItemAsync Method (String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetAssemblyItemAsync Method (String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemAssemblyInfo> GetAssemblyItemAsync(
    string itemNumber
)
Public Function GetAssemblyItemAsync (
    itemNumber As String
) As Task(Of WaspResultOfItemAssemblyInfo)
public:
Task<WaspResultOfItemAssemblyInfo^>^ GetAssemblyItemAsync(
    String^ itemNumber
)
member GetAssemblyItemAsync :
        itemNumber : string -> Task<WaspResultOfItemAssemblyInfo>

public Task<WaspResultOfItemAssemblyInfo> GetAssemblyItemAsync(
    String itemNumber
)
function GetAssemblyItemAsync(itemNumber);

Parameters

itemNumber
Type: SystemString

Return Value

Type: Task WaspResultOfItemAssemblyInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetAssemblyItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetAssemblyItemAsync Method (String, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetAssemblyItemAsync Method (String, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemAssemblyInfo> GetAssemblyItemAsync(
    string itemNumber,
    CancellationToken cancellationToken
)
Public Function GetAssemblyItemAsync (
    itemNumber As String,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfItemAssemblyInfo)
public:
Task<WaspResultOfItemAssemblyInfo^>^ GetAssemblyItemAsync(
    String^ itemNumber,
    CancellationToken cancellationToken
)
member GetAssemblyItemAsync :
        itemNumber : string *
        cancellationToken : CancellationToken -> Task<WaspResultOfItemAssemblyInfo>

public Task<WaspResultOfItemAssemblyInfo> GetAssemblyItemAsync(
    String itemNumber,
    CancellationToken cancellationToken
)
function GetAssemblyItemAsync(itemNumber, cancellationToken);

Parameters

itemNumber
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfItemAssemblyInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetAssemblyItemAsync Overload


ApiItemsPublicApiClients.GetInventoryItemAsync Method

ApiItemsPublicApiClientsGetInventoryItemAsync Method

Overload List
 | Name | Description
Public method | GetInventoryItemAsync(String) |
Public method | GetInventoryItemAsync(String, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetInventoryItemAsync Method (String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetInventoryItemAsync Method (String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemInventoryInfo> GetInventoryItemAsync(
    string itemNumber
)
Public Function GetInventoryItemAsync (
    itemNumber As String
) As Task(Of WaspResultOfItemInventoryInfo)
public:
Task<WaspResultOfItemInventoryInfo^>^ GetInventoryItemAsync(
    String^ itemNumber
)
member GetInventoryItemAsync :
        itemNumber : string -> Task<WaspResultOfItemInventoryInfo>

public Task<WaspResultOfItemInventoryInfo> GetInventoryItemAsync(
    String itemNumber
)
function GetInventoryItemAsync(itemNumber);

Parameters

itemNumber
Type: SystemString

Return Value

Type: Task WaspResultOfItemInventoryInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetInventoryItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetInventoryItemAsync Method (String, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetInventoryItemAsync Method (String, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemInventoryInfo> GetInventoryItemAsync(
    string itemNumber,
    CancellationToken cancellationToken
)
Public Function GetInventoryItemAsync (
    itemNumber As String,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfItemInventoryInfo)
public:
Task<WaspResultOfItemInventoryInfo^>^ GetInventoryItemAsync(
    String^ itemNumber,
    CancellationToken cancellationToken
)
member GetInventoryItemAsync :
        itemNumber : string *
        cancellationToken : CancellationToken -> Task<WaspResultOfItemInventoryInfo>

public Task<WaspResultOfItemInventoryInfo> GetInventoryItemAsync(
    String itemNumber,
    CancellationToken cancellationToken
)
function GetInventoryItemAsync(itemNumber, cancellationToken);

Parameters

itemNumber
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfItemInventoryInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetInventoryItemAsync Overload


ApiItemsPublicApiClients.GetItemsByNumberAsync Method

ApiItemsPublicApiClientsGetItemsByNumberAsync Method

Overload List
 | Name | Description
Public method | GetItemsByNumberAsync(IEnumerableString) |
Public method | GetItemsByNumberAsync(IEnumerableString, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetItemsByNumberAsync Method (IEnumerable(String))

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetItemsByNumberAsync Method (IEnumerableString)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfWaspResultOfItemInfo> GetItemsByNumberAsync(
    IEnumerable<string> listItemNumbers
)
Public Function GetItemsByNumberAsync (
    listItemNumbers As IEnumerable(Of String)
) As Task(Of WaspResultOfListOfWaspResultOfItemInfo)
public:
Task<WaspResultOfListOfWaspResultOfItemInfo^>^ GetItemsByNumberAsync(
    IEnumerable<String^>^ listItemNumbers
)
member GetItemsByNumberAsync :
        listItemNumbers : IEnumerable<string> -> Task<WaspResultOfListOfWaspResultOfItemInfo>

public Task<WaspResultOfListOfWaspResultOfItemInfo> GetItemsByNumberAsync(
    IEnumerable<String> listItemNumbers
)
function GetItemsByNumberAsync(listItemNumbers);

Parameters

listItemNumbers
Type: System.Collections.GenericIEnumerable String

Return Value

Type: Task WaspResultOfListOfWaspResultOfItemInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetItemsByNumberAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetItemsByNumberAsync Method (IEnumerable(String), CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetItemsByNumberAsync Method (IEnumerableString, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfWaspResultOfItemInfo> GetItemsByNumberAsync(
    IEnumerable<string> listItemNumbers,
    CancellationToken cancellationToken
)
Public Function GetItemsByNumberAsync (
    listItemNumbers As IEnumerable(Of String),
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfListOfWaspResultOfItemInfo)
public:
Task<WaspResultOfListOfWaspResultOfItemInfo^>^ GetItemsByNumberAsync(
    IEnumerable<String^>^ listItemNumbers,
    CancellationToken cancellationToken
)
member GetItemsByNumberAsync :
        listItemNumbers : IEnumerable<string> *
        cancellationToken : CancellationToken -> Task<WaspResultOfListOfWaspResultOfItemInfo>

public Task<WaspResultOfListOfWaspResultOfItemInfo> GetItemsByNumberAsync(
    IEnumerable<String> listItemNumbers,
    CancellationToken cancellationToken
)
function GetItemsByNumberAsync(listItemNumbers, cancellationToken);

Parameters

listItemNumbers
Type: System.Collections.GenericIEnumerable String
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfListOfWaspResultOfItemInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetItemsByNumberAsync Overload


ApiItemsPublicApiClients.GetKitItemAsync Method

ApiItemsPublicApiClientsGetKitItemAsync Method

Overload List
 | Name | Description
Public method | GetKitItemAsync(String) |
Public method | GetKitItemAsync(String, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetKitItemAsync Method (String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetKitItemAsync Method (String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemKitInfo> GetKitItemAsync(
    string itemNumber
)
Public Function GetKitItemAsync (
    itemNumber As String
) As Task(Of WaspResultOfItemKitInfo)
public:
Task<WaspResultOfItemKitInfo^>^ GetKitItemAsync(
    String^ itemNumber
)
member GetKitItemAsync :
        itemNumber : string -> Task<WaspResultOfItemKitInfo>

public Task<WaspResultOfItemKitInfo> GetKitItemAsync(
    String itemNumber
)
function GetKitItemAsync(itemNumber);

Parameters

itemNumber
Type: SystemString

Return Value

Type: Task WaspResultOfItemKitInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetKitItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetKitItemAsync Method (String, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetKitItemAsync Method (String, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemKitInfo> GetKitItemAsync(
    string itemNumber,
    CancellationToken cancellationToken
)
Public Function GetKitItemAsync (
    itemNumber As String,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfItemKitInfo)
public:
Task<WaspResultOfItemKitInfo^>^ GetKitItemAsync(
    String^ itemNumber,
    CancellationToken cancellationToken
)
member GetKitItemAsync :
        itemNumber : string *
        cancellationToken : CancellationToken -> Task<WaspResultOfItemKitInfo>

public Task<WaspResultOfItemKitInfo> GetKitItemAsync(
    String itemNumber,
    CancellationToken cancellationToken
)
function GetKitItemAsync(itemNumber, cancellationToken);

Parameters

itemNumber
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfItemKitInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetKitItemAsync Overload


ApiItemsPublicApiClients.GetNonInventoryItemAsync Method

ApiItemsPublicApiClientsGetNonInventoryItemAsync Method

Overload List
 | Name | Description
Public method | GetNonInventoryItemAsync(String) |
Public method | GetNonInventoryItemAsync(String, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetNonInventoryItemAsync Method (String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetNonInventoryItemAsync Method (String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemNonInventoryInfo> GetNonInventoryItemAsync(
    string itemNumber
)
Public Function GetNonInventoryItemAsync (
    itemNumber As String
) As Task(Of WaspResultOfItemNonInventoryInfo)
public:
Task<WaspResultOfItemNonInventoryInfo^>^ GetNonInventoryItemAsync(
    String^ itemNumber
)
member GetNonInventoryItemAsync :
        itemNumber : string -> Task<WaspResultOfItemNonInventoryInfo>

public Task<WaspResultOfItemNonInventoryInfo> GetNonInventoryItemAsync(
    String itemNumber
)
function GetNonInventoryItemAsync(itemNumber);

Parameters

itemNumber
Type: SystemString

Return Value

Type: Task WaspResultOfItemNonInventoryInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetNonInventoryItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetNonInventoryItemAsync Method (String, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetNonInventoryItemAsync Method (String, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemNonInventoryInfo> GetNonInventoryItemAsync(
    string itemNumber,
    CancellationToken cancellationToken
)
Public Function GetNonInventoryItemAsync (
    itemNumber As String,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfItemNonInventoryInfo)
public:
Task<WaspResultOfItemNonInventoryInfo^>^ GetNonInventoryItemAsync(
    String^ itemNumber,
    CancellationToken cancellationToken
)
member GetNonInventoryItemAsync :
        itemNumber : string *
        cancellationToken : CancellationToken -> Task<WaspResultOfItemNonInventoryInfo>

public Task<WaspResultOfItemNonInventoryInfo> GetNonInventoryItemAsync(
    String itemNumber,
    CancellationToken cancellationToken
)
function GetNonInventoryItemAsync(itemNumber, cancellationToken);

Parameters

itemNumber
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfItemNonInventoryInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetNonInventoryItemAsync Overload


ApiItemsPublicApiClients.GetServiceItemAsync Method

ApiItemsPublicApiClientsGetServiceItemAsync Method

Overload List
 | Name | Description
Public method | GetServiceItemAsync(String) |
Public method | GetServiceItemAsync(String, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetServiceItemAsync Method (String)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetServiceItemAsync Method (String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemServiceInfo> GetServiceItemAsync(
    string itemNumber
)
Public Function GetServiceItemAsync (
    itemNumber As String
) As Task(Of WaspResultOfItemServiceInfo)
public:
Task<WaspResultOfItemServiceInfo^>^ GetServiceItemAsync(
    String^ itemNumber
)
member GetServiceItemAsync :
        itemNumber : string -> Task<WaspResultOfItemServiceInfo>

public Task<WaspResultOfItemServiceInfo> GetServiceItemAsync(
    String itemNumber
)
function GetServiceItemAsync(itemNumber);

Parameters

itemNumber
Type: SystemString

Return Value

Type: Task WaspResultOfItemServiceInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetServiceItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.GetServiceItemAsync Method (String, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsGetServiceItemAsync Method (String, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfItemServiceInfo> GetServiceItemAsync(
    string itemNumber,
    CancellationToken cancellationToken
)
Public Function GetServiceItemAsync (
    itemNumber As String,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfItemServiceInfo)
public:
Task<WaspResultOfItemServiceInfo^>^ GetServiceItemAsync(
    String^ itemNumber,
    CancellationToken cancellationToken
)
member GetServiceItemAsync :
        itemNumber : string *
        cancellationToken : CancellationToken -> Task<WaspResultOfItemServiceInfo>

public Task<WaspResultOfItemServiceInfo> GetServiceItemAsync(
    String itemNumber,
    CancellationToken cancellationToken
)
function GetServiceItemAsync(itemNumber, cancellationToken);

Parameters

itemNumber
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfItemServiceInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
GetServiceItemAsync Overload


ApiItemsPublicApiClients.InventorySearchAsync Method

ApiItemsPublicApiClientsInventorySearchAsync Method

Overload List
 | Name | Description
Public method | InventorySearchAsync(InventorySearchParameters) |
Public method | InventorySearchAsync(InventorySearchParameters, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.InventorySearchAsync Method (InventorySearchParameters)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsInventorySearchAsync Method (InventorySearchParameters)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfInventoryInfo> InventorySearchAsync(
    InventorySearchParameters param
)
Public Function InventorySearchAsync (
    param As InventorySearchParameters
) As Task(Of WaspResultOfListOfInventoryInfo)
public:
Task<WaspResultOfListOfInventoryInfo^>^ InventorySearchAsync(
    InventorySearchParameters^ param
)
member InventorySearchAsync :
        param : InventorySearchParameters -> Task<WaspResultOfListOfInventoryInfo>

public Task<WaspResultOfListOfInventoryInfo> InventorySearchAsync(
    InventorySearchParameters param
)
function InventorySearchAsync(param);

Parameters

param
Type: InventorySearchParameters

Return Value

Type: Task WaspResultOfListOfInventoryInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
InventorySearchAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.InventorySearchAsync Method (InventorySearchParameters, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsInventorySearchAsync Method (InventorySearchParameters, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfInventoryInfo> InventorySearchAsync(
    InventorySearchParameters param,
    CancellationToken cancellationToken
)
Public Function InventorySearchAsync (
    param As InventorySearchParameters,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfListOfInventoryInfo)
public:
Task<WaspResultOfListOfInventoryInfo^>^ InventorySearchAsync(
    InventorySearchParameters^ param,
    CancellationToken cancellationToken
)
member InventorySearchAsync :
        param : InventorySearchParameters *
        cancellationToken : CancellationToken -> Task<WaspResultOfListOfInventoryInfo>

public Task<WaspResultOfListOfInventoryInfo> InventorySearchAsync(
    InventorySearchParameters param,
    CancellationToken cancellationToken
)
function InventorySearchAsync(param, cancellationToken);

Parameters

param
Type: InventorySearchParameters
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfListOfInventoryInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
InventorySearchAsync Overload


ApiItemsPublicApiClients.ItemInfoAdvancedSearchAsync Method

ApiItemsPublicApiClientsItemInfoAdvancedSearchAsync Method

Overload List
 | Name | Description
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters) |
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.ItemInfoAdvancedSearchAsync Method (AdvancedSearchParameters)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsItemInfoAdvancedSearchAsync Method (AdvancedSearchParameters)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfItemInfo> ItemInfoAdvancedSearchAsync(
    AdvancedSearchParameters model
)
Public Function ItemInfoAdvancedSearchAsync (
    model As AdvancedSearchParameters
) As Task(Of WaspResultOfListOfItemInfo)
public:
Task<WaspResultOfListOfItemInfo^>^ ItemInfoAdvancedSearchAsync(
    AdvancedSearchParameters^ model
)
member ItemInfoAdvancedSearchAsync :
        model : AdvancedSearchParameters -> Task<WaspResultOfListOfItemInfo>

public Task<WaspResultOfListOfItemInfo> ItemInfoAdvancedSearchAsync(
    AdvancedSearchParameters model
)
function ItemInfoAdvancedSearchAsync(model);

Parameters

model
Type: AdvancedSearchParameters

Return Value

Type: Task WaspResultOfListOfItemInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
ItemInfoAdvancedSearchAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.ItemInfoAdvancedSearchAsync Method (AdvancedSearchParameters, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsItemInfoAdvancedSearchAsync Method (AdvancedSearchParameters, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfItemInfo> ItemInfoAdvancedSearchAsync(
    AdvancedSearchParameters model,
    CancellationToken cancellationToken
)
Public Function ItemInfoAdvancedSearchAsync (
    model As AdvancedSearchParameters,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfListOfItemInfo)
public:
Task<WaspResultOfListOfItemInfo^>^ ItemInfoAdvancedSearchAsync(
    AdvancedSearchParameters^ model,
    CancellationToken cancellationToken
)
member ItemInfoAdvancedSearchAsync :
        model : AdvancedSearchParameters *
        cancellationToken : CancellationToken -> Task<WaspResultOfListOfItemInfo>

public Task<WaspResultOfListOfItemInfo> ItemInfoAdvancedSearchAsync(
    AdvancedSearchParameters model,
    CancellationToken cancellationToken
)
function ItemInfoAdvancedSearchAsync(model, cancellationToken);

Parameters

model
Type: AdvancedSearchParameters
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfListOfItemInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
ItemInfoAdvancedSearchAsync Overload


ApiItemsPublicApiClients.ItemInfoSearchAsync Method

ApiItemsPublicApiClientsItemInfoSearchAsync Method

Overload List
 | Name | Description
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters) |
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.ItemInfoSearchAsync Method (ItemContainsSearchParameters)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsItemInfoSearchAsync Method (ItemContainsSearchParameters)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfItemInfo> ItemInfoSearchAsync(
    ItemContainsSearchParameters param
)
Public Function ItemInfoSearchAsync (
    param As ItemContainsSearchParameters
) As Task(Of WaspResultOfListOfItemInfo)
public:
Task<WaspResultOfListOfItemInfo^>^ ItemInfoSearchAsync(
    ItemContainsSearchParameters^ param
)
member ItemInfoSearchAsync :
        param : ItemContainsSearchParameters -> Task<WaspResultOfListOfItemInfo>

public Task<WaspResultOfListOfItemInfo> ItemInfoSearchAsync(
    ItemContainsSearchParameters param
)
function ItemInfoSearchAsync(param);

Parameters

param
Type: ItemContainsSearchParameters

Return Value

Type: Task WaspResultOfListOfItemInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
ItemInfoSearchAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.ItemInfoSearchAsync Method (ItemContainsSearchParameters, CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsItemInfoSearchAsync Method (ItemContainsSearchParameters, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfListOfItemInfo> ItemInfoSearchAsync(
    ItemContainsSearchParameters param,
    CancellationToken cancellationToken
)
Public Function ItemInfoSearchAsync (
    param As ItemContainsSearchParameters,
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfListOfItemInfo)
public:
Task<WaspResultOfListOfItemInfo^>^ ItemInfoSearchAsync(
    ItemContainsSearchParameters^ param,
    CancellationToken cancellationToken
)
member ItemInfoSearchAsync :
        param : ItemContainsSearchParameters *
        cancellationToken : CancellationToken -> Task<WaspResultOfListOfItemInfo>

public Task<WaspResultOfListOfItemInfo> ItemInfoSearchAsync(
    ItemContainsSearchParameters param,
    CancellationToken cancellationToken
)
function ItemInfoSearchAsync(param, cancellationToken);

Parameters

param
Type: ItemContainsSearchParameters
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfListOfItemInfo
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
ItemInfoSearchAsync Overload


ApiItemsPublicApiClients.UpdateInventoryItemAsync Method

ApiItemsPublicApiClientsUpdateInventoryItemAsync Method

Overload List
 | Name | Description
Public method | UpdateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo) |
Public method | UpdateInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.UpdateInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemInventorysInfo))

CSharpPublicApiExampleProgramApiItemsPublicApiClientsUpdateInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> UpdateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems
)
Public Function UpdateInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemInventorysInfo)
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ UpdateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo^>^ listItems
)
member UpdateInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> UpdateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems
)
function UpdateInventoryItemAsync(listItems);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemInventorysInfo

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
UpdateInventoryItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.UpdateInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemInventorysInfo), CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsUpdateInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemInventorysInfo, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> UpdateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems,
    CancellationToken cancellationToken
)
Public Function UpdateInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemInventorysInfo),
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ UpdateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo^>^ listItems,
    CancellationToken cancellationToken
)
member UpdateInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> *
        cancellationToken : CancellationToken -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> UpdateInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemInventorysInfo> listItems,
    CancellationToken cancellationToken
)
function UpdateInventoryItemAsync(listItems, cancellationToken);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemInventorysInfo
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
UpdateInventoryItemAsync Overload


ApiItemsPublicApiClients.UpdateNonInventoryItemAsync Method

ApiItemsPublicApiClientsUpdateNonInventoryItemAsync Method

Overload List
 | Name | Description
Public method | UpdateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos) |
Public method | UpdateNonInventoryItemAsync(IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.UpdateNonInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemNonInventoryInfos))

CSharpPublicApiExampleProgramApiItemsPublicApiClientsUpdateNonInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> UpdateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems
)
Public Function UpdateNonInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemNonInventoryInfos)
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ UpdateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos^>^ listItems
)
member UpdateNonInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> UpdateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems
)
function UpdateNonInventoryItemAsync(listItems);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemNonInventoryInfos

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
UpdateNonInventoryItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.UpdateNonInventoryItemAsync Method (IEnumerable(CSharpPublicApiExampleProgram.ItemNonInventoryInfos), CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsUpdateNonInventoryItemAsync Method (IEnumerableCSharpPublicApiExampleProgramItemNonInventoryInfos, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> UpdateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems,
    CancellationToken cancellationToken
)
Public Function UpdateNonInventoryItemAsync (
    listItems As IEnumerable(Of CSharpPublicApiExampleProgramItemNonInventoryInfos),
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ UpdateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos^>^ listItems,
    CancellationToken cancellationToken
)
member UpdateNonInventoryItemAsync :
        listItems : IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> *
        cancellationToken : CancellationToken -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> UpdateNonInventoryItemAsync(
    IEnumerable<CSharpPublicApiExampleProgramItemNonInventoryInfos> listItems,
    CancellationToken cancellationToken
)
function UpdateNonInventoryItemAsync(listItems, cancellationToken);

Parameters

listItems
Type: System.Collections.GenericIEnumerable CSharpPublicApiExampleProgramItemNonInventoryInfos
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
UpdateNonInventoryItemAsync Overload


ApiItemsPublicApiClients.UpdateServiceItemAsync Method

ApiItemsPublicApiClientsUpdateServiceItemAsync Method

Overload List
 | Name | Description
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo) |
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken) |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.UpdateServiceItemAsync Method (IEnumerable(ItemServiceInfo))

CSharpPublicApiExampleProgramApiItemsPublicApiClientsUpdateServiceItemAsync Method (IEnumerableItemServiceInfo)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> UpdateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems
)
Public Function UpdateServiceItemAsync (
    listItems As IEnumerable(Of ItemServiceInfo)
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ UpdateServiceItemAsync(
    IEnumerable<ItemServiceInfo^>^ listItems
)
member UpdateServiceItemAsync :
        listItems : IEnumerable<ItemServiceInfo> -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> UpdateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems
)
function UpdateServiceItemAsync(listItems);

Parameters

listItems
Type: System.Collections.GenericIEnumerable ItemServiceInfo

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
UpdateServiceItemAsync Overload


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients.UpdateServiceItemAsync Method (IEnumerable(ItemServiceInfo), CancellationToken)

CSharpPublicApiExampleProgramApiItemsPublicApiClientsUpdateServiceItemAsync Method (IEnumerableItemServiceInfo, CancellationToken)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<WaspResultOfResults> UpdateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems,
    CancellationToken cancellationToken
)
Public Function UpdateServiceItemAsync (
    listItems As IEnumerable(Of ItemServiceInfo),
    cancellationToken As CancellationToken
) As Task(Of WaspResultOfResults)
public:
Task<WaspResultOfResults^>^ UpdateServiceItemAsync(
    IEnumerable<ItemServiceInfo^>^ listItems,
    CancellationToken cancellationToken
)
member UpdateServiceItemAsync :
        listItems : IEnumerable<ItemServiceInfo> *
        cancellationToken : CancellationToken -> Task<WaspResultOfResults>

public Task<WaspResultOfResults> UpdateServiceItemAsync(
    IEnumerable<ItemServiceInfo> listItems,
    CancellationToken cancellationToken
)
function UpdateServiceItemAsync(listItems, cancellationToken);

Parameters

listItems
Type: System.Collections.GenericIEnumerable ItemServiceInfo
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task WaspResultOfResults
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class
UpdateServiceItemAsync Overload


ApiItemsPublicApiClients Fields

Fields
 | Name | Description
Private field | _baseUrl |
Private field | _settings |
Top
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients._baseUrl Field

CSharpPublicApiExampleProgramApiItemsPublicApiClients_baseUrl Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _baseUrl
Private _baseUrl As String
private:
String^ _baseUrl
val mutable private _baseUrl: string
private String _baseUrl
var _baseUrl

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.ApiItemsPublicApiClients._settings Field

CSharpPublicApiExampleProgramApiItemsPublicApiClients_settings Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Lazy<JsonSerializerSettings> _settings
Private _settings As Lazy(Of JsonSerializerSettings)
private:
Lazy<JsonSerializerSettings^>^ _settings
val mutable private _settings: Lazy<JsonSerializerSettings>
private Lazy<JsonSerializerSettings> _settings
var _settings

Field Value

Type: Lazy JsonSerializerSettings
See Also

Reference

CSharpPublicApiExampleProgramApiItemsPublicApiClients Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel Class

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class AttachmentsUploadAssociatedModel : INotifyPropertyChanged
Public Class AttachmentsUploadAssociatedModel
    Implements INotifyPropertyChanged
public ref class AttachmentsUploadAssociatedModel : INotifyPropertyChanged
type AttachmentsUploadAssociatedModel =
    class
        interface INotifyPropertyChanged
    end
public class AttachmentsUploadAssociatedModel implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.AttachmentsUploadAssociatedModel = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.AttachmentsUploadAssociatedModel',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel | Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel class
Top
Properties
 | Name | Description
Public property | AssociatedObjectList |
Public property | AttachmentFormType |
Public property | AttachmentsList |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _associatedObjectList |
Private field | _attachmentFormType |
Private field | _attachmentsList |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel Constructor

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public AttachmentsUploadAssociatedModel()
Public Sub New
public:
AttachmentsUploadAssociatedModel()
new : unit -> AttachmentsUploadAssociatedModel
public AttachmentsUploadAssociatedModel()
Wasp.Cloud.Inventory.Example.AttachmentsUploadAssociatedModel = function();
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Properties

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Properties
 | Name | Description
Public property | AssociatedObjectList |
Public property | AttachmentFormType |
Public property | AttachmentsList |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.AssociatedObjectList Property

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelAssociatedObjectList Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<string> AssociatedObjectList { get; set; }
Public Property AssociatedObjectList As List(Of String)
    Get
    Set
public:
property List<String^>^ AssociatedObjectList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member AssociatedObjectList : List<string> with get, set

/** @property */
public List<String> get_AssociatedObjectList()
/** @property */
public void set_AssociatedObjectList(List<String> value)

function get_AssociatedObjectList();
function set_AssociatedObjectList(value);

Property Value

Type: List String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.AttachmentFormType Property

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelAttachmentFormType Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramWtFormId AttachmentFormType { get; set; }
Public Property AttachmentFormType As CSharpPublicApiExampleProgramWtFormId
    Get
    Set
public:
property CSharpPublicApiExampleProgramWtFormId AttachmentFormType {
    CSharpPublicApiExampleProgramWtFormId get ();
    void set (CSharpPublicApiExampleProgramWtFormId value);
}
member AttachmentFormType : CSharpPublicApiExampleProgramWtFormId with get, set

/** @property */
public CSharpPublicApiExampleProgramWtFormId get_AttachmentFormType()
/** @property */
public void set_AttachmentFormType(CSharpPublicApiExampleProgramWtFormId value)

function get_AttachmentFormType();
function set_AttachmentFormType(value);

Property Value

Type: CSharpPublicApiExampleProgramWtFormId
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.AttachmentsList Property

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelAttachmentsList Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> AttachmentsList { get; set; }
Public Property AttachmentsList As List(Of CSharpPublicApiExampleProgramAttachmentUploadAttributes)
    Get
    Set
public:
property List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ AttachmentsList {
    List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ get ();
    void set (List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ value);
}
member AttachmentsList : List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> with get, set

/** @property */
public List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> get_AttachmentsList()
/** @property */
public void set_AttachmentsList(List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> value)

function get_AttachmentsList();
function set_AttachmentsList(value);

Property Value

Type: List CSharpPublicApiExampleProgramAttachmentUploadAttributes
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Methods

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.FromJson Method

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel
public:
static CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel

public static CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.AttachmentsUploadAssociatedModel.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.RaisePropertyChanged Method

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.ToJson Method

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Events

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.PropertyChanged Event

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Fields

Fields
 | Name | Description
Private field | _associatedObjectList |
Private field | _attachmentFormType |
Private field | _attachmentsList |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel._associatedObjectList Field

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel_associatedObjectList Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<string> _associatedObjectList
Private _associatedObjectList As List(Of String)
private:
List<String^>^ _associatedObjectList
val mutable private _associatedObjectList: List<string>
private List<String> _associatedObjectList
var _associatedObjectList

Field Value

Type: List String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel._attachmentFormType Field

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel_attachmentFormType Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramWtFormId _attachmentFormType
Private _attachmentFormType As CSharpPublicApiExampleProgramWtFormId
private:
CSharpPublicApiExampleProgramWtFormId _attachmentFormType
val mutable private _attachmentFormType: CSharpPublicApiExampleProgramWtFormId
private CSharpPublicApiExampleProgramWtFormId _attachmentFormType
var _attachmentFormType

Field Value

Type: CSharpPublicApiExampleProgramWtFormId
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel._attachmentsList Field

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel_attachmentsList Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> _attachmentsList
Private _attachmentsList As List(Of CSharpPublicApiExampleProgramAttachmentUploadAttributes)
private:
List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ _attachmentsList
val mutable private _attachmentsList: List<CSharpPublicApiExampleProgramAttachmentUploadAttributes>
private List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> _attachmentsList
var _attachmentsList

Field Value

Type: List CSharpPublicApiExampleProgramAttachmentUploadAttributes
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes Class

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramAttachmentUploadAttributes

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class AttachmentUploadAttributes : INotifyPropertyChanged
Public Class AttachmentUploadAttributes
    Implements INotifyPropertyChanged
public ref class AttachmentUploadAttributes : INotifyPropertyChanged
type AttachmentUploadAttributes =
    class
        interface INotifyPropertyChanged
    end
public class AttachmentUploadAttributes implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.AttachmentUploadAttributes = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.AttachmentUploadAttributes',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramAttachmentUploadAttributes | Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentUploadAttributes class
Top
Properties
 | Name | Description
Public property | AttachmentFileByteArray |
Public property | AttachmentFileName |
Public property | AttachmentType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _attachmentFileByteArray |
Private field | _attachmentFileName |
Private field | _attachmentType |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.AttachmentUploadAttributes Constructor

CSharpPublicApiExampleProgramAttachmentUploadAttributes Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentUploadAttributes class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public AttachmentUploadAttributes()
Public Sub New
public:
AttachmentUploadAttributes()
new : unit -> AttachmentUploadAttributes
public AttachmentUploadAttributes()
Wasp.Cloud.Inventory.Example.AttachmentUploadAttributes = function();
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Properties

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Properties
 | Name | Description
Public property | AttachmentFileByteArray |
Public property | AttachmentFileName |
Public property | AttachmentType |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.AttachmentFileByteArray Property

CSharpPublicApiExampleProgramAttachmentUploadAttributesAttachmentFileByteArray Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public byte[] AttachmentFileByteArray { get; set; }
Public Property AttachmentFileByteArray As Byte()
    Get
    Set
public:
property array<unsigned char>^ AttachmentFileByteArray {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member AttachmentFileByteArray : byte[] with get, set

/** @property */
public byte[] get_AttachmentFileByteArray()
/** @property */
public void set_AttachmentFileByteArray(byte[] value)

function get_AttachmentFileByteArray();
function set_AttachmentFileByteArray(value);

Property Value

Type: Byte
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.AttachmentFileName Property

CSharpPublicApiExampleProgramAttachmentUploadAttributesAttachmentFileName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string AttachmentFileName { get; set; }
Public Property AttachmentFileName As String
    Get
    Set
public:
property String^ AttachmentFileName {
    String^ get ();
    void set (String^ value);
}
member AttachmentFileName : string with get, set

/** @property */
public String get_AttachmentFileName()
/** @property */
public void set_AttachmentFileName(String value)

function get_AttachmentFileName();
function set_AttachmentFileName(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.AttachmentType Property

CSharpPublicApiExampleProgramAttachmentUploadAttributesAttachmentType Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramUploadFileType AttachmentType { get; set; }
Public Property AttachmentType As CSharpPublicApiExampleProgramUploadFileType
    Get
    Set
public:
property CSharpPublicApiExampleProgramUploadFileType AttachmentType {
    CSharpPublicApiExampleProgramUploadFileType get ();
    void set (CSharpPublicApiExampleProgramUploadFileType value);
}
member AttachmentType : CSharpPublicApiExampleProgramUploadFileType with get, set

/** @property */
public CSharpPublicApiExampleProgramUploadFileType get_AttachmentType()
/** @property */
public void set_AttachmentType(CSharpPublicApiExampleProgramUploadFileType value)

function get_AttachmentType();
function set_AttachmentType(value);

Property Value

Type: CSharpPublicApiExampleProgramUploadFileType
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Methods

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.FromJson Method

CSharpPublicApiExampleProgramAttachmentUploadAttributesFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramAttachmentUploadAttributes FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramAttachmentUploadAttributes
public:
static CSharpPublicApiExampleProgramAttachmentUploadAttributes^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramAttachmentUploadAttributes

public static CSharpPublicApiExampleProgramAttachmentUploadAttributes FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.AttachmentUploadAttributes.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramAttachmentUploadAttributes
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.RaisePropertyChanged Method

CSharpPublicApiExampleProgramAttachmentUploadAttributesRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.ToJson Method

CSharpPublicApiExampleProgramAttachmentUploadAttributesToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Events

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.PropertyChanged Event

CSharpPublicApiExampleProgramAttachmentUploadAttributesPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Fields

Fields
 | Name | Description
Private field | _attachmentFileByteArray |
Private field | _attachmentFileName |
Private field | _attachmentType |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes._attachmentFileByteArray Field

CSharpPublicApiExampleProgramAttachmentUploadAttributes_attachmentFileByteArray Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private byte[] _attachmentFileByteArray
Private _attachmentFileByteArray As Byte()
private:
array<unsigned char>^ _attachmentFileByteArray
val mutable private _attachmentFileByteArray: byte[]
private byte[] _attachmentFileByteArray
var _attachmentFileByteArray

Field Value

Type: Byte
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes._attachmentFileName Field

CSharpPublicApiExampleProgramAttachmentUploadAttributes_attachmentFileName Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _attachmentFileName
Private _attachmentFileName As String
private:
String^ _attachmentFileName
val mutable private _attachmentFileName: string
private String _attachmentFileName
var _attachmentFileName

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes._attachmentType Field

CSharpPublicApiExampleProgramAttachmentUploadAttributes_attachmentType Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramUploadFileType _attachmentType
Private _attachmentType As CSharpPublicApiExampleProgramUploadFileType
private:
CSharpPublicApiExampleProgramUploadFileType _attachmentType
val mutable private _attachmentType: CSharpPublicApiExampleProgramUploadFileType
private CSharpPublicApiExampleProgramUploadFileType _attachmentType
var _attachmentType

Field Value

Type: CSharpPublicApiExampleProgramUploadFileType
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.CostMethodEnums Enumeration

CSharpPublicApiExampleProgramCostMethodEnums Enumeration

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public enum CostMethodEnums
Public Enumeration CostMethodEnums
public enum class CostMethodEnums
type CostMethodEnums
public enum CostMethodEnums
Wasp.Cloud.Inventory.Example.CostMethodEnums = function();
Wasp.Cloud.Inventory.Example.CostMethodEnums.createEnum('Wasp.Cloud.Inventory.Example.CostMethodEnums', false);
Members
Member name | Value | Description
MovingAverage | 10 |
FIFO | 20 |
LIFO | 30 |
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.HigherTimeoutApiItemsPublicApiClient Class

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Class

Inheritance Hierarchy
SystemObject
ExamplePublicApiClientBase
ApiItemsPublicApiClient
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private class HigherTimeoutApiItemsPublicApiClient : ApiItemsPublicApiClient
Private Class HigherTimeoutApiItemsPublicApiClient
    Inherits ApiItemsPublicApiClient
private ref class HigherTimeoutApiItemsPublicApiClient : public ApiItemsPublicApiClient
type HigherTimeoutApiItemsPublicApiClient =
    class
        inherit ApiItemsPublicApiClient
    end
private class HigherTimeoutApiItemsPublicApiClient extends ApiItemsPublicApiClient
Wasp.Cloud.Inventory.Example.HigherTimeoutApiItemsPublicApiClient = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.HigherTimeoutApiItemsPublicApiClient',
    Wasp.Cloud.Inventory.API.ApiItemsPublicApiClient);

The CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient | Initializes a new instance of the CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient class
Top
Properties
 | Name | Description
Public property | BaseUrl | (Inherited from ApiItemsPublicApiClient.)
Protected property | JsonSerializerSettings | (Inherited from ApiItemsPublicApiClient.)
Public property | ReadResponseAsString | (Inherited from ApiItemsPublicApiClient.)
Top
Methods
 | Name | Description
Private method | ConvertToString | (Inherited from ApiItemsPublicApiClient.)
Protected method | CreateHttpClientAsync | (Inherited from ExamplePublicApiClientBase.)
Protected method | CreateHttpRequestMessageAsync | (Inherited from ExamplePublicApiClientBase.)
Public method | CreateInventoryItemAsync(IEnumerableItemInventoryInfo) | This method is used to create new inventory items. You can pass in a list of ItemInventoryInfo to create several new items at once. It creates only inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateInventoryItemAsync(IEnumerableItemInventoryInfo, CancellationToken) | This method is used to create new inventory items. You can pass in a list of ItemInventoryInfo to create several new items at once. It creates only inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo) | This method is used to create new non inventory items. You can pass in a list of ItemNonInventoryInfo to create several new items at once. It creates only non-inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo, CancellationToken) | This method is used to create new non inventory items. You can pass in a list of ItemNonInventoryInfo to create several new items at once. It creates only non-inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Private method | CreateSerializerSettings | (Inherited from ApiItemsPublicApiClient.)
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo) | This method is used to create new service items. You can pass in a list of ItemServiceInfo to create several new items at once. It creates only service type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken) | This method is used to create new service items. You can pass in a list of ItemServiceInfo to create several new items at once. It creates only service type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | DecodeAsync``1 | (Inherited from ExamplePublicApiClientBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Private method | FormatJSON | (Inherited from ExamplePublicApiClientBase.)
Public method | GetAssemblyItemAsync(String) | This method is used to get an assembly item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetAssemblyItemAsync(String, CancellationToken) | This method is used to get an assembly item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInventoryItemAsync(String) | This method is used to get an inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetInventoryItemAsync(String, CancellationToken) | This method is used to get an inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetItemsByNumberAsync(IEnumerableString) | This method returns existing items by number. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | GetItemsByNumberAsync(IEnumerableString, CancellationToken) | This method returns existing items by number. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | GetKitItemAsync(String) | This method is used to get a kit item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetKitItemAsync(String, CancellationToken) | This method is used to get a kit item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetMultipleInventoryItemAsync(IEnumerableString) | This method is used to get up to 20 inventory items by item number, on providing the details about the item. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetMultipleInventoryItemAsync(IEnumerableString, CancellationToken) | This method is used to get up to 20 inventory items by item number, on providing the details about the item. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Private method | GetNewRequestIdentifier | (Inherited from ExamplePublicApiClientBase.)
Public method | GetNonInventoryItemAsync(String) | This method is used to get a non inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetNonInventoryItemAsync(String, CancellationToken) | This method is used to get a non inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetServiceItemAsync(String) | This method is used to get a service item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetServiceItemAsync(String, CancellationToken) | This method is used to get a service item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InventoryAdvancedSearchAsync(AdvancedSearchParameters) | This method is a robust inventory query similar to the main View Item non tree mode grid. This is a paging API. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | InventoryAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) | This method is a robust inventory query similar to the main View Item non tree mode grid. This is a paging API. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | InventorySearchAsync(InventorySearchParameters) | This method is a simple inventory query similar to what is found on the Edit Item screen or on the mobile devices. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | InventorySearchAsync(InventorySearchParameters, CancellationToken) | This method is a simple inventory query similar to what is found on the Edit Item screen or on the mobile devices. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters) | This method returns a page full of active items given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (about 100) or records to fetch, repeatedly, until you get them all. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) | This method returns a page full of active items given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (about 100) or records to fetch, repeatedly, until you get them all. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters) | This method returns all active items whose item number, alternate item number or item description contains the specified texts that are entered on the combo box. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters, CancellationToken) | This method returns all active items whose item number, alternate item number or item description contains the specified texts that are entered on the combo box. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) | (Inherited from ExamplePublicApiClientBase.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) | (Overrides ExamplePublicApiClientBase.PrepareRequest(HttpClient, HttpRequestMessage, String).)
Protected method | ProcessResponse | (Inherited from ExamplePublicApiClientBase.)
Protected method | ReadObjectResponseAsync``1 | (Inherited from ApiItemsPublicApiClient.)
Protected method | SaveJSONResponseToFile | (Inherited from ExamplePublicApiClientBase.)
Protected method | SaveRequestJSONBodyToFile | (Inherited from ExamplePublicApiClientBase.)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel) | Request item inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel, CancellationToken) | Request item inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel) | Request item records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel, CancellationToken) | Request item records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateInventoryItemAsync(IEnumerableItemInventoryInfo) | This method is used to update existing inventory items. You can pass in a list of ItemInventoryInfo to update several existing items at once. It updates only inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateInventoryItemAsync(IEnumerableItemInventoryInfo, CancellationToken) | This method is used to update existing inventory items. You can pass in a list of ItemInventoryInfo to update several existing items at once. It updates only inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Protected method | UpdateJsonSerializerSettings | (Inherited from ExamplePublicApiClientBase.)
Public method | UpdateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo) | This method is used to update existing non inventory items. You can pass in a list of ItemNonInventoryInfo to update several existing items at once. It updates only non-inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo, CancellationToken) | This method is used to update existing non inventory items. You can pass in a list of ItemNonInventoryInfo to update several existing items at once. It updates only non-inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo) | This method is used to update existing service items. You can pass in a list of ItemServiceInfo to update several existing items at once. It updates only service type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken) | This method is used to update existing service items. You can pass in a list of ItemServiceInfo to update several existing items at once. It updates only service type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Top
Fields
 | Name | Description
Private field | _baseUrl | (Inherited from ApiItemsPublicApiClient.)
Private field | _settings | (Inherited from ApiItemsPublicApiClient.)
Public field | RequestDescription | (Inherited from ExamplePublicApiClientBase.)
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.HigherTimeoutApiItemsPublicApiClient Constructor

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public HigherTimeoutApiItemsPublicApiClient(
    string baseUrl
)
Public Sub New (
    baseUrl As String
)
public:
HigherTimeoutApiItemsPublicApiClient(
    String^ baseUrl
)
new :
        baseUrl : string -> HigherTimeoutApiItemsPublicApiClient
public HigherTimeoutApiItemsPublicApiClient(
    String baseUrl
)
Wasp.Cloud.Inventory.Example.HigherTimeoutApiItemsPublicApiClient = function(baseUrl);

Parameters

baseUrl
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Class


HigherTimeoutApiItemsPublicApiClient Properties

The CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient type exposes the following members.

Properties
 | Name | Description
Public property | BaseUrl | (Inherited from ApiItemsPublicApiClient.)
Protected property | JsonSerializerSettings | (Inherited from ApiItemsPublicApiClient.)
Public property | ReadResponseAsString | (Inherited from ApiItemsPublicApiClient.)
Top
See Also

Reference

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Class


HigherTimeoutApiItemsPublicApiClient Methods

The CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient type exposes the following members.

Methods
 | Name | Description
Private method | ConvertToString | (Inherited from ApiItemsPublicApiClient.)
Protected method | CreateHttpClientAsync | (Inherited from ExamplePublicApiClientBase.)
Protected method | CreateHttpRequestMessageAsync | (Inherited from ExamplePublicApiClientBase.)
Public method | CreateInventoryItemAsync(IEnumerableItemInventoryInfo) | This method is used to create new inventory items. You can pass in a list of ItemInventoryInfo to create several new items at once. It creates only inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateInventoryItemAsync(IEnumerableItemInventoryInfo, CancellationToken) | This method is used to create new inventory items. You can pass in a list of ItemInventoryInfo to create several new items at once. It creates only inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo) | This method is used to create new non inventory items. You can pass in a list of ItemNonInventoryInfo to create several new items at once. It creates only non-inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo, CancellationToken) | This method is used to create new non inventory items. You can pass in a list of ItemNonInventoryInfo to create several new items at once. It creates only non-inventory type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Private method | CreateSerializerSettings | (Inherited from ApiItemsPublicApiClient.)
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo) | This method is used to create new service items. You can pass in a list of ItemServiceInfo to create several new items at once. It creates only service type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | CreateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken) | This method is used to create new service items. You can pass in a list of ItemServiceInfo to create several new items at once. It creates only service type items. Requires Create Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | DecodeAsync``1 | (Inherited from ExamplePublicApiClientBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Private method | FormatJSON | (Inherited from ExamplePublicApiClientBase.)
Public method | GetAssemblyItemAsync(String) | This method is used to get an assembly item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetAssemblyItemAsync(String, CancellationToken) | This method is used to get an assembly item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInventoryItemAsync(String) | This method is used to get an inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetInventoryItemAsync(String, CancellationToken) | This method is used to get an inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetItemsByNumberAsync(IEnumerableString) | This method returns existing items by number. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | GetItemsByNumberAsync(IEnumerableString, CancellationToken) | This method returns existing items by number. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | GetKitItemAsync(String) | This method is used to get a kit item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetKitItemAsync(String, CancellationToken) | This method is used to get a kit item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetMultipleInventoryItemAsync(IEnumerableString) | This method is used to get up to 20 inventory items by item number, on providing the details about the item. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetMultipleInventoryItemAsync(IEnumerableString, CancellationToken) | This method is used to get up to 20 inventory items by item number, on providing the details about the item. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Private method | GetNewRequestIdentifier | (Inherited from ExamplePublicApiClientBase.)
Public method | GetNonInventoryItemAsync(String) | This method is used to get a non inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetNonInventoryItemAsync(String, CancellationToken) | This method is used to get a non inventory item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetServiceItemAsync(String) | This method is used to get a service item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetServiceItemAsync(String, CancellationToken) | This method is used to get a service item with an item number that matches the string parameter exactly. Requires Allow Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InventoryAdvancedSearchAsync(AdvancedSearchParameters) | This method is a robust inventory query similar to the main View Item non tree mode grid. This is a paging API. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | InventoryAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) | This method is a robust inventory query similar to the main View Item non tree mode grid. This is a paging API. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | InventorySearchAsync(InventorySearchParameters) | This method is a simple inventory query similar to what is found on the Edit Item screen or on the mobile devices. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | InventorySearchAsync(InventorySearchParameters, CancellationToken) | This method is a simple inventory query similar to what is found on the Edit Item screen or on the mobile devices. Requires Allow Item permission and enforces role site permission. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters) | This method returns a page full of active items given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (about 100) or records to fetch, repeatedly, until you get them all. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) | This method returns a page full of active items given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (about 100) or records to fetch, repeatedly, until you get them all. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters) | This method returns all active items whose item number, alternate item number or item description contains the specified texts that are entered on the combo box. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Public method | ItemInfoSearchAsync(ItemContainsSearchParameters, CancellationToken) | This method returns all active items whose item number, alternate item number or item description contains the specified texts that are entered on the combo box. Requires Allow Item permission. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiItemsPublicApiClient.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) | (Inherited from ExamplePublicApiClientBase.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) | (Overrides ExamplePublicApiClientBase.PrepareRequest(HttpClient, HttpRequestMessage, String).)
Protected method | ProcessResponse | (Inherited from ExamplePublicApiClientBase.)
Protected method | ReadObjectResponseAsync``1 | (Inherited from ApiItemsPublicApiClient.)
Protected method | SaveJSONResponseToFile | (Inherited from ExamplePublicApiClientBase.)
Protected method | SaveRequestJSONBodyToFile | (Inherited from ExamplePublicApiClientBase.)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel) | Request item inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel, CancellationToken) | Request item inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel) | Request item records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel, CancellationToken) | Request item records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on items you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consistent results from one version to the next, make sure you provide this value after you have determined the values you need. If the FieldTitles parameter is not provided the column names returned will be the database column names. This API does not support paging as it is intended to stream all of the data at once (Inherited from ApiItemsPublicApiClient.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateInventoryItemAsync(IEnumerableItemInventoryInfo) | This method is used to update existing inventory items. You can pass in a list of ItemInventoryInfo to update several existing items at once. It updates only inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateInventoryItemAsync(IEnumerableItemInventoryInfo, CancellationToken) | This method is used to update existing inventory items. You can pass in a list of ItemInventoryInfo to update several existing items at once. It updates only inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Protected method | UpdateJsonSerializerSettings | (Inherited from ExamplePublicApiClientBase.)
Public method | UpdateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo) | This method is used to update existing non inventory items. You can pass in a list of ItemNonInventoryInfo to update several existing items at once. It updates only non-inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateNonInventoryItemAsync(IEnumerableItemNonInventoryInfo, CancellationToken) | This method is used to update existing non inventory items. You can pass in a list of ItemNonInventoryInfo to update several existing items at once. It updates only non-inventory type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo) | This method is used to update existing service items. You can pass in a list of ItemServiceInfo to update several existing items at once. It updates only service type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Public method | UpdateServiceItemAsync(IEnumerableItemServiceInfo, CancellationToken) | This method is used to update existing service items. You can pass in a list of ItemServiceInfo to update several existing items at once. It updates only service type items. Requires Edit Item permission. (Inherited from ApiItemsPublicApiClient.)
Top
See Also

Reference

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Class


HigherTimeoutApiItemsPublicApiClient.PrepareRequest Method

HigherTimeoutApiItemsPublicApiClientPrepareRequest Method

Overload List
 | Name | Description
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) | (Inherited from ExamplePublicApiClientBase.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) | (Overrides ExamplePublicApiClientBase.PrepareRequest(HttpClient, HttpRequestMessage, String).)
Top
See Also

Reference

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Class


CSharpPublicApiExampleProgram.HigherTimeoutApiItemsPublicApiClient.PrepareRequest Method (HttpClient, HttpRequestMessage, String)

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClientPrepareRequest Method (HttpClient, HttpRequestMessage, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected override void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    string url
)
Protected Overrides Sub PrepareRequest (
    client As HttpClient,
    request As HttpRequestMessage,
    url As String
)
protected:
virtual void PrepareRequest(
    HttpClient^ client,
    HttpRequestMessage^ request,
    String^ url
) override
abstract PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        url : string -> unit
override PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        url : string -> unit
protected void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    String url
)
function PrepareRequest(client, request, url);

Parameters

client
Type: System.Net.HttpHttpClient
request
Type: System.Net.HttpHttpRequestMessage
url
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Class
PrepareRequest Overload


HigherTimeoutApiItemsPublicApiClient Fields

The CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient type exposes the following members.

Fields
 | Name | Description
Private field | _baseUrl | (Inherited from ApiItemsPublicApiClient.)
Private field | _settings | (Inherited from ApiItemsPublicApiClient.)
Public field | RequestDescription | (Inherited from ExamplePublicApiClientBase.)
Top
See Also

Reference

CSharpPublicApiExampleProgramHigherTimeoutApiItemsPublicApiClient Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo Class

CSharpPublicApiExampleProgramItemAttachmentInfo Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemAttachmentInfo

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemAttachmentInfo : INotifyPropertyChanged
Public Class ItemAttachmentInfo
    Implements INotifyPropertyChanged
public ref class ItemAttachmentInfo : INotifyPropertyChanged
type ItemAttachmentInfo =
    class
        interface INotifyPropertyChanged
    end
public class ItemAttachmentInfo implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemAttachmentInfo = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemAttachmentInfo',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemAttachmentInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemAttachmentInfo | Initializes a new instance of the CSharpPublicApiExampleProgramItemAttachmentInfo class
Top
Properties
 | Name | Description
Public property | AttachmentNames |
Public property | AttachmentsToAdd |
Public property | AttachmentsToDelete |
Public property | HasAttachment |
Public property | NewDefaultAttachment |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _attachmentNames |
Private field | _attachmentsToAdd |
Private field | _attachmentsToDelete |
Private field | _hasAttachment |
Private field | _newDefaultAttachment |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemAttachmentInfo Constructor

CSharpPublicApiExampleProgramItemAttachmentInfo Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemAttachmentInfo class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemAttachmentInfo()
Public Sub New
public:
ItemAttachmentInfo()
new : unit -> ItemAttachmentInfo
public ItemAttachmentInfo()
Wasp.Cloud.Inventory.Example.ItemAttachmentInfo = function();
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


ItemAttachmentInfo Properties

The CSharpPublicApiExampleProgramItemAttachmentInfo type exposes the following members.

Properties
 | Name | Description
Public property | AttachmentNames |
Public property | AttachmentsToAdd |
Public property | AttachmentsToDelete |
Public property | HasAttachment |
Public property | NewDefaultAttachment |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.AttachmentNames Property

CSharpPublicApiExampleProgramItemAttachmentInfoAttachmentNames Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<KeyValuePairOfStringAndString> AttachmentNames { get; set; }
Public Property AttachmentNames As List(Of KeyValuePairOfStringAndString)
    Get
    Set
public:
property List<KeyValuePairOfStringAndString^>^ AttachmentNames {
    List<KeyValuePairOfStringAndString^>^ get ();
    void set (List<KeyValuePairOfStringAndString^>^ value);
}
member AttachmentNames : List<KeyValuePairOfStringAndString> with get, set

/** @property */
public List<KeyValuePairOfStringAndString> get_AttachmentNames()
/** @property */
public void set_AttachmentNames(List<KeyValuePairOfStringAndString> value)

function get_AttachmentNames();
function set_AttachmentNames(value);

Property Value

Type: List KeyValuePairOfStringAndString
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.AttachmentsToAdd Property

CSharpPublicApiExampleProgramItemAttachmentInfoAttachmentsToAdd Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<string> AttachmentsToAdd { get; set; }
Public Property AttachmentsToAdd As List(Of String)
    Get
    Set
public:
property List<String^>^ AttachmentsToAdd {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member AttachmentsToAdd : List<string> with get, set

/** @property */
public List<String> get_AttachmentsToAdd()
/** @property */
public void set_AttachmentsToAdd(List<String> value)

function get_AttachmentsToAdd();
function set_AttachmentsToAdd(value);

Property Value

Type: List String
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.AttachmentsToDelete Property

CSharpPublicApiExampleProgramItemAttachmentInfoAttachmentsToDelete Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<string> AttachmentsToDelete { get; set; }
Public Property AttachmentsToDelete As List(Of String)
    Get
    Set
public:
property List<String^>^ AttachmentsToDelete {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member AttachmentsToDelete : List<string> with get, set

/** @property */
public List<String> get_AttachmentsToDelete()
/** @property */
public void set_AttachmentsToDelete(List<String> value)

function get_AttachmentsToDelete();
function set_AttachmentsToDelete(value);

Property Value

Type: List String
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.HasAttachment Property

CSharpPublicApiExampleProgramItemAttachmentInfoHasAttachment Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool HasAttachment { get; set; }
Public Property HasAttachment As Boolean
    Get
    Set
public:
property bool HasAttachment {
    bool get ();
    void set (bool value);
}
member HasAttachment : bool with get, set

/** @property */
public boolean get_HasAttachment()
/** @property */
public void set_HasAttachment(boolean value)

function get_HasAttachment();
function set_HasAttachment(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.NewDefaultAttachment Property

CSharpPublicApiExampleProgramItemAttachmentInfoNewDefaultAttachment Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string NewDefaultAttachment { get; set; }
Public Property NewDefaultAttachment As String
    Get
    Set
public:
property String^ NewDefaultAttachment {
    String^ get ();
    void set (String^ value);
}
member NewDefaultAttachment : string with get, set

/** @property */
public String get_NewDefaultAttachment()
/** @property */
public void set_NewDefaultAttachment(String value)

function get_NewDefaultAttachment();
function set_NewDefaultAttachment(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


ItemAttachmentInfo Methods

The CSharpPublicApiExampleProgramItemAttachmentInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.FromJson Method

CSharpPublicApiExampleProgramItemAttachmentInfoFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemAttachmentInfo FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemAttachmentInfo
public:
static CSharpPublicApiExampleProgramItemAttachmentInfo^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemAttachmentInfo

public static CSharpPublicApiExampleProgramItemAttachmentInfo FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemAttachmentInfo.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemAttachmentInfo
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemAttachmentInfoRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.ToJson Method

CSharpPublicApiExampleProgramItemAttachmentInfoToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


ItemAttachmentInfo Events

The CSharpPublicApiExampleProgramItemAttachmentInfo type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo.PropertyChanged Event

CSharpPublicApiExampleProgramItemAttachmentInfoPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


ItemAttachmentInfo Fields

Fields
 | Name | Description
Private field | _attachmentNames |
Private field | _attachmentsToAdd |
Private field | _attachmentsToDelete |
Private field | _hasAttachment |
Private field | _newDefaultAttachment |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo._attachmentNames Field

CSharpPublicApiExampleProgramItemAttachmentInfo_attachmentNames Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<KeyValuePairOfStringAndString> _attachmentNames
Private _attachmentNames As List(Of KeyValuePairOfStringAndString)
private:
List<KeyValuePairOfStringAndString^>^ _attachmentNames
val mutable private _attachmentNames: List<KeyValuePairOfStringAndString>
private List<KeyValuePairOfStringAndString> _attachmentNames
var _attachmentNames

Field Value

Type: List KeyValuePairOfStringAndString
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo._attachmentsToAdd Field

CSharpPublicApiExampleProgramItemAttachmentInfo_attachmentsToAdd Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<string> _attachmentsToAdd
Private _attachmentsToAdd As List(Of String)
private:
List<String^>^ _attachmentsToAdd
val mutable private _attachmentsToAdd: List<string>
private List<String> _attachmentsToAdd
var _attachmentsToAdd

Field Value

Type: List String
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo._attachmentsToDelete Field

CSharpPublicApiExampleProgramItemAttachmentInfo_attachmentsToDelete Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<string> _attachmentsToDelete
Private _attachmentsToDelete As List(Of String)
private:
List<String^>^ _attachmentsToDelete
val mutable private _attachmentsToDelete: List<string>
private List<String> _attachmentsToDelete
var _attachmentsToDelete

Field Value

Type: List String
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo._hasAttachment Field

CSharpPublicApiExampleProgramItemAttachmentInfo_hasAttachment Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _hasAttachment
Private _hasAttachment As Boolean
private:
bool _hasAttachment
val mutable private _hasAttachment: bool
private boolean _hasAttachment
var _hasAttachment

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemAttachmentInfo._newDefaultAttachment Field

CSharpPublicApiExampleProgramItemAttachmentInfo_newDefaultAttachment Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _newDefaultAttachment
Private _newDefaultAttachment As String
private:
String^ _newDefaultAttachment
val mutable private _newDefaultAttachment: string
private String _newDefaultAttachment
var _newDefaultAttachment

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemAttachmentInfo Class


CSharpPublicApiExampleProgram.ItemDimensionInfos Class

CSharpPublicApiExampleProgramItemDimensionInfos Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemDimensionInfos

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemDimensionInfos : INotifyPropertyChanged
Public Class ItemDimensionInfos
    Implements INotifyPropertyChanged
public ref class ItemDimensionInfos : INotifyPropertyChanged
type ItemDimensionInfos =
    class
        interface INotifyPropertyChanged
    end
public class ItemDimensionInfos implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemDimensionInfos = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemDimensionInfos',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemDimensionInfos type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemDimensionInfos | Initializes a new instance of the CSharpPublicApiExampleProgramItemDimensionInfos class
Top
Properties
 | Name | Description
Public property | Depth |
Public property | DimensionUnit |
Public property | Height |
Public property | MaxVolume |
Public property | VolumeUnit |
Public property | Weight |
Public property | WeightUnit |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _depth |
Private field | _dimensionUnit |
Private field | _height |
Private field | _maxVolume |
Private field | _volumeUnit |
Private field | _weight |
Private field | _weightUnit |
Private field | _width |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemDimensionInfos Constructor

CSharpPublicApiExampleProgramItemDimensionInfos Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemDimensionInfos class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemDimensionInfos()
Public Sub New
public:
ItemDimensionInfos()
new : unit -> ItemDimensionInfos
public ItemDimensionInfos()
Wasp.Cloud.Inventory.Example.ItemDimensionInfos = function();
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


ItemDimensionInfos Properties

The CSharpPublicApiExampleProgramItemDimensionInfos type exposes the following members.

Properties
 | Name | Description
Public property | Depth |
Public property | DimensionUnit |
Public property | Height |
Public property | MaxVolume |
Public property | VolumeUnit |
Public property | Weight |
Public property | WeightUnit |
Public property | Width |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.Depth Property

CSharpPublicApiExampleProgramItemDimensionInfosDepth Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal Depth { get; set; }
Public Property Depth As Decimal
    Get
    Set
public:
property Decimal Depth {
    Decimal get ();
    void set (Decimal value);
}
member Depth : decimal with get, set

/** @property */
public Decimal get_Depth()
/** @property */
public void set_Depth(Decimal value)

function get_Depth();
function set_Depth(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.DimensionUnit Property

CSharpPublicApiExampleProgramItemDimensionInfosDimensionUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string DimensionUnit { get; set; }
Public Property DimensionUnit As String
    Get
    Set
public:
property String^ DimensionUnit {
    String^ get ();
    void set (String^ value);
}
member DimensionUnit : string with get, set

/** @property */
public String get_DimensionUnit()
/** @property */
public void set_DimensionUnit(String value)

function get_DimensionUnit();
function set_DimensionUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.Height Property

CSharpPublicApiExampleProgramItemDimensionInfosHeight Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal Height { get; set; }
Public Property Height As Decimal
    Get
    Set
public:
property Decimal Height {
    Decimal get ();
    void set (Decimal value);
}
member Height : decimal with get, set

/** @property */
public Decimal get_Height()
/** @property */
public void set_Height(Decimal value)

function get_Height();
function set_Height(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.MaxVolume Property

CSharpPublicApiExampleProgramItemDimensionInfosMaxVolume Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal MaxVolume { get; set; }
Public Property MaxVolume As Decimal
    Get
    Set
public:
property Decimal MaxVolume {
    Decimal get ();
    void set (Decimal value);
}
member MaxVolume : decimal with get, set

/** @property */
public Decimal get_MaxVolume()
/** @property */
public void set_MaxVolume(Decimal value)

function get_MaxVolume();
function set_MaxVolume(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.VolumeUnit Property

CSharpPublicApiExampleProgramItemDimensionInfosVolumeUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string VolumeUnit { get; set; }
Public Property VolumeUnit As String
    Get
    Set
public:
property String^ VolumeUnit {
    String^ get ();
    void set (String^ value);
}
member VolumeUnit : string with get, set

/** @property */
public String get_VolumeUnit()
/** @property */
public void set_VolumeUnit(String value)

function get_VolumeUnit();
function set_VolumeUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.Weight Property

CSharpPublicApiExampleProgramItemDimensionInfosWeight Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal Weight { get; set; }
Public Property Weight As Decimal
    Get
    Set
public:
property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
member Weight : decimal with get, set

/** @property */
public Decimal get_Weight()
/** @property */
public void set_Weight(Decimal value)

function get_Weight();
function set_Weight(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.WeightUnit Property

CSharpPublicApiExampleProgramItemDimensionInfosWeightUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string WeightUnit { get; set; }
Public Property WeightUnit As String
    Get
    Set
public:
property String^ WeightUnit {
    String^ get ();
    void set (String^ value);
}
member WeightUnit : string with get, set

/** @property */
public String get_WeightUnit()
/** @property */
public void set_WeightUnit(String value)

function get_WeightUnit();
function set_WeightUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.Width Property

CSharpPublicApiExampleProgramItemDimensionInfosWidth Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal Width { get; set; }
Public Property Width As Decimal
    Get
    Set
public:
property Decimal Width {
    Decimal get ();
    void set (Decimal value);
}
member Width : decimal with get, set

/** @property */
public Decimal get_Width()
/** @property */
public void set_Width(Decimal value)

function get_Width();
function set_Width(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


ItemDimensionInfos Methods

The CSharpPublicApiExampleProgramItemDimensionInfos type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.FromJson Method

CSharpPublicApiExampleProgramItemDimensionInfosFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemDimensionInfos FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemDimensionInfos
public:
static CSharpPublicApiExampleProgramItemDimensionInfos^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemDimensionInfos

public static CSharpPublicApiExampleProgramItemDimensionInfos FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemDimensionInfos.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemDimensionInfos
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemDimensionInfosRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.ToJson Method

CSharpPublicApiExampleProgramItemDimensionInfosToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


ItemDimensionInfos Events

The CSharpPublicApiExampleProgramItemDimensionInfos type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos.PropertyChanged Event

CSharpPublicApiExampleProgramItemDimensionInfosPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


ItemDimensionInfos Fields

Fields
 | Name | Description
Private field | _depth |
Private field | _dimensionUnit |
Private field | _height |
Private field | _maxVolume |
Private field | _volumeUnit |
Private field | _weight |
Private field | _weightUnit |
Private field | _width |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._depth Field

CSharpPublicApiExampleProgramItemDimensionInfos_depth Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _depth
Private _depth As Decimal
private:
Decimal _depth
val mutable private _depth: decimal
private Decimal _depth
var _depth

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._dimensionUnit Field

CSharpPublicApiExampleProgramItemDimensionInfos_dimensionUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _dimensionUnit
Private _dimensionUnit As String
private:
String^ _dimensionUnit
val mutable private _dimensionUnit: string
private String _dimensionUnit
var _dimensionUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._height Field

CSharpPublicApiExampleProgramItemDimensionInfos_height Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _height
Private _height As Decimal
private:
Decimal _height
val mutable private _height: decimal
private Decimal _height
var _height

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._maxVolume Field

CSharpPublicApiExampleProgramItemDimensionInfos_maxVolume Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _maxVolume
Private _maxVolume As Decimal
private:
Decimal _maxVolume
val mutable private _maxVolume: decimal
private Decimal _maxVolume
var _maxVolume

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._volumeUnit Field

CSharpPublicApiExampleProgramItemDimensionInfos_volumeUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _volumeUnit
Private _volumeUnit As String
private:
String^ _volumeUnit
val mutable private _volumeUnit: string
private String _volumeUnit
var _volumeUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._weight Field

CSharpPublicApiExampleProgramItemDimensionInfos_weight Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _weight
Private _weight As Decimal
private:
Decimal _weight
val mutable private _weight: decimal
private Decimal _weight
var _weight

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._weightUnit Field

CSharpPublicApiExampleProgramItemDimensionInfos_weightUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _weightUnit
Private _weightUnit As String
private:
String^ _weightUnit
val mutable private _weightUnit: string
private String _weightUnit
var _weightUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemDimensionInfos._width Field

CSharpPublicApiExampleProgramItemDimensionInfos_width Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _width
Private _width As Decimal
private:
Decimal _width
val mutable private _width: decimal
private Decimal _width
var _width

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemDimensionInfos Class


CSharpPublicApiExampleProgram.ItemInventorysInfo Class

CSharpPublicApiExampleProgramItemInventorysInfo Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemInventorysInfo

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemInventorysInfo : INotifyPropertyChanged
Public Class ItemInventorysInfo
    Implements INotifyPropertyChanged
public ref class ItemInventorysInfo : INotifyPropertyChanged
type ItemInventorysInfo =
    class
        interface INotifyPropertyChanged
    end
public class ItemInventorysInfo implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemInventorysInfo = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemInventorysInfo',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemInventorysInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemInventorysInfo | Initializes a new instance of the CSharpPublicApiExampleProgramItemInventorysInfo class
Top
Properties
 | Name | Description
Public property | AlternateItemNumber |
Public property | AttachmentInfo |
Public property | AverageCost |
Public property | CategoryDescription |
Public property | CheckOutLengthMinutes |
Public property | Cost |
Public property | CostMethod |
Public property | CustomFields |
Public property | DimensionInfo |
Public property | ItemDescription |
Public property | ItemLocationSettings |
Public property | ItemNumber |
Public property | ItemPrices |
Public property | ItemVendors |
Public property | ListPrice |
Public property | ManufacturerName |
Public property | PurchaseUnit |
Public property | RowNumber |
Public property | SalesPrice |
Public property | SalesUnit |
Public property | StockingUnit |
Public property | TaxCode |
Public property | TrackbyInfo |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _alternateItemNumber |
Private field | _attachmentInfo |
Private field | _averageCost |
Private field | _categoryDescription |
Private field | _checkOutLengthMinutes |
Private field | _cost |
Private field | _costMethod |
Private field | _customFields |
Private field | _dimensionInfo |
Private field | _itemDescription |
Private field | _itemLocationSettings |
Private field | _itemNumber |
Private field | _itemPrices |
Private field | _itemVendors |
Private field | _listPrice |
Private field | _manufacturerName |
Private field | _purchaseUnit |
Private field | _rowNumber |
Private field | _salesPrice |
Private field | _salesUnit |
Private field | _stockingUnit |
Private field | _taxCode |
Private field | _trackbyInfo |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemInventorysInfo Constructor

CSharpPublicApiExampleProgramItemInventorysInfo Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemInventorysInfo class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemInventorysInfo()
Public Sub New
public:
ItemInventorysInfo()
new : unit -> ItemInventorysInfo
public ItemInventorysInfo()
Wasp.Cloud.Inventory.Example.ItemInventorysInfo = function();
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


ItemInventorysInfo Properties

The CSharpPublicApiExampleProgramItemInventorysInfo type exposes the following members.

Properties
 | Name | Description
Public property | AlternateItemNumber |
Public property | AttachmentInfo |
Public property | AverageCost |
Public property | CategoryDescription |
Public property | CheckOutLengthMinutes |
Public property | Cost |
Public property | CostMethod |
Public property | CustomFields |
Public property | DimensionInfo |
Public property | ItemDescription |
Public property | ItemLocationSettings |
Public property | ItemNumber |
Public property | ItemPrices |
Public property | ItemVendors |
Public property | ListPrice |
Public property | ManufacturerName |
Public property | PurchaseUnit |
Public property | RowNumber |
Public property | SalesPrice |
Public property | SalesUnit |
Public property | StockingUnit |
Public property | TaxCode |
Public property | TrackbyInfo |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.AlternateItemNumber Property

CSharpPublicApiExampleProgramItemInventorysInfoAlternateItemNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string AlternateItemNumber { get; set; }
Public Property AlternateItemNumber As String
    Get
    Set
public:
property String^ AlternateItemNumber {
    String^ get ();
    void set (String^ value);
}
member AlternateItemNumber : string with get, set

/** @property */
public String get_AlternateItemNumber()
/** @property */
public void set_AlternateItemNumber(String value)

function get_AlternateItemNumber();
function set_AlternateItemNumber(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.AttachmentInfo Property

CSharpPublicApiExampleProgramItemInventorysInfoAttachmentInfo Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramItemAttachmentInfo AttachmentInfo { get; set; }
Public Property AttachmentInfo As CSharpPublicApiExampleProgramItemAttachmentInfo
    Get
    Set
public:
property CSharpPublicApiExampleProgramItemAttachmentInfo^ AttachmentInfo {
    CSharpPublicApiExampleProgramItemAttachmentInfo^ get ();
    void set (CSharpPublicApiExampleProgramItemAttachmentInfo^ value);
}
member AttachmentInfo : CSharpPublicApiExampleProgramItemAttachmentInfo with get, set

/** @property */
public CSharpPublicApiExampleProgramItemAttachmentInfo get_AttachmentInfo()
/** @property */
public void set_AttachmentInfo(CSharpPublicApiExampleProgramItemAttachmentInfo value)

function get_AttachmentInfo();
function set_AttachmentInfo(value);

Property Value

Type: CSharpPublicApiExampleProgramItemAttachmentInfo
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.AverageCost Property

CSharpPublicApiExampleProgramItemInventorysInfoAverageCost Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal AverageCost { get; set; }
Public Property AverageCost As Decimal
    Get
    Set
public:
property Decimal AverageCost {
    Decimal get ();
    void set (Decimal value);
}
member AverageCost : decimal with get, set

/** @property */
public Decimal get_AverageCost()
/** @property */
public void set_AverageCost(Decimal value)

function get_AverageCost();
function set_AverageCost(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.CategoryDescription Property

CSharpPublicApiExampleProgramItemInventorysInfoCategoryDescription Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string CategoryDescription { get; set; }
Public Property CategoryDescription As String
    Get
    Set
public:
property String^ CategoryDescription {
    String^ get ();
    void set (String^ value);
}
member CategoryDescription : string with get, set

/** @property */
public String get_CategoryDescription()
/** @property */
public void set_CategoryDescription(String value)

function get_CategoryDescription();
function set_CategoryDescription(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.CheckOutLengthMinutes Property

CSharpPublicApiExampleProgramItemInventorysInfoCheckOutLengthMinutes Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int CheckOutLengthMinutes { get; set; }
Public Property CheckOutLengthMinutes As Integer
    Get
    Set
public:
property int CheckOutLengthMinutes {
    int get ();
    void set (int value);
}
member CheckOutLengthMinutes : int with get, set

/** @property */
public int get_CheckOutLengthMinutes()
/** @property */
public void set_CheckOutLengthMinutes(int value)

function get_CheckOutLengthMinutes();
function set_CheckOutLengthMinutes(value);

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.Cost Property

CSharpPublicApiExampleProgramItemInventorysInfoCost Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal Cost { get; set; }
Public Property Cost As Decimal
    Get
    Set
public:
property Decimal Cost {
    Decimal get ();
    void set (Decimal value);
}
member Cost : decimal with get, set

/** @property */
public Decimal get_Cost()
/** @property */
public void set_Cost(Decimal value)

function get_Cost();
function set_Cost(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.CostMethod Property

CSharpPublicApiExampleProgramItemInventorysInfoCostMethod Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramCostMethodEnums CostMethod { get; set; }
Public Property CostMethod As CSharpPublicApiExampleProgramCostMethodEnums
    Get
    Set
public:
property CSharpPublicApiExampleProgramCostMethodEnums CostMethod {
    CSharpPublicApiExampleProgramCostMethodEnums get ();
    void set (CSharpPublicApiExampleProgramCostMethodEnums value);
}
member CostMethod : CSharpPublicApiExampleProgramCostMethodEnums with get, set

/** @property */
public CSharpPublicApiExampleProgramCostMethodEnums get_CostMethod()
/** @property */
public void set_CostMethod(CSharpPublicApiExampleProgramCostMethodEnums value)

function get_CostMethod();
function set_CostMethod(value);

Property Value

Type: CSharpPublicApiExampleProgramCostMethodEnums
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.CustomFields Property

CSharpPublicApiExampleProgramItemInventorysInfoCustomFields Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<DcfValueInfo> CustomFields { get; set; }
Public Property CustomFields As List(Of DcfValueInfo)
    Get
    Set
public:
property List<DcfValueInfo^>^ CustomFields {
    List<DcfValueInfo^>^ get ();
    void set (List<DcfValueInfo^>^ value);
}
member CustomFields : List<DcfValueInfo> with get, set

/** @property */
public List<DcfValueInfo> get_CustomFields()
/** @property */
public void set_CustomFields(List<DcfValueInfo> value)

function get_CustomFields();
function set_CustomFields(value);

Property Value

Type: List DcfValueInfo
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.DimensionInfo Property

CSharpPublicApiExampleProgramItemInventorysInfoDimensionInfo Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramItemDimensionInfos DimensionInfo { get; set; }
Public Property DimensionInfo As CSharpPublicApiExampleProgramItemDimensionInfos
    Get
    Set
public:
property CSharpPublicApiExampleProgramItemDimensionInfos^ DimensionInfo {
    CSharpPublicApiExampleProgramItemDimensionInfos^ get ();
    void set (CSharpPublicApiExampleProgramItemDimensionInfos^ value);
}
member DimensionInfo : CSharpPublicApiExampleProgramItemDimensionInfos with get, set

/** @property */
public CSharpPublicApiExampleProgramItemDimensionInfos get_DimensionInfo()
/** @property */
public void set_DimensionInfo(CSharpPublicApiExampleProgramItemDimensionInfos value)

function get_DimensionInfo();
function set_DimensionInfo(value);

Property Value

Type: CSharpPublicApiExampleProgramItemDimensionInfos
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ItemDescription Property

CSharpPublicApiExampleProgramItemInventorysInfoItemDescription Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ItemDescription { get; set; }
Public Property ItemDescription As String
    Get
    Set
public:
property String^ ItemDescription {
    String^ get ();
    void set (String^ value);
}
member ItemDescription : string with get, set

/** @property */
public String get_ItemDescription()
/** @property */
public void set_ItemDescription(String value)

function get_ItemDescription();
function set_ItemDescription(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ItemLocationSettings Property

CSharpPublicApiExampleProgramItemInventorysInfoItemLocationSettings Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<CSharpPublicApiExampleProgramItemLocationSettings> ItemLocationSettings { get; set; }
Public Property ItemLocationSettings As List(Of CSharpPublicApiExampleProgramItemLocationSettings)
    Get
    Set
public:
property List<CSharpPublicApiExampleProgramItemLocationSettings^>^ ItemLocationSettings {
    List<CSharpPublicApiExampleProgramItemLocationSettings^>^ get ();
    void set (List<CSharpPublicApiExampleProgramItemLocationSettings^>^ value);
}
member ItemLocationSettings : List<CSharpPublicApiExampleProgramItemLocationSettings> with get, set

/** @property */
public List<CSharpPublicApiExampleProgramItemLocationSettings> get_ItemLocationSettings()
/** @property */
public void set_ItemLocationSettings(List<CSharpPublicApiExampleProgramItemLocationSettings> value)

function get_ItemLocationSettings();
function set_ItemLocationSettings(value);

Property Value

Type: List CSharpPublicApiExampleProgramItemLocationSettings
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ItemNumber Property

CSharpPublicApiExampleProgramItemInventorysInfoItemNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ItemNumber { get; set; }
Public Property ItemNumber As String
    Get
    Set
public:
property String^ ItemNumber {
    String^ get ();
    void set (String^ value);
}
member ItemNumber : string with get, set

/** @property */
public String get_ItemNumber()
/** @property */
public void set_ItemNumber(String value)

function get_ItemNumber();
function set_ItemNumber(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ItemPrices Property

CSharpPublicApiExampleProgramItemInventorysInfoItemPrices Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<CSharpPublicApiExampleProgramItemPrices> ItemPrices { get; set; }
Public Property ItemPrices As List(Of CSharpPublicApiExampleProgramItemPrices)
    Get
    Set
public:
property List<CSharpPublicApiExampleProgramItemPrices^>^ ItemPrices {
    List<CSharpPublicApiExampleProgramItemPrices^>^ get ();
    void set (List<CSharpPublicApiExampleProgramItemPrices^>^ value);
}
member ItemPrices : List<CSharpPublicApiExampleProgramItemPrices> with get, set

/** @property */
public List<CSharpPublicApiExampleProgramItemPrices> get_ItemPrices()
/** @property */
public void set_ItemPrices(List<CSharpPublicApiExampleProgramItemPrices> value)

function get_ItemPrices();
function set_ItemPrices(value);

Property Value

Type: List CSharpPublicApiExampleProgramItemPrices
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ItemVendors Property

CSharpPublicApiExampleProgramItemInventorysInfoItemVendors Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<CSharpPublicApiExampleProgramItemVendorInfo> ItemVendors { get; set; }
Public Property ItemVendors As List(Of CSharpPublicApiExampleProgramItemVendorInfo)
    Get
    Set
public:
property List<CSharpPublicApiExampleProgramItemVendorInfo^>^ ItemVendors {
    List<CSharpPublicApiExampleProgramItemVendorInfo^>^ get ();
    void set (List<CSharpPublicApiExampleProgramItemVendorInfo^>^ value);
}
member ItemVendors : List<CSharpPublicApiExampleProgramItemVendorInfo> with get, set

/** @property */
public List<CSharpPublicApiExampleProgramItemVendorInfo> get_ItemVendors()
/** @property */
public void set_ItemVendors(List<CSharpPublicApiExampleProgramItemVendorInfo> value)

function get_ItemVendors();
function set_ItemVendors(value);

Property Value

Type: List CSharpPublicApiExampleProgramItemVendorInfo
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ListPrice Property

CSharpPublicApiExampleProgramItemInventorysInfoListPrice Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal ListPrice { get; set; }
Public Property ListPrice As Decimal
    Get
    Set
public:
property Decimal ListPrice {
    Decimal get ();
    void set (Decimal value);
}
member ListPrice : decimal with get, set

/** @property */
public Decimal get_ListPrice()
/** @property */
public void set_ListPrice(Decimal value)

function get_ListPrice();
function set_ListPrice(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ManufacturerName Property

CSharpPublicApiExampleProgramItemInventorysInfoManufacturerName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ManufacturerName { get; set; }
Public Property ManufacturerName As String
    Get
    Set
public:
property String^ ManufacturerName {
    String^ get ();
    void set (String^ value);
}
member ManufacturerName : string with get, set

/** @property */
public String get_ManufacturerName()
/** @property */
public void set_ManufacturerName(String value)

function get_ManufacturerName();
function set_ManufacturerName(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.PurchaseUnit Property

CSharpPublicApiExampleProgramItemInventorysInfoPurchaseUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string PurchaseUnit { get; set; }
Public Property PurchaseUnit As String
    Get
    Set
public:
property String^ PurchaseUnit {
    String^ get ();
    void set (String^ value);
}
member PurchaseUnit : string with get, set

/** @property */
public String get_PurchaseUnit()
/** @property */
public void set_PurchaseUnit(String value)

function get_PurchaseUnit();
function set_PurchaseUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.RowNumber Property

CSharpPublicApiExampleProgramItemInventorysInfoRowNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public long RowNumber { get; set; }
Public Property RowNumber As Long
    Get
    Set
public:
property long long RowNumber {
    long long get ();
    void set (long long value);
}
member RowNumber : int64 with get, set

/** @property */
public long get_RowNumber()
/** @property */
public void set_RowNumber(long value)

function get_RowNumber();
function set_RowNumber(value);

Property Value

Type: Int64
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.SalesPrice Property

CSharpPublicApiExampleProgramItemInventorysInfoSalesPrice Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal SalesPrice { get; set; }
Public Property SalesPrice As Decimal
    Get
    Set
public:
property Decimal SalesPrice {
    Decimal get ();
    void set (Decimal value);
}
member SalesPrice : decimal with get, set

/** @property */
public Decimal get_SalesPrice()
/** @property */
public void set_SalesPrice(Decimal value)

function get_SalesPrice();
function set_SalesPrice(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.SalesUnit Property

CSharpPublicApiExampleProgramItemInventorysInfoSalesUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string SalesUnit { get; set; }
Public Property SalesUnit As String
    Get
    Set
public:
property String^ SalesUnit {
    String^ get ();
    void set (String^ value);
}
member SalesUnit : string with get, set

/** @property */
public String get_SalesUnit()
/** @property */
public void set_SalesUnit(String value)

function get_SalesUnit();
function set_SalesUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.StockingUnit Property

CSharpPublicApiExampleProgramItemInventorysInfoStockingUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string StockingUnit { get; set; }
Public Property StockingUnit As String
    Get
    Set
public:
property String^ StockingUnit {
    String^ get ();
    void set (String^ value);
}
member StockingUnit : string with get, set

/** @property */
public String get_StockingUnit()
/** @property */
public void set_StockingUnit(String value)

function get_StockingUnit();
function set_StockingUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.TaxCode Property

CSharpPublicApiExampleProgramItemInventorysInfoTaxCode Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string TaxCode { get; set; }
Public Property TaxCode As String
    Get
    Set
public:
property String^ TaxCode {
    String^ get ();
    void set (String^ value);
}
member TaxCode : string with get, set

/** @property */
public String get_TaxCode()
/** @property */
public void set_TaxCode(String value)

function get_TaxCode();
function set_TaxCode(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.TrackbyInfo Property

CSharpPublicApiExampleProgramItemInventorysInfoTrackbyInfo Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramItemTrackbyInfos TrackbyInfo { get; set; }
Public Property TrackbyInfo As CSharpPublicApiExampleProgramItemTrackbyInfos
    Get
    Set
public:
property CSharpPublicApiExampleProgramItemTrackbyInfos^ TrackbyInfo {
    CSharpPublicApiExampleProgramItemTrackbyInfos^ get ();
    void set (CSharpPublicApiExampleProgramItemTrackbyInfos^ value);
}
member TrackbyInfo : CSharpPublicApiExampleProgramItemTrackbyInfos with get, set

/** @property */
public CSharpPublicApiExampleProgramItemTrackbyInfos get_TrackbyInfo()
/** @property */
public void set_TrackbyInfo(CSharpPublicApiExampleProgramItemTrackbyInfos value)

function get_TrackbyInfo();
function set_TrackbyInfo(value);

Property Value

Type: CSharpPublicApiExampleProgramItemTrackbyInfos
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


ItemInventorysInfo Methods

The CSharpPublicApiExampleProgramItemInventorysInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.FromJson Method

CSharpPublicApiExampleProgramItemInventorysInfoFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemInventorysInfo FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemInventorysInfo
public:
static CSharpPublicApiExampleProgramItemInventorysInfo^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemInventorysInfo

public static CSharpPublicApiExampleProgramItemInventorysInfo FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemInventorysInfo.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemInventorysInfo
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemInventorysInfoRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.ToJson Method

CSharpPublicApiExampleProgramItemInventorysInfoToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


ItemInventorysInfo Events

The CSharpPublicApiExampleProgramItemInventorysInfo type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo.PropertyChanged Event

CSharpPublicApiExampleProgramItemInventorysInfoPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


ItemInventorysInfo Fields

Fields
 | Name | Description
Private field | _alternateItemNumber |
Private field | _attachmentInfo |
Private field | _averageCost |
Private field | _categoryDescription |
Private field | _checkOutLengthMinutes |
Private field | _cost |
Private field | _costMethod |
Private field | _customFields |
Private field | _dimensionInfo |
Private field | _itemDescription |
Private field | _itemLocationSettings |
Private field | _itemNumber |
Private field | _itemPrices |
Private field | _itemVendors |
Private field | _listPrice |
Private field | _manufacturerName |
Private field | _purchaseUnit |
Private field | _rowNumber |
Private field | _salesPrice |
Private field | _salesUnit |
Private field | _stockingUnit |
Private field | _taxCode |
Private field | _trackbyInfo |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._alternateItemNumber Field

CSharpPublicApiExampleProgramItemInventorysInfo_alternateItemNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _alternateItemNumber
Private _alternateItemNumber As String
private:
String^ _alternateItemNumber
val mutable private _alternateItemNumber: string
private String _alternateItemNumber
var _alternateItemNumber

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._attachmentInfo Field

CSharpPublicApiExampleProgramItemInventorysInfo_attachmentInfo Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramItemAttachmentInfo _attachmentInfo
Private _attachmentInfo As CSharpPublicApiExampleProgramItemAttachmentInfo
private:
CSharpPublicApiExampleProgramItemAttachmentInfo^ _attachmentInfo
val mutable private _attachmentInfo: CSharpPublicApiExampleProgramItemAttachmentInfo
private CSharpPublicApiExampleProgramItemAttachmentInfo _attachmentInfo
var _attachmentInfo

Field Value

Type: CSharpPublicApiExampleProgramItemAttachmentInfo
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._averageCost Field

CSharpPublicApiExampleProgramItemInventorysInfo_averageCost Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _averageCost
Private _averageCost As Decimal
private:
Decimal _averageCost
val mutable private _averageCost: decimal
private Decimal _averageCost
var _averageCost

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._categoryDescription Field

CSharpPublicApiExampleProgramItemInventorysInfo_categoryDescription Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _categoryDescription
Private _categoryDescription As String
private:
String^ _categoryDescription
val mutable private _categoryDescription: string
private String _categoryDescription
var _categoryDescription

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._checkOutLengthMinutes Field

CSharpPublicApiExampleProgramItemInventorysInfo_checkOutLengthMinutes Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private int _checkOutLengthMinutes
Private _checkOutLengthMinutes As Integer
private:
int _checkOutLengthMinutes
val mutable private _checkOutLengthMinutes: int
private int _checkOutLengthMinutes
var _checkOutLengthMinutes

Field Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._cost Field

CSharpPublicApiExampleProgramItemInventorysInfo_cost Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _cost
Private _cost As Decimal
private:
Decimal _cost
val mutable private _cost: decimal
private Decimal _cost
var _cost

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._costMethod Field

CSharpPublicApiExampleProgramItemInventorysInfo_costMethod Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramCostMethodEnums _costMethod
Private _costMethod As CSharpPublicApiExampleProgramCostMethodEnums
private:
CSharpPublicApiExampleProgramCostMethodEnums _costMethod
val mutable private _costMethod: CSharpPublicApiExampleProgramCostMethodEnums
private CSharpPublicApiExampleProgramCostMethodEnums _costMethod
var _costMethod

Field Value

Type: CSharpPublicApiExampleProgramCostMethodEnums
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._customFields Field

CSharpPublicApiExampleProgramItemInventorysInfo_customFields Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<DcfValueInfo> _customFields
Private _customFields As List(Of DcfValueInfo)
private:
List<DcfValueInfo^>^ _customFields
val mutable private _customFields: List<DcfValueInfo>
private List<DcfValueInfo> _customFields
var _customFields

Field Value

Type: List DcfValueInfo
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._dimensionInfo Field

CSharpPublicApiExampleProgramItemInventorysInfo_dimensionInfo Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramItemDimensionInfos _dimensionInfo
Private _dimensionInfo As CSharpPublicApiExampleProgramItemDimensionInfos
private:
CSharpPublicApiExampleProgramItemDimensionInfos^ _dimensionInfo
val mutable private _dimensionInfo: CSharpPublicApiExampleProgramItemDimensionInfos
private CSharpPublicApiExampleProgramItemDimensionInfos _dimensionInfo
var _dimensionInfo

Field Value

Type: CSharpPublicApiExampleProgramItemDimensionInfos
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._itemDescription Field

CSharpPublicApiExampleProgramItemInventorysInfo_itemDescription Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _itemDescription
Private _itemDescription As String
private:
String^ _itemDescription
val mutable private _itemDescription: string
private String _itemDescription
var _itemDescription

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._itemLocationSettings Field

CSharpPublicApiExampleProgramItemInventorysInfo_itemLocationSettings Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<CSharpPublicApiExampleProgramItemLocationSettings> _itemLocationSettings
Private _itemLocationSettings As List(Of CSharpPublicApiExampleProgramItemLocationSettings)
private:
List<CSharpPublicApiExampleProgramItemLocationSettings^>^ _itemLocationSettings
val mutable private _itemLocationSettings: List<CSharpPublicApiExampleProgramItemLocationSettings>
private List<CSharpPublicApiExampleProgramItemLocationSettings> _itemLocationSettings
var _itemLocationSettings

Field Value

Type: List CSharpPublicApiExampleProgramItemLocationSettings
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._itemNumber Field

CSharpPublicApiExampleProgramItemInventorysInfo_itemNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _itemNumber
Private _itemNumber As String
private:
String^ _itemNumber
val mutable private _itemNumber: string
private String _itemNumber
var _itemNumber

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._itemPrices Field

CSharpPublicApiExampleProgramItemInventorysInfo_itemPrices Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<CSharpPublicApiExampleProgramItemPrices> _itemPrices
Private _itemPrices As List(Of CSharpPublicApiExampleProgramItemPrices)
private:
List<CSharpPublicApiExampleProgramItemPrices^>^ _itemPrices
val mutable private _itemPrices: List<CSharpPublicApiExampleProgramItemPrices>
private List<CSharpPublicApiExampleProgramItemPrices> _itemPrices
var _itemPrices

Field Value

Type: List CSharpPublicApiExampleProgramItemPrices
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._itemVendors Field

CSharpPublicApiExampleProgramItemInventorysInfo_itemVendors Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<CSharpPublicApiExampleProgramItemVendorInfo> _itemVendors
Private _itemVendors As List(Of CSharpPublicApiExampleProgramItemVendorInfo)
private:
List<CSharpPublicApiExampleProgramItemVendorInfo^>^ _itemVendors
val mutable private _itemVendors: List<CSharpPublicApiExampleProgramItemVendorInfo>
private List<CSharpPublicApiExampleProgramItemVendorInfo> _itemVendors
var _itemVendors

Field Value

Type: List CSharpPublicApiExampleProgramItemVendorInfo
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._listPrice Field

CSharpPublicApiExampleProgramItemInventorysInfo_listPrice Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _listPrice
Private _listPrice As Decimal
private:
Decimal _listPrice
val mutable private _listPrice: decimal
private Decimal _listPrice
var _listPrice

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._manufacturerName Field

CSharpPublicApiExampleProgramItemInventorysInfo_manufacturerName Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _manufacturerName
Private _manufacturerName As String
private:
String^ _manufacturerName
val mutable private _manufacturerName: string
private String _manufacturerName
var _manufacturerName

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._purchaseUnit Field

CSharpPublicApiExampleProgramItemInventorysInfo_purchaseUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _purchaseUnit
Private _purchaseUnit As String
private:
String^ _purchaseUnit
val mutable private _purchaseUnit: string
private String _purchaseUnit
var _purchaseUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._rowNumber Field

CSharpPublicApiExampleProgramItemInventorysInfo_rowNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private long _rowNumber
Private _rowNumber As Long
private:
long long _rowNumber
val mutable private _rowNumber: int64
private long _rowNumber
var _rowNumber

Field Value

Type: Int64
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._salesPrice Field

CSharpPublicApiExampleProgramItemInventorysInfo_salesPrice Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _salesPrice
Private _salesPrice As Decimal
private:
Decimal _salesPrice
val mutable private _salesPrice: decimal
private Decimal _salesPrice
var _salesPrice

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._salesUnit Field

CSharpPublicApiExampleProgramItemInventorysInfo_salesUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _salesUnit
Private _salesUnit As String
private:
String^ _salesUnit
val mutable private _salesUnit: string
private String _salesUnit
var _salesUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._stockingUnit Field

CSharpPublicApiExampleProgramItemInventorysInfo_stockingUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _stockingUnit
Private _stockingUnit As String
private:
String^ _stockingUnit
val mutable private _stockingUnit: string
private String _stockingUnit
var _stockingUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._taxCode Field

CSharpPublicApiExampleProgramItemInventorysInfo_taxCode Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _taxCode
Private _taxCode As String
private:
String^ _taxCode
val mutable private _taxCode: string
private String _taxCode
var _taxCode

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemInventorysInfo._trackbyInfo Field

CSharpPublicApiExampleProgramItemInventorysInfo_trackbyInfo Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramItemTrackbyInfos _trackbyInfo
Private _trackbyInfo As CSharpPublicApiExampleProgramItemTrackbyInfos
private:
CSharpPublicApiExampleProgramItemTrackbyInfos^ _trackbyInfo
val mutable private _trackbyInfo: CSharpPublicApiExampleProgramItemTrackbyInfos
private CSharpPublicApiExampleProgramItemTrackbyInfos _trackbyInfo
var _trackbyInfo

Field Value

Type: CSharpPublicApiExampleProgramItemTrackbyInfos
See Also

Reference

CSharpPublicApiExampleProgramItemInventorysInfo Class


CSharpPublicApiExampleProgram.ItemLocationSettings Class

CSharpPublicApiExampleProgramItemLocationSettings Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemLocationSettings

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemLocationSettings : INotifyPropertyChanged
Public Class ItemLocationSettings
    Implements INotifyPropertyChanged
public ref class ItemLocationSettings : INotifyPropertyChanged
type ItemLocationSettings =
    class
        interface INotifyPropertyChanged
    end
public class ItemLocationSettings implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemLocationSettings = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemLocationSettings',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemLocationSettings type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemLocationSettings | Initializes a new instance of the CSharpPublicApiExampleProgramItemLocationSettings class
Top
Properties
 | Name | Description
Public property | LocationCode |
Public property | MaximumQuantity |
Public property | MinimumQuantity |
Public property | PrimaryLocation |
Public property | ReorderQuantity |
Public property | SiteName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _locationCode |
Private field | _maximumQuantity |
Private field | _minimumQuantity |
Private field | _primaryLocation |
Private field | _reorderQuantity |
Private field | _siteName |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemLocationSettings Constructor

CSharpPublicApiExampleProgramItemLocationSettings Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemLocationSettings class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemLocationSettings()
Public Sub New
public:
ItemLocationSettings()
new : unit -> ItemLocationSettings
public ItemLocationSettings()
Wasp.Cloud.Inventory.Example.ItemLocationSettings = function();
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


ItemLocationSettings Properties

The CSharpPublicApiExampleProgramItemLocationSettings type exposes the following members.

Properties
 | Name | Description
Public property | LocationCode |
Public property | MaximumQuantity |
Public property | MinimumQuantity |
Public property | PrimaryLocation |
Public property | ReorderQuantity |
Public property | SiteName |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.LocationCode Property

CSharpPublicApiExampleProgramItemLocationSettingsLocationCode Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string LocationCode { get; set; }
Public Property LocationCode As String
    Get
    Set
public:
property String^ LocationCode {
    String^ get ();
    void set (String^ value);
}
member LocationCode : string with get, set

/** @property */
public String get_LocationCode()
/** @property */
public void set_LocationCode(String value)

function get_LocationCode();
function set_LocationCode(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.MaximumQuantity Property

CSharpPublicApiExampleProgramItemLocationSettingsMaximumQuantity Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal MaximumQuantity { get; set; }
Public Property MaximumQuantity As Decimal
    Get
    Set
public:
property Decimal MaximumQuantity {
    Decimal get ();
    void set (Decimal value);
}
member MaximumQuantity : decimal with get, set

/** @property */
public Decimal get_MaximumQuantity()
/** @property */
public void set_MaximumQuantity(Decimal value)

function get_MaximumQuantity();
function set_MaximumQuantity(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.MinimumQuantity Property

CSharpPublicApiExampleProgramItemLocationSettingsMinimumQuantity Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal MinimumQuantity { get; set; }
Public Property MinimumQuantity As Decimal
    Get
    Set
public:
property Decimal MinimumQuantity {
    Decimal get ();
    void set (Decimal value);
}
member MinimumQuantity : decimal with get, set

/** @property */
public Decimal get_MinimumQuantity()
/** @property */
public void set_MinimumQuantity(Decimal value)

function get_MinimumQuantity();
function set_MinimumQuantity(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.PrimaryLocation Property

CSharpPublicApiExampleProgramItemLocationSettingsPrimaryLocation Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool PrimaryLocation { get; set; }
Public Property PrimaryLocation As Boolean
    Get
    Set
public:
property bool PrimaryLocation {
    bool get ();
    void set (bool value);
}
member PrimaryLocation : bool with get, set

/** @property */
public boolean get_PrimaryLocation()
/** @property */
public void set_PrimaryLocation(boolean value)

function get_PrimaryLocation();
function set_PrimaryLocation(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.ReorderQuantity Property

CSharpPublicApiExampleProgramItemLocationSettingsReorderQuantity Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal ReorderQuantity { get; set; }
Public Property ReorderQuantity As Decimal
    Get
    Set
public:
property Decimal ReorderQuantity {
    Decimal get ();
    void set (Decimal value);
}
member ReorderQuantity : decimal with get, set

/** @property */
public Decimal get_ReorderQuantity()
/** @property */
public void set_ReorderQuantity(Decimal value)

function get_ReorderQuantity();
function set_ReorderQuantity(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.SiteName Property

CSharpPublicApiExampleProgramItemLocationSettingsSiteName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string SiteName { get; set; }
Public Property SiteName As String
    Get
    Set
public:
property String^ SiteName {
    String^ get ();
    void set (String^ value);
}
member SiteName : string with get, set

/** @property */
public String get_SiteName()
/** @property */
public void set_SiteName(String value)

function get_SiteName();
function set_SiteName(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


ItemLocationSettings Methods

The CSharpPublicApiExampleProgramItemLocationSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.FromJson Method

CSharpPublicApiExampleProgramItemLocationSettingsFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemLocationSettings FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemLocationSettings
public:
static CSharpPublicApiExampleProgramItemLocationSettings^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemLocationSettings

public static CSharpPublicApiExampleProgramItemLocationSettings FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemLocationSettings.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemLocationSettings
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemLocationSettingsRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.ToJson Method

CSharpPublicApiExampleProgramItemLocationSettingsToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


ItemLocationSettings Events

The CSharpPublicApiExampleProgramItemLocationSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings.PropertyChanged Event

CSharpPublicApiExampleProgramItemLocationSettingsPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


ItemLocationSettings Fields

Fields
 | Name | Description
Private field | _locationCode |
Private field | _maximumQuantity |
Private field | _minimumQuantity |
Private field | _primaryLocation |
Private field | _reorderQuantity |
Private field | _siteName |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings._locationCode Field

CSharpPublicApiExampleProgramItemLocationSettings_locationCode Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _locationCode
Private _locationCode As String
private:
String^ _locationCode
val mutable private _locationCode: string
private String _locationCode
var _locationCode

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings._maximumQuantity Field

CSharpPublicApiExampleProgramItemLocationSettings_maximumQuantity Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _maximumQuantity
Private _maximumQuantity As Decimal
private:
Decimal _maximumQuantity
val mutable private _maximumQuantity: decimal
private Decimal _maximumQuantity
var _maximumQuantity

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings._minimumQuantity Field

CSharpPublicApiExampleProgramItemLocationSettings_minimumQuantity Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _minimumQuantity
Private _minimumQuantity As Decimal
private:
Decimal _minimumQuantity
val mutable private _minimumQuantity: decimal
private Decimal _minimumQuantity
var _minimumQuantity

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings._primaryLocation Field

CSharpPublicApiExampleProgramItemLocationSettings_primaryLocation Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _primaryLocation
Private _primaryLocation As Boolean
private:
bool _primaryLocation
val mutable private _primaryLocation: bool
private boolean _primaryLocation
var _primaryLocation

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings._reorderQuantity Field

CSharpPublicApiExampleProgramItemLocationSettings_reorderQuantity Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _reorderQuantity
Private _reorderQuantity As Decimal
private:
Decimal _reorderQuantity
val mutable private _reorderQuantity: decimal
private Decimal _reorderQuantity
var _reorderQuantity

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemLocationSettings._siteName Field

CSharpPublicApiExampleProgramItemLocationSettings_siteName Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _siteName
Private _siteName As String
private:
String^ _siteName
val mutable private _siteName: string
private String _siteName
var _siteName

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemLocationSettings Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos Class

CSharpPublicApiExampleProgramItemNonInventoryInfos Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemNonInventoryInfos

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemNonInventoryInfos : INotifyPropertyChanged
Public Class ItemNonInventoryInfos
    Implements INotifyPropertyChanged
public ref class ItemNonInventoryInfos : INotifyPropertyChanged
type ItemNonInventoryInfos =
    class
        interface INotifyPropertyChanged
    end
public class ItemNonInventoryInfos implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemNonInventoryInfos = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemNonInventoryInfos',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemNonInventoryInfos type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemNonInventoryInfos | Initializes a new instance of the CSharpPublicApiExampleProgramItemNonInventoryInfos class
Top
Properties
 | Name | Description
Public property | AlternateItemNumber |
Public property | AttachmentInfo |
Public property | AverageCost |
Public property | CategoryDescription |
Public property | Cost |
Public property | CostMethod |
Public property | CustomFields |
Public property | DimensionInfo |
Public property | ItemDescription |
Public property | ItemLocationSettings |
Public property | ItemNumber |
Public property | ItemVendors |
Public property | ListPrice |
Public property | ManufacturerName |
Public property | PurchaseUnit |
Public property | RowNumber |
Public property | SalesPrice |
Public property | SalesUnit |
Public property | StockingUnit |
Public property | TaxCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _alternateItemNumber |
Private field | _attachmentInfo |
Private field | _averageCost |
Private field | _categoryDescription |
Private field | _cost |
Private field | _costMethod |
Private field | _customFields |
Private field | _dimensionInfo |
Private field | _itemDescription |
Private field | _itemLocationSettings |
Private field | _itemNumber |
Private field | _itemVendors |
Private field | _listPrice |
Private field | _manufacturerName |
Private field | _purchaseUnit |
Private field | _rowNumber |
Private field | _salesPrice |
Private field | _salesUnit |
Private field | _stockingUnit |
Private field | _taxCode |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemNonInventoryInfos Constructor

CSharpPublicApiExampleProgramItemNonInventoryInfos Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemNonInventoryInfos class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemNonInventoryInfos()
Public Sub New
public:
ItemNonInventoryInfos()
new : unit -> ItemNonInventoryInfos
public ItemNonInventoryInfos()
Wasp.Cloud.Inventory.Example.ItemNonInventoryInfos = function();
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


ItemNonInventoryInfos Properties

The CSharpPublicApiExampleProgramItemNonInventoryInfos type exposes the following members.

Properties
 | Name | Description
Public property | AlternateItemNumber |
Public property | AttachmentInfo |
Public property | AverageCost |
Public property | CategoryDescription |
Public property | Cost |
Public property | CostMethod |
Public property | CustomFields |
Public property | DimensionInfo |
Public property | ItemDescription |
Public property | ItemLocationSettings |
Public property | ItemNumber |
Public property | ItemVendors |
Public property | ListPrice |
Public property | ManufacturerName |
Public property | PurchaseUnit |
Public property | RowNumber |
Public property | SalesPrice |
Public property | SalesUnit |
Public property | StockingUnit |
Public property | TaxCode |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.AlternateItemNumber Property

CSharpPublicApiExampleProgramItemNonInventoryInfosAlternateItemNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string AlternateItemNumber { get; set; }
Public Property AlternateItemNumber As String
    Get
    Set
public:
property String^ AlternateItemNumber {
    String^ get ();
    void set (String^ value);
}
member AlternateItemNumber : string with get, set

/** @property */
public String get_AlternateItemNumber()
/** @property */
public void set_AlternateItemNumber(String value)

function get_AlternateItemNumber();
function set_AlternateItemNumber(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.AttachmentInfo Property

CSharpPublicApiExampleProgramItemNonInventoryInfosAttachmentInfo Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramItemAttachmentInfo AttachmentInfo { get; set; }
Public Property AttachmentInfo As CSharpPublicApiExampleProgramItemAttachmentInfo
    Get
    Set
public:
property CSharpPublicApiExampleProgramItemAttachmentInfo^ AttachmentInfo {
    CSharpPublicApiExampleProgramItemAttachmentInfo^ get ();
    void set (CSharpPublicApiExampleProgramItemAttachmentInfo^ value);
}
member AttachmentInfo : CSharpPublicApiExampleProgramItemAttachmentInfo with get, set

/** @property */
public CSharpPublicApiExampleProgramItemAttachmentInfo get_AttachmentInfo()
/** @property */
public void set_AttachmentInfo(CSharpPublicApiExampleProgramItemAttachmentInfo value)

function get_AttachmentInfo();
function set_AttachmentInfo(value);

Property Value

Type: CSharpPublicApiExampleProgramItemAttachmentInfo
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.AverageCost Property

CSharpPublicApiExampleProgramItemNonInventoryInfosAverageCost Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal AverageCost { get; set; }
Public Property AverageCost As Decimal
    Get
    Set
public:
property Decimal AverageCost {
    Decimal get ();
    void set (Decimal value);
}
member AverageCost : decimal with get, set

/** @property */
public Decimal get_AverageCost()
/** @property */
public void set_AverageCost(Decimal value)

function get_AverageCost();
function set_AverageCost(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.CategoryDescription Property

CSharpPublicApiExampleProgramItemNonInventoryInfosCategoryDescription Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string CategoryDescription { get; set; }
Public Property CategoryDescription As String
    Get
    Set
public:
property String^ CategoryDescription {
    String^ get ();
    void set (String^ value);
}
member CategoryDescription : string with get, set

/** @property */
public String get_CategoryDescription()
/** @property */
public void set_CategoryDescription(String value)

function get_CategoryDescription();
function set_CategoryDescription(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.Cost Property

CSharpPublicApiExampleProgramItemNonInventoryInfosCost Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal Cost { get; set; }
Public Property Cost As Decimal
    Get
    Set
public:
property Decimal Cost {
    Decimal get ();
    void set (Decimal value);
}
member Cost : decimal with get, set

/** @property */
public Decimal get_Cost()
/** @property */
public void set_Cost(Decimal value)

function get_Cost();
function set_Cost(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.CostMethod Property

CSharpPublicApiExampleProgramItemNonInventoryInfosCostMethod Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramCostMethodEnums CostMethod { get; set; }
Public Property CostMethod As CSharpPublicApiExampleProgramCostMethodEnums
    Get
    Set
public:
property CSharpPublicApiExampleProgramCostMethodEnums CostMethod {
    CSharpPublicApiExampleProgramCostMethodEnums get ();
    void set (CSharpPublicApiExampleProgramCostMethodEnums value);
}
member CostMethod : CSharpPublicApiExampleProgramCostMethodEnums with get, set

/** @property */
public CSharpPublicApiExampleProgramCostMethodEnums get_CostMethod()
/** @property */
public void set_CostMethod(CSharpPublicApiExampleProgramCostMethodEnums value)

function get_CostMethod();
function set_CostMethod(value);

Property Value

Type: CSharpPublicApiExampleProgramCostMethodEnums
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.CustomFields Property

CSharpPublicApiExampleProgramItemNonInventoryInfosCustomFields Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<DcfValueInfo> CustomFields { get; set; }
Public Property CustomFields As List(Of DcfValueInfo)
    Get
    Set
public:
property List<DcfValueInfo^>^ CustomFields {
    List<DcfValueInfo^>^ get ();
    void set (List<DcfValueInfo^>^ value);
}
member CustomFields : List<DcfValueInfo> with get, set

/** @property */
public List<DcfValueInfo> get_CustomFields()
/** @property */
public void set_CustomFields(List<DcfValueInfo> value)

function get_CustomFields();
function set_CustomFields(value);

Property Value

Type: List DcfValueInfo
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.DimensionInfo Property

CSharpPublicApiExampleProgramItemNonInventoryInfosDimensionInfo Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramItemDimensionInfos DimensionInfo { get; set; }
Public Property DimensionInfo As CSharpPublicApiExampleProgramItemDimensionInfos
    Get
    Set
public:
property CSharpPublicApiExampleProgramItemDimensionInfos^ DimensionInfo {
    CSharpPublicApiExampleProgramItemDimensionInfos^ get ();
    void set (CSharpPublicApiExampleProgramItemDimensionInfos^ value);
}
member DimensionInfo : CSharpPublicApiExampleProgramItemDimensionInfos with get, set

/** @property */
public CSharpPublicApiExampleProgramItemDimensionInfos get_DimensionInfo()
/** @property */
public void set_DimensionInfo(CSharpPublicApiExampleProgramItemDimensionInfos value)

function get_DimensionInfo();
function set_DimensionInfo(value);

Property Value

Type: CSharpPublicApiExampleProgramItemDimensionInfos
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.ItemDescription Property

CSharpPublicApiExampleProgramItemNonInventoryInfosItemDescription Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ItemDescription { get; set; }
Public Property ItemDescription As String
    Get
    Set
public:
property String^ ItemDescription {
    String^ get ();
    void set (String^ value);
}
member ItemDescription : string with get, set

/** @property */
public String get_ItemDescription()
/** @property */
public void set_ItemDescription(String value)

function get_ItemDescription();
function set_ItemDescription(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.ItemLocationSettings Property

CSharpPublicApiExampleProgramItemNonInventoryInfosItemLocationSettings Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<CSharpPublicApiExampleProgramItemLocationSettings> ItemLocationSettings { get; set; }
Public Property ItemLocationSettings As List(Of CSharpPublicApiExampleProgramItemLocationSettings)
    Get
    Set
public:
property List<CSharpPublicApiExampleProgramItemLocationSettings^>^ ItemLocationSettings {
    List<CSharpPublicApiExampleProgramItemLocationSettings^>^ get ();
    void set (List<CSharpPublicApiExampleProgramItemLocationSettings^>^ value);
}
member ItemLocationSettings : List<CSharpPublicApiExampleProgramItemLocationSettings> with get, set

/** @property */
public List<CSharpPublicApiExampleProgramItemLocationSettings> get_ItemLocationSettings()
/** @property */
public void set_ItemLocationSettings(List<CSharpPublicApiExampleProgramItemLocationSettings> value)

function get_ItemLocationSettings();
function set_ItemLocationSettings(value);

Property Value

Type: List CSharpPublicApiExampleProgramItemLocationSettings
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.ItemNumber Property

CSharpPublicApiExampleProgramItemNonInventoryInfosItemNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ItemNumber { get; set; }
Public Property ItemNumber As String
    Get
    Set
public:
property String^ ItemNumber {
    String^ get ();
    void set (String^ value);
}
member ItemNumber : string with get, set

/** @property */
public String get_ItemNumber()
/** @property */
public void set_ItemNumber(String value)

function get_ItemNumber();
function set_ItemNumber(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.ItemVendors Property

CSharpPublicApiExampleProgramItemNonInventoryInfosItemVendors Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<CSharpPublicApiExampleProgramItemVendorInfo> ItemVendors { get; set; }
Public Property ItemVendors As List(Of CSharpPublicApiExampleProgramItemVendorInfo)
    Get
    Set
public:
property List<CSharpPublicApiExampleProgramItemVendorInfo^>^ ItemVendors {
    List<CSharpPublicApiExampleProgramItemVendorInfo^>^ get ();
    void set (List<CSharpPublicApiExampleProgramItemVendorInfo^>^ value);
}
member ItemVendors : List<CSharpPublicApiExampleProgramItemVendorInfo> with get, set

/** @property */
public List<CSharpPublicApiExampleProgramItemVendorInfo> get_ItemVendors()
/** @property */
public void set_ItemVendors(List<CSharpPublicApiExampleProgramItemVendorInfo> value)

function get_ItemVendors();
function set_ItemVendors(value);

Property Value

Type: List CSharpPublicApiExampleProgramItemVendorInfo
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.ListPrice Property

CSharpPublicApiExampleProgramItemNonInventoryInfosListPrice Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal ListPrice { get; set; }
Public Property ListPrice As Decimal
    Get
    Set
public:
property Decimal ListPrice {
    Decimal get ();
    void set (Decimal value);
}
member ListPrice : decimal with get, set

/** @property */
public Decimal get_ListPrice()
/** @property */
public void set_ListPrice(Decimal value)

function get_ListPrice();
function set_ListPrice(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.ManufacturerName Property

CSharpPublicApiExampleProgramItemNonInventoryInfosManufacturerName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ManufacturerName { get; set; }
Public Property ManufacturerName As String
    Get
    Set
public:
property String^ ManufacturerName {
    String^ get ();
    void set (String^ value);
}
member ManufacturerName : string with get, set

/** @property */
public String get_ManufacturerName()
/** @property */
public void set_ManufacturerName(String value)

function get_ManufacturerName();
function set_ManufacturerName(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.PurchaseUnit Property

CSharpPublicApiExampleProgramItemNonInventoryInfosPurchaseUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string PurchaseUnit { get; set; }
Public Property PurchaseUnit As String
    Get
    Set
public:
property String^ PurchaseUnit {
    String^ get ();
    void set (String^ value);
}
member PurchaseUnit : string with get, set

/** @property */
public String get_PurchaseUnit()
/** @property */
public void set_PurchaseUnit(String value)

function get_PurchaseUnit();
function set_PurchaseUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.RowNumber Property

CSharpPublicApiExampleProgramItemNonInventoryInfosRowNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public long RowNumber { get; set; }
Public Property RowNumber As Long
    Get
    Set
public:
property long long RowNumber {
    long long get ();
    void set (long long value);
}
member RowNumber : int64 with get, set

/** @property */
public long get_RowNumber()
/** @property */
public void set_RowNumber(long value)

function get_RowNumber();
function set_RowNumber(value);

Property Value

Type: Int64
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.SalesPrice Property

CSharpPublicApiExampleProgramItemNonInventoryInfosSalesPrice Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal SalesPrice { get; set; }
Public Property SalesPrice As Decimal
    Get
    Set
public:
property Decimal SalesPrice {
    Decimal get ();
    void set (Decimal value);
}
member SalesPrice : decimal with get, set

/** @property */
public Decimal get_SalesPrice()
/** @property */
public void set_SalesPrice(Decimal value)

function get_SalesPrice();
function set_SalesPrice(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.SalesUnit Property

CSharpPublicApiExampleProgramItemNonInventoryInfosSalesUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string SalesUnit { get; set; }
Public Property SalesUnit As String
    Get
    Set
public:
property String^ SalesUnit {
    String^ get ();
    void set (String^ value);
}
member SalesUnit : string with get, set

/** @property */
public String get_SalesUnit()
/** @property */
public void set_SalesUnit(String value)

function get_SalesUnit();
function set_SalesUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.StockingUnit Property

CSharpPublicApiExampleProgramItemNonInventoryInfosStockingUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string StockingUnit { get; set; }
Public Property StockingUnit As String
    Get
    Set
public:
property String^ StockingUnit {
    String^ get ();
    void set (String^ value);
}
member StockingUnit : string with get, set

/** @property */
public String get_StockingUnit()
/** @property */
public void set_StockingUnit(String value)

function get_StockingUnit();
function set_StockingUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.TaxCode Property

CSharpPublicApiExampleProgramItemNonInventoryInfosTaxCode Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string TaxCode { get; set; }
Public Property TaxCode As String
    Get
    Set
public:
property String^ TaxCode {
    String^ get ();
    void set (String^ value);
}
member TaxCode : string with get, set

/** @property */
public String get_TaxCode()
/** @property */
public void set_TaxCode(String value)

function get_TaxCode();
function set_TaxCode(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


ItemNonInventoryInfos Methods

The CSharpPublicApiExampleProgramItemNonInventoryInfos type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.FromJson Method

CSharpPublicApiExampleProgramItemNonInventoryInfosFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemNonInventoryInfos FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemNonInventoryInfos
public:
static CSharpPublicApiExampleProgramItemNonInventoryInfos^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemNonInventoryInfos

public static CSharpPublicApiExampleProgramItemNonInventoryInfos FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemNonInventoryInfos.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemNonInventoryInfos
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemNonInventoryInfosRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.ToJson Method

CSharpPublicApiExampleProgramItemNonInventoryInfosToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


ItemNonInventoryInfos Events

The CSharpPublicApiExampleProgramItemNonInventoryInfos type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos.PropertyChanged Event

CSharpPublicApiExampleProgramItemNonInventoryInfosPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


ItemNonInventoryInfos Fields

Fields
 | Name | Description
Private field | _alternateItemNumber |
Private field | _attachmentInfo |
Private field | _averageCost |
Private field | _categoryDescription |
Private field | _cost |
Private field | _costMethod |
Private field | _customFields |
Private field | _dimensionInfo |
Private field | _itemDescription |
Private field | _itemLocationSettings |
Private field | _itemNumber |
Private field | _itemVendors |
Private field | _listPrice |
Private field | _manufacturerName |
Private field | _purchaseUnit |
Private field | _rowNumber |
Private field | _salesPrice |
Private field | _salesUnit |
Private field | _stockingUnit |
Private field | _taxCode |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._alternateItemNumber Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_alternateItemNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _alternateItemNumber
Private _alternateItemNumber As String
private:
String^ _alternateItemNumber
val mutable private _alternateItemNumber: string
private String _alternateItemNumber
var _alternateItemNumber

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._attachmentInfo Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_attachmentInfo Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramItemAttachmentInfo _attachmentInfo
Private _attachmentInfo As CSharpPublicApiExampleProgramItemAttachmentInfo
private:
CSharpPublicApiExampleProgramItemAttachmentInfo^ _attachmentInfo
val mutable private _attachmentInfo: CSharpPublicApiExampleProgramItemAttachmentInfo
private CSharpPublicApiExampleProgramItemAttachmentInfo _attachmentInfo
var _attachmentInfo

Field Value

Type: CSharpPublicApiExampleProgramItemAttachmentInfo
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._averageCost Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_averageCost Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _averageCost
Private _averageCost As Decimal
private:
Decimal _averageCost
val mutable private _averageCost: decimal
private Decimal _averageCost
var _averageCost

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._categoryDescription Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_categoryDescription Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _categoryDescription
Private _categoryDescription As String
private:
String^ _categoryDescription
val mutable private _categoryDescription: string
private String _categoryDescription
var _categoryDescription

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._cost Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_cost Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _cost
Private _cost As Decimal
private:
Decimal _cost
val mutable private _cost: decimal
private Decimal _cost
var _cost

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._costMethod Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_costMethod Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramCostMethodEnums _costMethod
Private _costMethod As CSharpPublicApiExampleProgramCostMethodEnums
private:
CSharpPublicApiExampleProgramCostMethodEnums _costMethod
val mutable private _costMethod: CSharpPublicApiExampleProgramCostMethodEnums
private CSharpPublicApiExampleProgramCostMethodEnums _costMethod
var _costMethod

Field Value

Type: CSharpPublicApiExampleProgramCostMethodEnums
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._customFields Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_customFields Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<DcfValueInfo> _customFields
Private _customFields As List(Of DcfValueInfo)
private:
List<DcfValueInfo^>^ _customFields
val mutable private _customFields: List<DcfValueInfo>
private List<DcfValueInfo> _customFields
var _customFields

Field Value

Type: List DcfValueInfo
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._dimensionInfo Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_dimensionInfo Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramItemDimensionInfos _dimensionInfo
Private _dimensionInfo As CSharpPublicApiExampleProgramItemDimensionInfos
private:
CSharpPublicApiExampleProgramItemDimensionInfos^ _dimensionInfo
val mutable private _dimensionInfo: CSharpPublicApiExampleProgramItemDimensionInfos
private CSharpPublicApiExampleProgramItemDimensionInfos _dimensionInfo
var _dimensionInfo

Field Value

Type: CSharpPublicApiExampleProgramItemDimensionInfos
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._itemDescription Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_itemDescription Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _itemDescription
Private _itemDescription As String
private:
String^ _itemDescription
val mutable private _itemDescription: string
private String _itemDescription
var _itemDescription

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._itemLocationSettings Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_itemLocationSettings Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<CSharpPublicApiExampleProgramItemLocationSettings> _itemLocationSettings
Private _itemLocationSettings As List(Of CSharpPublicApiExampleProgramItemLocationSettings)
private:
List<CSharpPublicApiExampleProgramItemLocationSettings^>^ _itemLocationSettings
val mutable private _itemLocationSettings: List<CSharpPublicApiExampleProgramItemLocationSettings>
private List<CSharpPublicApiExampleProgramItemLocationSettings> _itemLocationSettings
var _itemLocationSettings

Field Value

Type: List CSharpPublicApiExampleProgramItemLocationSettings
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._itemNumber Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_itemNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _itemNumber
Private _itemNumber As String
private:
String^ _itemNumber
val mutable private _itemNumber: string
private String _itemNumber
var _itemNumber

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._itemVendors Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_itemVendors Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<CSharpPublicApiExampleProgramItemVendorInfo> _itemVendors
Private _itemVendors As List(Of CSharpPublicApiExampleProgramItemVendorInfo)
private:
List<CSharpPublicApiExampleProgramItemVendorInfo^>^ _itemVendors
val mutable private _itemVendors: List<CSharpPublicApiExampleProgramItemVendorInfo>
private List<CSharpPublicApiExampleProgramItemVendorInfo> _itemVendors
var _itemVendors

Field Value

Type: List CSharpPublicApiExampleProgramItemVendorInfo
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._listPrice Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_listPrice Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _listPrice
Private _listPrice As Decimal
private:
Decimal _listPrice
val mutable private _listPrice: decimal
private Decimal _listPrice
var _listPrice

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._manufacturerName Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_manufacturerName Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _manufacturerName
Private _manufacturerName As String
private:
String^ _manufacturerName
val mutable private _manufacturerName: string
private String _manufacturerName
var _manufacturerName

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._purchaseUnit Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_purchaseUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _purchaseUnit
Private _purchaseUnit As String
private:
String^ _purchaseUnit
val mutable private _purchaseUnit: string
private String _purchaseUnit
var _purchaseUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._rowNumber Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_rowNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private long _rowNumber
Private _rowNumber As Long
private:
long long _rowNumber
val mutable private _rowNumber: int64
private long _rowNumber
var _rowNumber

Field Value

Type: Int64
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._salesPrice Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_salesPrice Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _salesPrice
Private _salesPrice As Decimal
private:
Decimal _salesPrice
val mutable private _salesPrice: decimal
private Decimal _salesPrice
var _salesPrice

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._salesUnit Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_salesUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _salesUnit
Private _salesUnit As String
private:
String^ _salesUnit
val mutable private _salesUnit: string
private String _salesUnit
var _salesUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._stockingUnit Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_stockingUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _stockingUnit
Private _stockingUnit As String
private:
String^ _stockingUnit
val mutable private _stockingUnit: string
private String _stockingUnit
var _stockingUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemNonInventoryInfos._taxCode Field

CSharpPublicApiExampleProgramItemNonInventoryInfos_taxCode Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _taxCode
Private _taxCode As String
private:
String^ _taxCode
val mutable private _taxCode: string
private String _taxCode
var _taxCode

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemNonInventoryInfos Class


CSharpPublicApiExampleProgram.ItemPrices Class

CSharpPublicApiExampleProgramItemPrices Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemPrices

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemPrices : INotifyPropertyChanged
Public Class ItemPrices
    Implements INotifyPropertyChanged
public ref class ItemPrices : INotifyPropertyChanged
type ItemPrices =
    class
        interface INotifyPropertyChanged
    end
public class ItemPrices implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemPrices = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemPrices',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemPrices type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemPrices | Initializes a new instance of the CSharpPublicApiExampleProgramItemPrices class
Top
Properties
 | Name | Description
Public property | MaximumQuantity |
Public property | MinimumQuantity |
Public property | Price |
Public property | PriceTier |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _maximumQuantity |
Private field | _minimumQuantity |
Private field | _price |
Private field | _priceTier |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemPrices Constructor

CSharpPublicApiExampleProgramItemPrices Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemPrices class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemPrices()
Public Sub New
public:
ItemPrices()
new : unit -> ItemPrices
public ItemPrices()
Wasp.Cloud.Inventory.Example.ItemPrices = function();
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


ItemPrices Properties

The CSharpPublicApiExampleProgramItemPrices type exposes the following members.

Properties
 | Name | Description
Public property | MaximumQuantity |
Public property | MinimumQuantity |
Public property | Price |
Public property | PriceTier |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.MaximumQuantity Property

CSharpPublicApiExampleProgramItemPricesMaximumQuantity Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal MaximumQuantity { get; set; }
Public Property MaximumQuantity As Decimal
    Get
    Set
public:
property Decimal MaximumQuantity {
    Decimal get ();
    void set (Decimal value);
}
member MaximumQuantity : decimal with get, set

/** @property */
public Decimal get_MaximumQuantity()
/** @property */
public void set_MaximumQuantity(Decimal value)

function get_MaximumQuantity();
function set_MaximumQuantity(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.MinimumQuantity Property

CSharpPublicApiExampleProgramItemPricesMinimumQuantity Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal MinimumQuantity { get; set; }
Public Property MinimumQuantity As Decimal
    Get
    Set
public:
property Decimal MinimumQuantity {
    Decimal get ();
    void set (Decimal value);
}
member MinimumQuantity : decimal with get, set

/** @property */
public Decimal get_MinimumQuantity()
/** @property */
public void set_MinimumQuantity(Decimal value)

function get_MinimumQuantity();
function set_MinimumQuantity(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.Price Property

CSharpPublicApiExampleProgramItemPricesPrice Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal Price { get; set; }
Public Property Price As Decimal
    Get
    Set
public:
property Decimal Price {
    Decimal get ();
    void set (Decimal value);
}
member Price : decimal with get, set

/** @property */
public Decimal get_Price()
/** @property */
public void set_Price(Decimal value)

function get_Price();
function set_Price(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.PriceTier Property

CSharpPublicApiExampleProgramItemPricesPriceTier Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string PriceTier { get; set; }
Public Property PriceTier As String
    Get
    Set
public:
property String^ PriceTier {
    String^ get ();
    void set (String^ value);
}
member PriceTier : string with get, set

/** @property */
public String get_PriceTier()
/** @property */
public void set_PriceTier(String value)

function get_PriceTier();
function set_PriceTier(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


ItemPrices Methods

The CSharpPublicApiExampleProgramItemPrices type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.FromJson Method

CSharpPublicApiExampleProgramItemPricesFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemPrices FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemPrices
public:
static CSharpPublicApiExampleProgramItemPrices^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemPrices

public static CSharpPublicApiExampleProgramItemPrices FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemPrices.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemPrices
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemPricesRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.ToJson Method

CSharpPublicApiExampleProgramItemPricesToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


ItemPrices Events

The CSharpPublicApiExampleProgramItemPrices type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices.PropertyChanged Event

CSharpPublicApiExampleProgramItemPricesPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


ItemPrices Fields

Fields
 | Name | Description
Private field | _maximumQuantity |
Private field | _minimumQuantity |
Private field | _price |
Private field | _priceTier |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices._maximumQuantity Field

CSharpPublicApiExampleProgramItemPrices_maximumQuantity Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _maximumQuantity
Private _maximumQuantity As Decimal
private:
Decimal _maximumQuantity
val mutable private _maximumQuantity: decimal
private Decimal _maximumQuantity
var _maximumQuantity

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices._minimumQuantity Field

CSharpPublicApiExampleProgramItemPrices_minimumQuantity Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _minimumQuantity
Private _minimumQuantity As Decimal
private:
Decimal _minimumQuantity
val mutable private _minimumQuantity: decimal
private Decimal _minimumQuantity
var _minimumQuantity

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices._price Field

CSharpPublicApiExampleProgramItemPrices_price Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _price
Private _price As Decimal
private:
Decimal _price
val mutable private _price: decimal
private Decimal _price
var _price

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemPrices._priceTier Field

CSharpPublicApiExampleProgramItemPrices_priceTier Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _priceTier
Private _priceTier As String
private:
String^ _priceTier
val mutable private _priceTier: string
private String _priceTier
var _priceTier

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemPrices Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos Class

CSharpPublicApiExampleProgramItemTrackbyInfos Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemTrackbyInfos

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemTrackbyInfos : INotifyPropertyChanged
Public Class ItemTrackbyInfos
    Implements INotifyPropertyChanged
public ref class ItemTrackbyInfos : INotifyPropertyChanged
type ItemTrackbyInfos =
    class
        interface INotifyPropertyChanged
    end
public class ItemTrackbyInfos implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemTrackbyInfos = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemTrackbyInfos',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemTrackbyInfos type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemTrackbyInfos | Initializes a new instance of the CSharpPublicApiExampleProgramItemTrackbyInfos class
Top
Properties
 | Name | Description
Public property | AutoGenerateSerialNumber |
Public property | TrackedByCustomer |
Public property | TrackedByDateCode |
Public property | TrackedByLot |
Public property | TrackedByReferenceNumber |
Public property | TrackedBySerialNumber |
Public property | TrackedBySerialNumberOnlyOnInvoicing |
Public property | TrackedByVendor |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _autoGenerateSerialNumber |
Private field | _trackedByCustomer |
Private field | _trackedByDateCode |
Private field | _trackedByLot |
Private field | _trackedByReferenceNumber |
Private field | _trackedBySerialNumber |
Private field | _trackedBySerialNumberOnlyOnInvoicing |
Private field | _trackedByVendor |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemTrackbyInfos Constructor

CSharpPublicApiExampleProgramItemTrackbyInfos Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemTrackbyInfos class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemTrackbyInfos()
Public Sub New
public:
ItemTrackbyInfos()
new : unit -> ItemTrackbyInfos
public ItemTrackbyInfos()
Wasp.Cloud.Inventory.Example.ItemTrackbyInfos = function();
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


ItemTrackbyInfos Properties

The CSharpPublicApiExampleProgramItemTrackbyInfos type exposes the following members.

Properties
 | Name | Description
Public property | AutoGenerateSerialNumber |
Public property | TrackedByCustomer |
Public property | TrackedByDateCode |
Public property | TrackedByLot |
Public property | TrackedByReferenceNumber |
Public property | TrackedBySerialNumber |
Public property | TrackedBySerialNumberOnlyOnInvoicing |
Public property | TrackedByVendor |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.AutoGenerateSerialNumber Property

CSharpPublicApiExampleProgramItemTrackbyInfosAutoGenerateSerialNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool AutoGenerateSerialNumber { get; set; }
Public Property AutoGenerateSerialNumber As Boolean
    Get
    Set
public:
property bool AutoGenerateSerialNumber {
    bool get ();
    void set (bool value);
}
member AutoGenerateSerialNumber : bool with get, set

/** @property */
public boolean get_AutoGenerateSerialNumber()
/** @property */
public void set_AutoGenerateSerialNumber(boolean value)

function get_AutoGenerateSerialNumber();
function set_AutoGenerateSerialNumber(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.TrackedByCustomer Property

CSharpPublicApiExampleProgramItemTrackbyInfosTrackedByCustomer Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool TrackedByCustomer { get; set; }
Public Property TrackedByCustomer As Boolean
    Get
    Set
public:
property bool TrackedByCustomer {
    bool get ();
    void set (bool value);
}
member TrackedByCustomer : bool with get, set

/** @property */
public boolean get_TrackedByCustomer()
/** @property */
public void set_TrackedByCustomer(boolean value)

function get_TrackedByCustomer();
function set_TrackedByCustomer(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.TrackedByDateCode Property

CSharpPublicApiExampleProgramItemTrackbyInfosTrackedByDateCode Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool TrackedByDateCode { get; set; }
Public Property TrackedByDateCode As Boolean
    Get
    Set
public:
property bool TrackedByDateCode {
    bool get ();
    void set (bool value);
}
member TrackedByDateCode : bool with get, set

/** @property */
public boolean get_TrackedByDateCode()
/** @property */
public void set_TrackedByDateCode(boolean value)

function get_TrackedByDateCode();
function set_TrackedByDateCode(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.TrackedByLot Property

CSharpPublicApiExampleProgramItemTrackbyInfosTrackedByLot Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool TrackedByLot { get; set; }
Public Property TrackedByLot As Boolean
    Get
    Set
public:
property bool TrackedByLot {
    bool get ();
    void set (bool value);
}
member TrackedByLot : bool with get, set

/** @property */
public boolean get_TrackedByLot()
/** @property */
public void set_TrackedByLot(boolean value)

function get_TrackedByLot();
function set_TrackedByLot(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.TrackedByReferenceNumber Property

CSharpPublicApiExampleProgramItemTrackbyInfosTrackedByReferenceNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool TrackedByReferenceNumber { get; set; }
Public Property TrackedByReferenceNumber As Boolean
    Get
    Set
public:
property bool TrackedByReferenceNumber {
    bool get ();
    void set (bool value);
}
member TrackedByReferenceNumber : bool with get, set

/** @property */
public boolean get_TrackedByReferenceNumber()
/** @property */
public void set_TrackedByReferenceNumber(boolean value)

function get_TrackedByReferenceNumber();
function set_TrackedByReferenceNumber(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.TrackedBySerialNumber Property

CSharpPublicApiExampleProgramItemTrackbyInfosTrackedBySerialNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool TrackedBySerialNumber { get; set; }
Public Property TrackedBySerialNumber As Boolean
    Get
    Set
public:
property bool TrackedBySerialNumber {
    bool get ();
    void set (bool value);
}
member TrackedBySerialNumber : bool with get, set

/** @property */
public boolean get_TrackedBySerialNumber()
/** @property */
public void set_TrackedBySerialNumber(boolean value)

function get_TrackedBySerialNumber();
function set_TrackedBySerialNumber(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.TrackedBySerialNumberOnlyOnInvoicing Property

CSharpPublicApiExampleProgramItemTrackbyInfosTrackedBySerialNumberOnlyOnInvoicing Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool TrackedBySerialNumberOnlyOnInvoicing { get; set; }
Public Property TrackedBySerialNumberOnlyOnInvoicing As Boolean
    Get
    Set
public:
property bool TrackedBySerialNumberOnlyOnInvoicing {
    bool get ();
    void set (bool value);
}
member TrackedBySerialNumberOnlyOnInvoicing : bool with get, set

/** @property */
public boolean get_TrackedBySerialNumberOnlyOnInvoicing()
/** @property */
public void set_TrackedBySerialNumberOnlyOnInvoicing(boolean value)

function get_TrackedBySerialNumberOnlyOnInvoicing();
function set_TrackedBySerialNumberOnlyOnInvoicing(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.TrackedByVendor Property

CSharpPublicApiExampleProgramItemTrackbyInfosTrackedByVendor Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool TrackedByVendor { get; set; }
Public Property TrackedByVendor As Boolean
    Get
    Set
public:
property bool TrackedByVendor {
    bool get ();
    void set (bool value);
}
member TrackedByVendor : bool with get, set

/** @property */
public boolean get_TrackedByVendor()
/** @property */
public void set_TrackedByVendor(boolean value)

function get_TrackedByVendor();
function set_TrackedByVendor(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


ItemTrackbyInfos Methods

The CSharpPublicApiExampleProgramItemTrackbyInfos type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.FromJson Method

CSharpPublicApiExampleProgramItemTrackbyInfosFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemTrackbyInfos FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemTrackbyInfos
public:
static CSharpPublicApiExampleProgramItemTrackbyInfos^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemTrackbyInfos

public static CSharpPublicApiExampleProgramItemTrackbyInfos FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemTrackbyInfos.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemTrackbyInfos
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemTrackbyInfosRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.ToJson Method

CSharpPublicApiExampleProgramItemTrackbyInfosToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


ItemTrackbyInfos Events

The CSharpPublicApiExampleProgramItemTrackbyInfos type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos.PropertyChanged Event

CSharpPublicApiExampleProgramItemTrackbyInfosPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


ItemTrackbyInfos Fields

Fields
 | Name | Description
Private field | _autoGenerateSerialNumber |
Private field | _trackedByCustomer |
Private field | _trackedByDateCode |
Private field | _trackedByLot |
Private field | _trackedByReferenceNumber |
Private field | _trackedBySerialNumber |
Private field | _trackedBySerialNumberOnlyOnInvoicing |
Private field | _trackedByVendor |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._autoGenerateSerialNumber Field

CSharpPublicApiExampleProgramItemTrackbyInfos_autoGenerateSerialNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _autoGenerateSerialNumber
Private _autoGenerateSerialNumber As Boolean
private:
bool _autoGenerateSerialNumber
val mutable private _autoGenerateSerialNumber: bool
private boolean _autoGenerateSerialNumber
var _autoGenerateSerialNumber

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._trackedByCustomer Field

CSharpPublicApiExampleProgramItemTrackbyInfos_trackedByCustomer Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _trackedByCustomer
Private _trackedByCustomer As Boolean
private:
bool _trackedByCustomer
val mutable private _trackedByCustomer: bool
private boolean _trackedByCustomer
var _trackedByCustomer

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._trackedByDateCode Field

CSharpPublicApiExampleProgramItemTrackbyInfos_trackedByDateCode Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _trackedByDateCode
Private _trackedByDateCode As Boolean
private:
bool _trackedByDateCode
val mutable private _trackedByDateCode: bool
private boolean _trackedByDateCode
var _trackedByDateCode

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._trackedByLot Field

CSharpPublicApiExampleProgramItemTrackbyInfos_trackedByLot Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _trackedByLot
Private _trackedByLot As Boolean
private:
bool _trackedByLot
val mutable private _trackedByLot: bool
private boolean _trackedByLot
var _trackedByLot

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._trackedByReferenceNumber Field

CSharpPublicApiExampleProgramItemTrackbyInfos_trackedByReferenceNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _trackedByReferenceNumber
Private _trackedByReferenceNumber As Boolean
private:
bool _trackedByReferenceNumber
val mutable private _trackedByReferenceNumber: bool
private boolean _trackedByReferenceNumber
var _trackedByReferenceNumber

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._trackedBySerialNumber Field

CSharpPublicApiExampleProgramItemTrackbyInfos_trackedBySerialNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _trackedBySerialNumber
Private _trackedBySerialNumber As Boolean
private:
bool _trackedBySerialNumber
val mutable private _trackedBySerialNumber: bool
private boolean _trackedBySerialNumber
var _trackedBySerialNumber

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._trackedBySerialNumberOnlyOnInvoicing Field

CSharpPublicApiExampleProgramItemTrackbyInfos_trackedBySerialNumberOnlyOnInvoicing Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _trackedBySerialNumberOnlyOnInvoicing
Private _trackedBySerialNumberOnlyOnInvoicing As Boolean
private:
bool _trackedBySerialNumberOnlyOnInvoicing
val mutable private _trackedBySerialNumberOnlyOnInvoicing: bool
private boolean _trackedBySerialNumberOnlyOnInvoicing
var _trackedBySerialNumberOnlyOnInvoicing

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTrackbyInfos._trackedByVendor Field

CSharpPublicApiExampleProgramItemTrackbyInfos_trackedByVendor Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _trackedByVendor
Private _trackedByVendor As Boolean
private:
bool _trackedByVendor
val mutable private _trackedByVendor: bool
private boolean _trackedByVendor
var _trackedByVendor

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemTrackbyInfos Class


CSharpPublicApiExampleProgram.ItemTypeEnums Enumeration

CSharpPublicApiExampleProgramItemTypeEnums Enumeration

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public enum ItemTypeEnums
Public Enumeration ItemTypeEnums
public enum class ItemTypeEnums
type ItemTypeEnums
public enum ItemTypeEnums
Wasp.Cloud.Inventory.Example.ItemTypeEnums = function();
Wasp.Cloud.Inventory.Example.ItemTypeEnums.createEnum('Wasp.Cloud.Inventory.Example.ItemTypeEnums', false);
Members
Member name | Value | Description
All | 0 |
InventoryItem | 2147483635 |
NonInventoryItem | 2147483636 |
Kit | 2147483637 |
Assembly | 2147483638 |
Service | 2147483639 |
Container | 2147483640 |
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemVendorInfo Class

CSharpPublicApiExampleProgramItemVendorInfo Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramItemVendorInfo

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class ItemVendorInfo : INotifyPropertyChanged
Public Class ItemVendorInfo
    Implements INotifyPropertyChanged
public ref class ItemVendorInfo : INotifyPropertyChanged
type ItemVendorInfo =
    class
        interface INotifyPropertyChanged
    end
public class ItemVendorInfo implements INotifyPropertyChanged
Wasp.Cloud.Inventory.Example.ItemVendorInfo = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.ItemVendorInfo',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramItemVendorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramItemVendorInfo | Initializes a new instance of the CSharpPublicApiExampleProgramItemVendorInfo class
Top
Properties
 | Name | Description
Public property | DefaultVendorUnit |
Public property | LeadTimeMinutes |
Public property | PreferredVendor |
Public property | VendorDescription |
Public property | VendorNotes |
Public property | VendorNumber |
Public property | VendorPrice |
Public property | VendorSKU |
Public property | VendorUnit |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _defaultVendorUnit |
Private field | _leadTimeMinutes |
Private field | _preferredVendor |
Private field | _vendorDescription |
Private field | _vendorNotes |
Private field | _vendorNumber |
Private field | _vendorPrice |
Private field | _vendorSKU |
Private field | _vendorUnit |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.ItemVendorInfo Constructor

CSharpPublicApiExampleProgramItemVendorInfo Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramItemVendorInfo class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public ItemVendorInfo()
Public Sub New
public:
ItemVendorInfo()
new : unit -> ItemVendorInfo
public ItemVendorInfo()
Wasp.Cloud.Inventory.Example.ItemVendorInfo = function();
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


ItemVendorInfo Properties

The CSharpPublicApiExampleProgramItemVendorInfo type exposes the following members.

Properties
 | Name | Description
Public property | DefaultVendorUnit |
Public property | LeadTimeMinutes |
Public property | PreferredVendor |
Public property | VendorDescription |
Public property | VendorNotes |
Public property | VendorNumber |
Public property | VendorPrice |
Public property | VendorSKU |
Public property | VendorUnit |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.DefaultVendorUnit Property

CSharpPublicApiExampleProgramItemVendorInfoDefaultVendorUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool DefaultVendorUnit { get; set; }
Public Property DefaultVendorUnit As Boolean
    Get
    Set
public:
property bool DefaultVendorUnit {
    bool get ();
    void set (bool value);
}
member DefaultVendorUnit : bool with get, set

/** @property */
public boolean get_DefaultVendorUnit()
/** @property */
public void set_DefaultVendorUnit(boolean value)

function get_DefaultVendorUnit();
function set_DefaultVendorUnit(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.LeadTimeMinutes Property

CSharpPublicApiExampleProgramItemVendorInfoLeadTimeMinutes Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int LeadTimeMinutes { get; set; }
Public Property LeadTimeMinutes As Integer
    Get
    Set
public:
property int LeadTimeMinutes {
    int get ();
    void set (int value);
}
member LeadTimeMinutes : int with get, set

/** @property */
public int get_LeadTimeMinutes()
/** @property */
public void set_LeadTimeMinutes(int value)

function get_LeadTimeMinutes();
function set_LeadTimeMinutes(value);

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.PreferredVendor Property

CSharpPublicApiExampleProgramItemVendorInfoPreferredVendor Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public bool PreferredVendor { get; set; }
Public Property PreferredVendor As Boolean
    Get
    Set
public:
property bool PreferredVendor {
    bool get ();
    void set (bool value);
}
member PreferredVendor : bool with get, set

/** @property */
public boolean get_PreferredVendor()
/** @property */
public void set_PreferredVendor(boolean value)

function get_PreferredVendor();
function set_PreferredVendor(value);

Property Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.VendorDescription Property

CSharpPublicApiExampleProgramItemVendorInfoVendorDescription Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string VendorDescription { get; set; }
Public Property VendorDescription As String
    Get
    Set
public:
property String^ VendorDescription {
    String^ get ();
    void set (String^ value);
}
member VendorDescription : string with get, set

/** @property */
public String get_VendorDescription()
/** @property */
public void set_VendorDescription(String value)

function get_VendorDescription();
function set_VendorDescription(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.VendorNotes Property

CSharpPublicApiExampleProgramItemVendorInfoVendorNotes Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<NoteInfo> VendorNotes { get; set; }
Public Property VendorNotes As List(Of NoteInfo)
    Get
    Set
public:
property List<NoteInfo^>^ VendorNotes {
    List<NoteInfo^>^ get ();
    void set (List<NoteInfo^>^ value);
}
member VendorNotes : List<NoteInfo> with get, set

/** @property */
public List<NoteInfo> get_VendorNotes()
/** @property */
public void set_VendorNotes(List<NoteInfo> value)

function get_VendorNotes();
function set_VendorNotes(value);

Property Value

Type: List NoteInfo
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.VendorNumber Property

CSharpPublicApiExampleProgramItemVendorInfoVendorNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string VendorNumber { get; set; }
Public Property VendorNumber As String
    Get
    Set
public:
property String^ VendorNumber {
    String^ get ();
    void set (String^ value);
}
member VendorNumber : string with get, set

/** @property */
public String get_VendorNumber()
/** @property */
public void set_VendorNumber(String value)

function get_VendorNumber();
function set_VendorNumber(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.VendorPrice Property

CSharpPublicApiExampleProgramItemVendorInfoVendorPrice Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public decimal VendorPrice { get; set; }
Public Property VendorPrice As Decimal
    Get
    Set
public:
property Decimal VendorPrice {
    Decimal get ();
    void set (Decimal value);
}
member VendorPrice : decimal with get, set

/** @property */
public Decimal get_VendorPrice()
/** @property */
public void set_VendorPrice(Decimal value)

function get_VendorPrice();
function set_VendorPrice(value);

Property Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.VendorSKU Property

CSharpPublicApiExampleProgramItemVendorInfoVendorSKU Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string VendorSKU { get; set; }
Public Property VendorSKU As String
    Get
    Set
public:
property String^ VendorSKU {
    String^ get ();
    void set (String^ value);
}
member VendorSKU : string with get, set

/** @property */
public String get_VendorSKU()
/** @property */
public void set_VendorSKU(String value)

function get_VendorSKU();
function set_VendorSKU(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.VendorUnit Property

CSharpPublicApiExampleProgramItemVendorInfoVendorUnit Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string VendorUnit { get; set; }
Public Property VendorUnit As String
    Get
    Set
public:
property String^ VendorUnit {
    String^ get ();
    void set (String^ value);
}
member VendorUnit : string with get, set

/** @property */
public String get_VendorUnit()
/** @property */
public void set_VendorUnit(String value)

function get_VendorUnit();
function set_VendorUnit(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


ItemVendorInfo Methods

The CSharpPublicApiExampleProgramItemVendorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.FromJson Method

CSharpPublicApiExampleProgramItemVendorInfoFromJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramItemVendorInfo FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramItemVendorInfo
public:
static CSharpPublicApiExampleProgramItemVendorInfo^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramItemVendorInfo

public static CSharpPublicApiExampleProgramItemVendorInfo FromJson(
    String data
)
Wasp.Cloud.Inventory.Example.ItemVendorInfo.FromJson = function(data);

Parameters

data
Type: SystemString

Return Value

Type: CSharpPublicApiExampleProgramItemVendorInfo
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.RaisePropertyChanged Method

CSharpPublicApiExampleProgramItemVendorInfoRaisePropertyChanged Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName (Optional)
Type: SystemString
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.ToJson Method

CSharpPublicApiExampleProgramItemVendorInfoToJson Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string

public String ToJson()
function ToJson();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


ItemVendorInfo Events

The CSharpPublicApiExampleProgramItemVendorInfo type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo.PropertyChanged Event

CSharpPublicApiExampleProgramItemVendorInfoPropertyChanged Event

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


ItemVendorInfo Fields

Fields
 | Name | Description
Private field | _defaultVendorUnit |
Private field | _leadTimeMinutes |
Private field | _preferredVendor |
Private field | _vendorDescription |
Private field | _vendorNotes |
Private field | _vendorNumber |
Private field | _vendorPrice |
Private field | _vendorSKU |
Private field | _vendorUnit |
Top
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._defaultVendorUnit Field

CSharpPublicApiExampleProgramItemVendorInfo_defaultVendorUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _defaultVendorUnit
Private _defaultVendorUnit As Boolean
private:
bool _defaultVendorUnit
val mutable private _defaultVendorUnit: bool
private boolean _defaultVendorUnit
var _defaultVendorUnit

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._leadTimeMinutes Field

CSharpPublicApiExampleProgramItemVendorInfo_leadTimeMinutes Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private int _leadTimeMinutes
Private _leadTimeMinutes As Integer
private:
int _leadTimeMinutes
val mutable private _leadTimeMinutes: int
private int _leadTimeMinutes
var _leadTimeMinutes

Field Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._preferredVendor Field

CSharpPublicApiExampleProgramItemVendorInfo_preferredVendor Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private bool _preferredVendor
Private _preferredVendor As Boolean
private:
bool _preferredVendor
val mutable private _preferredVendor: bool
private boolean _preferredVendor
var _preferredVendor

Field Value

Type: Boolean
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._vendorDescription Field

CSharpPublicApiExampleProgramItemVendorInfo_vendorDescription Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _vendorDescription
Private _vendorDescription As String
private:
String^ _vendorDescription
val mutable private _vendorDescription: string
private String _vendorDescription
var _vendorDescription

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._vendorNotes Field

CSharpPublicApiExampleProgramItemVendorInfo_vendorNotes Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<NoteInfo> _vendorNotes
Private _vendorNotes As List(Of NoteInfo)
private:
List<NoteInfo^>^ _vendorNotes
val mutable private _vendorNotes: List<NoteInfo>
private List<NoteInfo> _vendorNotes
var _vendorNotes

Field Value

Type: List NoteInfo
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._vendorNumber Field

CSharpPublicApiExampleProgramItemVendorInfo_vendorNumber Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _vendorNumber
Private _vendorNumber As String
private:
String^ _vendorNumber
val mutable private _vendorNumber: string
private String _vendorNumber
var _vendorNumber

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._vendorPrice Field

CSharpPublicApiExampleProgramItemVendorInfo_vendorPrice Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private decimal _vendorPrice
Private _vendorPrice As Decimal
private:
Decimal _vendorPrice
val mutable private _vendorPrice: decimal
private Decimal _vendorPrice
var _vendorPrice

Field Value

Type: Decimal
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._vendorSKU Field

CSharpPublicApiExampleProgramItemVendorInfo_vendorSKU Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _vendorSKU
Private _vendorSKU As String
private:
String^ _vendorSKU
val mutable private _vendorSKU: string
private String _vendorSKU
var _vendorSKU

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.ItemVendorInfo._vendorUnit Field

CSharpPublicApiExampleProgramItemVendorInfo_vendorUnit Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _vendorUnit
Private _vendorUnit As String
private:
String^ _vendorUnit
val mutable private _vendorUnit: string
private String _vendorUnit
var _vendorUnit

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramItemVendorInfo Class


CSharpPublicApiExampleProgram.MyItemMoveTransactionModel Class

CSharpPublicApiExampleProgramMyItemMoveTransactionModel Class

Inheritance Hierarchy
SystemObject
ItemMoveTransactionModel
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramMyItemMoveTransactionModel

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private class MyItemMoveTransactionModel : ItemMoveTransactionModel
Private Class MyItemMoveTransactionModel
    Inherits ItemMoveTransactionModel
private ref class MyItemMoveTransactionModel : public ItemMoveTransactionModel
type MyItemMoveTransactionModel =
    class
        inherit ItemMoveTransactionModel
    end
private class MyItemMoveTransactionModel extends ItemMoveTransactionModel
Wasp.Cloud.Inventory.Example.MyItemMoveTransactionModel = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.MyItemMoveTransactionModel',
    Wasp.Cloud.Inventory.API.ItemMoveTransactionModel);

The CSharpPublicApiExampleProgramMyItemMoveTransactionModel type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramMyItemMoveTransactionModel | Initializes a new instance of the CSharpPublicApiExampleProgramMyItemMoveTransactionModel class
Top
Properties
 | Name | Description
Public property | DateCode | the date code of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | FromLocationCode | the old location within the site where the inventory was (Inherited from ItemMoveTransactionModel.)
Public property | FromSiteName | the old site of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | ItemNumber | the unique identifier for this item (Inherited from ItemMoveTransactionModel.)
Public property | Lot | the lot of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | Quantity | the amount to adjust (Inherited from ItemMoveTransactionModel.)
Public property | SerialNumber | the unique serial number of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | ToLocationCode | the new location of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | ToSiteName | the new site of the inventory (Inherited from ItemMoveTransactionModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | sBuffer |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.MyItemMoveTransactionModel Constructor

CSharpPublicApiExampleProgramMyItemMoveTransactionModel Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramMyItemMoveTransactionModel class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public MyItemMoveTransactionModel()
Public Sub New
public:
MyItemMoveTransactionModel()
new : unit -> MyItemMoveTransactionModel
public MyItemMoveTransactionModel()
Wasp.Cloud.Inventory.Example.MyItemMoveTransactionModel = function();
See Also

Reference

CSharpPublicApiExampleProgramMyItemMoveTransactionModel Class


MyItemMoveTransactionModel Properties

The CSharpPublicApiExampleProgramMyItemMoveTransactionModel type exposes the following members.

Properties
 | Name | Description
Public property | DateCode | the date code of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | FromLocationCode | the old location within the site where the inventory was (Inherited from ItemMoveTransactionModel.)
Public property | FromSiteName | the old site of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | ItemNumber | the unique identifier for this item (Inherited from ItemMoveTransactionModel.)
Public property | Lot | the lot of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | Quantity | the amount to adjust (Inherited from ItemMoveTransactionModel.)
Public property | SerialNumber | the unique serial number of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | ToLocationCode | the new location of the inventory (Inherited from ItemMoveTransactionModel.)
Public property | ToSiteName | the new site of the inventory (Inherited from ItemMoveTransactionModel.)
Top
See Also

Reference

CSharpPublicApiExampleProgramMyItemMoveTransactionModel Class


MyItemMoveTransactionModel Methods

The CSharpPublicApiExampleProgramMyItemMoveTransactionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramMyItemMoveTransactionModel Class


MyItemMoveTransactionModel Fields

The CSharpPublicApiExampleProgramMyItemMoveTransactionModel type exposes the following members.

Fields
 | Name | Description
Protected field | sBuffer |
Top
See Also

Reference

CSharpPublicApiExampleProgramMyItemMoveTransactionModel Class


CSharpPublicApiExampleProgram.MyItemMoveTransactionModel.sBuffer Field

CSharpPublicApiExampleProgramMyItemMoveTransactionModelsBuffer Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
internal string sBuffer
Friend sBuffer As String
internal:
String^ sBuffer
val mutable internal sBuffer: string
 String sBuffer
var sBuffer

Field Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramMyItemMoveTransactionModel Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder Class

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramPurchaseOrderColumnOrder

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class PurchaseOrderColumnOrder
Public Class PurchaseOrderColumnOrder
public ref class PurchaseOrderColumnOrder
type PurchaseOrderColumnOrder =  class end
public class PurchaseOrderColumnOrder
Wasp.Cloud.Inventory.Example.PurchaseOrderColumnOrder = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.PurchaseOrderColumnOrder');

The CSharpPublicApiExampleProgramPurchaseOrderColumnOrder type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramPurchaseOrderColumnOrder | Initializes a new instance of the CSharpPublicApiExampleProgramPurchaseOrderColumnOrder class
Top
Properties
 | Name | Description
Public property | DateDue |
Public property | DateStarted |
Public property | ItemNumber |
Public property | ItemPrice |
Public property | NoteText |
Public property | PayMethod |
Public property | PurchaseOrderNumber |
Public property | QuantityRequested |
Public property | ShipMethod |
Public property | ShipToAddressLine1 |
Public property | UomName |
Public property | VendorAddressLine1 |
Public property | VendorNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Private field | purchaseOrderColumnOrder |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder Constructor

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramPurchaseOrderColumnOrder class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public PurchaseOrderColumnOrder()
Public Sub New
public:
PurchaseOrderColumnOrder()
new : unit -> PurchaseOrderColumnOrder
public PurchaseOrderColumnOrder()
Wasp.Cloud.Inventory.Example.PurchaseOrderColumnOrder = function();
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


PurchaseOrderColumnOrder Properties

The CSharpPublicApiExampleProgramPurchaseOrderColumnOrder type exposes the following members.

Properties
 | Name | Description
Public property | DateDue |
Public property | DateStarted |
Public property | ItemNumber |
Public property | ItemPrice |
Public property | NoteText |
Public property | PayMethod |
Public property | PurchaseOrderNumber |
Public property | QuantityRequested |
Public property | ShipMethod |
Public property | ShipToAddressLine1 |
Public property | UomName |
Public property | VendorAddressLine1 |
Public property | VendorNumber |
Top
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.DateDue Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderDateDue Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int DateDue { get; }
Public ReadOnly Property DateDue As Integer
    Get
public:
property int DateDue {
    int get ();
}
member DateDue : int with get

/** @property */
public int get_DateDue()

function get_DateDue();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.DateStarted Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderDateStarted Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int DateStarted { get; }
Public ReadOnly Property DateStarted As Integer
    Get
public:
property int DateStarted {
    int get ();
}
member DateStarted : int with get

/** @property */
public int get_DateStarted()

function get_DateStarted();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.ItemNumber Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderItemNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int ItemNumber { get; }
Public ReadOnly Property ItemNumber As Integer
    Get
public:
property int ItemNumber {
    int get ();
}
member ItemNumber : int with get

/** @property */
public int get_ItemNumber()

function get_ItemNumber();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.ItemPrice Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderItemPrice Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int ItemPrice { get; }
Public ReadOnly Property ItemPrice As Integer
    Get
public:
property int ItemPrice {
    int get ();
}
member ItemPrice : int with get

/** @property */
public int get_ItemPrice()

function get_ItemPrice();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.NoteText Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderNoteText Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int NoteText { get; }
Public ReadOnly Property NoteText As Integer
    Get
public:
property int NoteText {
    int get ();
}
member NoteText : int with get

/** @property */
public int get_NoteText()

function get_NoteText();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.PayMethod Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderPayMethod Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int PayMethod { get; }
Public ReadOnly Property PayMethod As Integer
    Get
public:
property int PayMethod {
    int get ();
}
member PayMethod : int with get

/** @property */
public int get_PayMethod()

function get_PayMethod();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.PurchaseOrderNumber Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderPurchaseOrderNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int PurchaseOrderNumber { get; }
Public ReadOnly Property PurchaseOrderNumber As Integer
    Get
public:
property int PurchaseOrderNumber {
    int get ();
}
member PurchaseOrderNumber : int with get

/** @property */
public int get_PurchaseOrderNumber()

function get_PurchaseOrderNumber();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.QuantityRequested Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderQuantityRequested Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int QuantityRequested { get; }
Public ReadOnly Property QuantityRequested As Integer
    Get
public:
property int QuantityRequested {
    int get ();
}
member QuantityRequested : int with get

/** @property */
public int get_QuantityRequested()

function get_QuantityRequested();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.ShipMethod Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderShipMethod Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int ShipMethod { get; }
Public ReadOnly Property ShipMethod As Integer
    Get
public:
property int ShipMethod {
    int get ();
}
member ShipMethod : int with get

/** @property */
public int get_ShipMethod()

function get_ShipMethod();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.ShipToAddressLine1 Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderShipToAddressLine1 Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int ShipToAddressLine1 { get; }
Public ReadOnly Property ShipToAddressLine1 As Integer
    Get
public:
property int ShipToAddressLine1 {
    int get ();
}
member ShipToAddressLine1 : int with get

/** @property */
public int get_ShipToAddressLine1()

function get_ShipToAddressLine1();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.UomName Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderUomName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int UomName { get; }
Public ReadOnly Property UomName As Integer
    Get
public:
property int UomName {
    int get ();
}
member UomName : int with get

/** @property */
public int get_UomName()

function get_UomName();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.VendorAddressLine1 Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderVendorAddressLine1 Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int VendorAddressLine1 { get; }
Public ReadOnly Property VendorAddressLine1 As Integer
    Get
public:
property int VendorAddressLine1 {
    int get ();
}
member VendorAddressLine1 : int with get

/** @property */
public int get_VendorAddressLine1()

function get_VendorAddressLine1();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.VendorNumber Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderVendorNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int VendorNumber { get; }
Public ReadOnly Property VendorNumber As Integer
    Get
public:
property int VendorNumber {
    int get ();
}
member VendorNumber : int with get

/** @property */
public int get_VendorNumber()

function get_VendorNumber();

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


PurchaseOrderColumnOrder Methods

The CSharpPublicApiExampleProgramPurchaseOrderColumnOrder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


PurchaseOrderColumnOrder Fields

Fields
 | Name | Description
Private field | purchaseOrderColumnOrder |
Top
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.purchaseOrderColumnOrder Field

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderpurchaseOrderColumnOrder Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private NameValueCollection purchaseOrderColumnOrder
Private purchaseOrderColumnOrder As NameValueCollection
private:
NameValueCollection^ purchaseOrderColumnOrder
val mutable private purchaseOrderColumnOrder: NameValueCollection
private NameValueCollection purchaseOrderColumnOrder
var purchaseOrderColumnOrder

Field Value

Type: NameValueCollection
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo Class

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class SourceCodeDiagnosticsInfo
Public Class SourceCodeDiagnosticsInfo
public ref class SourceCodeDiagnosticsInfo
type SourceCodeDiagnosticsInfo =  class end
public class SourceCodeDiagnosticsInfo
Wasp.Cloud.Inventory.Example.SourceCodeDiagnosticsInfo = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.SourceCodeDiagnosticsInfo');

The CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo | Initializes a new instance of the CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo class
Public method | CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo(Object, String, String, Int32) | Initializes a new instance of the CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo class
Top
Properties
 | Name | Description
Public property | CallerAssemblyName |
Public property | CallerAssemblyVersion |
Public property | CallerSourceFile |
Public property | CallerType |
Public property | CallerTypeAssembly |
Public property | CallerTypeAssemblyQualifiedName |
Public property | LineNumber |
Public property | MemberName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSerializableDiagnosticsInfo |
 | GetShortString(String, String, Int32) |
 | GetShortString(Object, String, String, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


SourceCodeDiagnosticsInfo Constructor

Overload List
 | Name | Description
Public method | CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo | Initializes a new instance of the CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo class
Public method | CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo(Object, String, String, Int32) | Initializes a new instance of the CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo class
Top
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo Constructor

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public SourceCodeDiagnosticsInfo()
Public Sub New
public:
SourceCodeDiagnosticsInfo()
new : unit -> SourceCodeDiagnosticsInfo
public SourceCodeDiagnosticsInfo()
Wasp.Cloud.Inventory.Example.SourceCodeDiagnosticsInfo = function();
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class
CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Overload


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo Constructor (Object, String, String, Int32)

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Constructor (Object, String, String, Int32)

Initializes a new instance of the CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public SourceCodeDiagnosticsInfo(
    Object callerType,
    string sourceFile = null,
    string callerMember = null,
    int lineNumber = 0
)
Public Sub New (
    callerType As Object,
    Optional sourceFile As String = Nothing,
    Optional callerMember As String = Nothing,
    Optional lineNumber As Integer = 0
)
public:
SourceCodeDiagnosticsInfo(
    Object^ callerType,
    String^ sourceFile = nullptr,
    String^ callerMember = nullptr,
    int lineNumber = 0
)
new :
        callerType : Object *
        ?sourceFile : string *
        ?callerMember : string *
        ?lineNumber : int
(* Defaults:
        let _sourceFile = defaultArg sourceFile null
        let _callerMember = defaultArg callerMember null
        let _lineNumber = defaultArg lineNumber 0
*)
-> SourceCodeDiagnosticsInfo
public SourceCodeDiagnosticsInfo(
    Object callerType,
    String sourceFile = null,
    String callerMember = null,
    int lineNumber = 0
)
Wasp.Cloud.Inventory.Example.SourceCodeDiagnosticsInfo = function(callerType, sourceFile, callerMember, lineNumber);

Parameters

callerType
Type: SystemObject
sourceFile (Optional)
Type: SystemString
callerMember (Optional)
Type: SystemString
lineNumber (Optional)
Type: SystemInt32
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class
CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Overload


SourceCodeDiagnosticsInfo Properties

The CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo type exposes the following members.

Properties
 | Name | Description
Public property | CallerAssemblyName |
Public property | CallerAssemblyVersion |
Public property | CallerSourceFile |
Public property | CallerType |
Public property | CallerTypeAssembly |
Public property | CallerTypeAssemblyQualifiedName |
Public property | LineNumber |
Public property | MemberName |
Top
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.CallerAssemblyName Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoCallerAssemblyName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public virtual AssemblyName CallerAssemblyName { get; }
Public Overridable ReadOnly Property CallerAssemblyName As AssemblyName
    Get
public:
virtual property AssemblyName^ CallerAssemblyName {
    AssemblyName^ get ();
}
abstract CallerAssemblyName : AssemblyName with get
override CallerAssemblyName : AssemblyName with get
/** @property */
public AssemblyName get_CallerAssemblyName()

function get_CallerAssemblyName();

Property Value

Type: AssemblyName
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.CallerAssemblyVersion Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoCallerAssemblyVersion Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public virtual Version CallerAssemblyVersion { get; }
Public Overridable ReadOnly Property CallerAssemblyVersion As Version
    Get
public:
virtual property Version^ CallerAssemblyVersion {
    Version^ get ();
}
abstract CallerAssemblyVersion : Version with get
override CallerAssemblyVersion : Version with get
/** @property */
public Version get_CallerAssemblyVersion()

function get_CallerAssemblyVersion();

Property Value

Type: Version
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.CallerSourceFile Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoCallerSourceFile Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public FileInfo CallerSourceFile { get; protected set; }
Public Property CallerSourceFile As FileInfo
    Get
    Protected Set
public:
property FileInfo^ CallerSourceFile {
    FileInfo^ get ();
    protected: void set (FileInfo^ value);
}
member CallerSourceFile : FileInfo with get, set

/** @property */
public FileInfo get_CallerSourceFile()
/** @property */
public void set_CallerSourceFile(FileInfo value)

function get_CallerSourceFile();
function set_CallerSourceFile(value);

Property Value

Type: FileInfo
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.CallerType Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoCallerType Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Type CallerType { get; protected set; }
Public Property CallerType As Type
    Get
    Protected Set
public:
property Type^ CallerType {
    Type^ get ();
    protected: void set (Type^ value);
}
member CallerType : Type with get, set

/** @property */
public Type get_CallerType()
/** @property */
public void set_CallerType(Type value)

function get_CallerType();
function set_CallerType(value);

Property Value

Type: Type
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.CallerTypeAssembly Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoCallerTypeAssembly Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public virtual Assembly CallerTypeAssembly { get; }
Public Overridable ReadOnly Property CallerTypeAssembly As Assembly
    Get
public:
virtual property Assembly^ CallerTypeAssembly {
    Assembly^ get ();
}
abstract CallerTypeAssembly : Assembly with get
override CallerTypeAssembly : Assembly with get
/** @property */
public Assembly get_CallerTypeAssembly()

function get_CallerTypeAssembly();

Property Value

Type: Assembly
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.CallerTypeAssemblyQualifiedName Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoCallerTypeAssemblyQualifiedName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public virtual string CallerTypeAssemblyQualifiedName { get; }
Public Overridable ReadOnly Property CallerTypeAssemblyQualifiedName As String
    Get
public:
virtual property String^ CallerTypeAssemblyQualifiedName {
    String^ get ();
}
abstract CallerTypeAssemblyQualifiedName : string with get
override CallerTypeAssemblyQualifiedName : string with get
/** @property */
public String get_CallerTypeAssemblyQualifiedName()

function get_CallerTypeAssemblyQualifiedName();

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.LineNumber Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoLineNumber Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int LineNumber { get; protected set; }
Public Property LineNumber As Integer
    Get
    Protected Set
public:
property int LineNumber {
    int get ();
    protected: void set (int value);
}
member LineNumber : int with get, set

/** @property */
public int get_LineNumber()
/** @property */
public void set_LineNumber(int value)

function get_LineNumber();
function set_LineNumber(value);

Property Value

Type: Int32
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.MemberName Property

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoMemberName Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string MemberName { get; protected set; }
Public Property MemberName As String
    Get
    Protected Set
public:
property String^ MemberName {
    String^ get ();
    protected: void set (String^ value);
}
member MemberName : string with get, set

/** @property */
public String get_MemberName()
/** @property */
public void set_MemberName(String value)

function get_MemberName();
function set_MemberName(value);

Property Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


SourceCodeDiagnosticsInfo Methods

The CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSerializableDiagnosticsInfo |
 | GetShortString(String, String, Int32) |
 | GetShortString(Object, String, String, Int32) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.GetSerializableDiagnosticsInfo Method

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoGetSerializableDiagnosticsInfo Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public (string CallerTypeFullName, string MemberNane, int LineNumber, string CallerSourceFilename) GetSerializableDiagnosticsInfo()
Public Function GetSerializableDiagnosticsInfo As (CallerTypeFullName As String, MemberNane As String, LineNumber As Integer, CallerSourceFilename As String)
public:
ValueTuple<String^, String^, int, String^> GetSerializableDiagnosticsInfo()
member GetSerializableDiagnosticsInfo : unit -> ValueTuple<string, string, int, string>

public (String CallerTypeFullName, String MemberNane, int LineNumber, String CallerSourceFilename) GetSerializableDiagnosticsInfo()
function GetSerializableDiagnosticsInfo();

Return Value

Type: ValueTuple String, String, Int32, String
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


SourceCodeDiagnosticsInfo.GetShortString Method

SourceCodeDiagnosticsInfoGetShortString Method

Overload List
Name | Description
GetShortString(String, String, Int32) |
GetShortString(Object, String, String, Int32) |
Top
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.GetShortString Method (String, String, Int32)

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoGetShortString Method (String, String, Int32)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static string GetShortString(
    string callerMethod = null,
    string filePath = null,
    int lineNumber = 0
)
Public Shared Function GetShortString (
    Optional callerMethod As String = Nothing,
    Optional filePath As String = Nothing,
    Optional lineNumber As Integer = 0
) As String
public:
static String^ GetShortString(
    String^ callerMethod = nullptr,
    String^ filePath = nullptr,
    int lineNumber = 0
)
static member GetShortString :
        ?callerMethod : string *
        ?filePath : string *
        ?lineNumber : int
(* Defaults:
        let _callerMethod = defaultArg callerMethod null
        let _filePath = defaultArg filePath null
        let _lineNumber = defaultArg lineNumber 0
*)
-> string

public static String GetShortString(
    String callerMethod = null,
    String filePath = null,
    int lineNumber = 0
)
Wasp.Cloud.Inventory.Example.SourceCodeDiagnosticsInfo.GetShortString = function(callerMethod, filePath, lineNumber);

Parameters

callerMethod (Optional)
Type: SystemString
filePath (Optional)
Type: SystemString
lineNumber (Optional)
Type: SystemInt32

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class
GetShortString Overload


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.GetShortString Method (Object, String, String, Int32)

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoGetShortString Method (Object, String, String, Int32)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static string GetShortString(
    Object callerType,
    string sourceFile = null,
    string callerMember = null,
    int lineNumber = 0
)
Public Shared Function GetShortString (
    callerType As Object,
    Optional sourceFile As String = Nothing,
    Optional callerMember As String = Nothing,
    Optional lineNumber As Integer = 0
) As String
public:
static String^ GetShortString(
    Object^ callerType,
    String^ sourceFile = nullptr,
    String^ callerMember = nullptr,
    int lineNumber = 0
)
static member GetShortString :
        callerType : Object *
        ?sourceFile : string *
        ?callerMember : string *
        ?lineNumber : int
(* Defaults:
        let _sourceFile = defaultArg sourceFile null
        let _callerMember = defaultArg callerMember null
        let _lineNumber = defaultArg lineNumber 0
*)
-> string

public static String GetShortString(
    Object callerType,
    String sourceFile = null,
    String callerMember = null,
    int lineNumber = 0
)
Wasp.Cloud.Inventory.Example.SourceCodeDiagnosticsInfo.GetShortString = function(callerType, sourceFile, callerMember, lineNumber);

Parameters

callerType
Type: SystemObject
sourceFile (Optional)
Type: SystemString
callerMember (Optional)
Type: SystemString
lineNumber (Optional)
Type: SystemInt32

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class
GetShortString Overload


CSharpPublicApiExampleProgram.SourceCodeDiagnosticsInfo.ToString Method

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfoToString Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
public String ToString()
function ToString();

Return Value

Type: String
See Also

Reference

CSharpPublicApiExampleProgramSourceCodeDiagnosticsInfo Class


CSharpPublicApiExampleProgram.UploadFileType Enumeration

CSharpPublicApiExampleProgramUploadFileType Enumeration

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public enum UploadFileType
Public Enumeration UploadFileType
public enum class UploadFileType
type UploadFileType
public enum UploadFileType
Wasp.Cloud.Inventory.Example.UploadFileType = function();
Wasp.Cloud.Inventory.Example.UploadFileType.createEnum('Wasp.Cloud.Inventory.Example.UploadFileType', false);
Members
Member name | Value | Description
Unknown | 0 |
TextFile | 1 |
ImageFile | 2 |
SignatureFile | 3 |
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


CSharpPublicApiExampleProgram.WtFormId Enumeration

CSharpPublicApiExampleProgramWtFormId Enumeration

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public enum WtFormId
Public Enumeration WtFormId
public enum class WtFormId
type WtFormId
public enum WtFormId
Wasp.Cloud.Inventory.Example.WtFormId = function();
Wasp.Cloud.Inventory.Example.WtFormId.createEnum('Wasp.Cloud.Inventory.Example.WtFormId', false);
Members
Member name | Value | Description
Unknown | 0 |
Common | 100 |
CompanyInfo | 101 |
Customer | 104 |
Manufacturer | 105 |
Site | 107 |
Location | 108 |
Supplier | 109 |
Category | 110 |
Inventory | 111 |
Employee | 112 |
User | 113 |
CustomView | 114 |
Attachment | 115 |
Role | 116 |
Contract | 117 |
Department | 118 |
FormCustomization | 119 |
Condition | 120 |
DisposalReason | 121 |
RecoverReason | 122 |
WorkOrderType | 123 |
Asset | 200 |
AssetType | 201 |
AssetGroup | 202 |
AssetFunding | 203 |
AssetDCF | 204 |
AssetNotification | 205 |
DepreciationClass | 209 |
InventoriedAsset | 210 |
InventoriedAssetType | 211 |
AssetTransaction | 250 |
AssetAdd | 251 |
AssetDispose | 252 |
AssetMove | 253 |
AssetCheckIn | 254 |
AssetCheckOut | 255 |
AssetAudit | 256 |
AssetTransfer | 257 |
AssetMaintenance | 258 |
AssetDepreciation | 259 |
ApproveReservation | 260 |
CreateReservation | 261 |
AssetRecover | 262 |
AssetPurchaseDetail | 270 |
AssetConversion | 271 |
AssetMassUpdate | 272 |
AssetSetting | 273 |
AuditWindow | 274 |
AuditReconciliation | 275 |
MobileFilter | 276 |
MobileError | 277 |
Import | 278 |
TransHistory | 279 |
Task | 280 |
TaskType | 281 |
MaintenanceManagement | 282 |
WebLogin | 300 |
Reports | 306 |
AppOptions | 307 |
ReportSchedule | 308 |
MobileLogin | 400 |
Item | 1100 |
InventoryItem | 1101 |
NonInventoryItem | 1102 |
KitItem | 1103 |
AssemblyItem | 1104 |
ContainerItem | 1105 |
ServiceItem | 1106 |
ItemPriceLevel | 1130 |
ItemSupplier | 1131 |
PricingTier | 1132 |
ItemZone | 1133 |
PurchaseOrder | 1160 |
PickOrder | 1161 |
Receive | 1162 |
Ship | 1163 |
UniversalOrder | 1164 |
PurchaseOrderTotals | 1165 |
Pick | 1166 |
Build | 1170 |
Disassemble | 1171 |
ViewBuildOrder | 1172 |
AutoBuild | 1173 |
ICInventory | 1249 |
InventoryTransactions | 1250 |
InventoryAdd | 1251 |
InventoryRemove | 1252 |
InventoryMove | 1253 |
InventoryCheckIn | 1254 |
InventoryCheckOut | 1255 |
InventoryAudit | 1256 |
InventoryAdjust | 1257 |
UnitOfMeasure | 1258 |
GenerateLicenesePlateNumber | 1259 |
BillOfMaterial | 1260 |
WorkOrder | 1261 |
WorkOrderHistory | 1262 |
AssetWorkOrderLine | 1263 |
PerformWorkForQuickMaintenance | 1264 |
AssetLineWorkOrder | 1265 |
PerformWorkForWorkOrder | 1266 |
OrderStatusReasonCodeForWorkOrder | 1267 |
PayMethod | 1300 |
InventoryMobile | 1400 |
AdjustReasonCode | 1402 |
OrderSubtype | 1405 |
MobileMain | 10200 |
MobileNew | 10201 |
MobileEdit | 10202 |
MobileAudit | 10203 |
MobileCheckin | 10204 |
MobileCheckout | 10205 |
MobileDispose | 10206 |
MobileMove | 10207 |
MobileMaintenance | 10208 |
MobileAssetLookup | 10209 |
MobileFundingAudit | 10210 |
MobileLabelTemplates | 10211 |
MobileNewInventoryAsset | 10212 |
MobileReceive | 10213 |
MobilePick | 10214 |
MobileDetails | 10215 |
MobileAdjust | 10216 |
MobileAddInventory | 10251 |
MobileRemoveInventory | 10252 |
MobileAssetConversion | 10271 |
TransactionHistoryGridConfiguration | 10280 |
InternalHighOrderMultiplier | 100000 |
ItemSite | 110000107 |
ItemLocation | 110000108 |
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


Filter Class

Inheritance Hierarchy
SystemObject
FilterFlatModel
FilterModel
Wasp.Cloud.Inventory.ExampleFilter

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class Filter : FilterModel
Public Class Filter
    Inherits FilterModel
public ref class Filter : public FilterModel
type Filter =
    class
        inherit FilterModel
    end
public class Filter extends FilterModel
Wasp.Cloud.Inventory.Example.Filter = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.Filter',
    Wasp.Cloud.Inventory.API.FilterModel);

The Filter type exposes the following members.

Constructors
 | Name | Description
Public method | Filter | Initializes a new instance of the Filter class
Top
Properties
 | Name | Description
Public property | Field | Gets or sets the name of the sorted field (property). Set to null if the Filters property is set. (Inherited from FilterFlatModel.)
Public property | Filters |
Public property | Operator | <![CDATA[ Gets or sets the filtering operator. Set to <c>null</c> if the <c>Filters</c> property is set. Possible values include: eq (==), neq (!=), lt (<), lte (<=), gt (>), gte (>=), startswith, endswith, contains, doesnotcontain Note that the operators startsWith, EndsWith, Contains, and DoesNotContain are for string/text fields only, and do NOT support any wild card characters. ]]> (Inherited from FilterFlatModel.)
Public property | Value | Gets or sets the filtering value. Set to null if the Filters property is set. (Inherited from FilterFlatModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
(Filter to TopLevelFilterType) |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


Filter Constructor

Initializes a new instance of the Filter class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Filter()
Public Sub New
public:
Filter()
new : unit -> Filter
public Filter()
Wasp.Cloud.Inventory.Example.Filter = function();
See Also

Reference

Filter Class


Filter Properties

The Filter type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets or sets the name of the sorted field (property). Set to null if the Filters property is set. (Inherited from FilterFlatModel.)
Public property | Filters |
Public property | Operator | <![CDATA[ Gets or sets the filtering operator. Set to <c>null</c> if the <c>Filters</c> property is set. Possible values include: eq (==), neq (!=), lt (<), lte (<=), gt (>), gte (>=), startswith, endswith, contains, doesnotcontain Note that the operators startsWith, EndsWith, Contains, and DoesNotContain are for string/text fields only, and do NOT support any wild card characters. ]]> (Inherited from FilterFlatModel.)
Public property | Value | Gets or sets the filtering value. Set to null if the Filters property is set. (Inherited from FilterFlatModel.)
Top
See Also

Reference

Filter Class


Filter.Filters Property

FilterFilters Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public virtual List<Filter> Filters { get; set; }
Public Overridable Property Filters As List(Of Filter)
    Get
    Set
public:
virtual property List<Filter^>^ Filters {
    List<Filter^>^ get ();
    void set (List<Filter^>^ value);
}
abstract Filters : List<Filter> with get, set
override Filters : List<Filter> with get, set
/** @property */
public List<Filter> get_Filters()
/** @property */
public void set_Filters(List<Filter> value)

function get_Filters();
function set_Filters(value);

Property Value

Type: List Filter
See Also

Reference

Filter Class


Filter Methods

The Filter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Filter Class


Filter Type Conversions

The Filter type exposes the following members.

Operators
Name | Description
(Filter to TopLevelFilterType) |
Top
See Also

Reference

Filter Class


Filter Implicit Conversion (Filter to TopLevelFilterType)

Filter Conversion (Filter to TopLevelFilterType)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static implicit operator TopLevelFilterType (
    Filter filter
)
Public Shared Widening Operator CType (
    filter As Filter
) As TopLevelFilterType
static implicit operator TopLevelFilterType^ (
    Filter^ filter
)
F# does not support the declaration of new casting operators.
J# does not support overloaded operators.
JavaScript does not support the declaration of new casting operators.

Parameters

filter
Type: Wasp.Cloud.Inventory.ExampleFilter

Return Value

Type: TopLevelFilterType
See Also

Reference

Filter Class


HttpClientInitializers Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleHttpClientInitializers

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class HttpClientInitializers
Public Class HttpClientInitializers
public ref class HttpClientInitializers
type HttpClientInitializers =  class end
public class HttpClientInitializers
Wasp.Cloud.Inventory.Example.HttpClientInitializers = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.HttpClientInitializers');

The HttpClientInitializers type exposes the following members.

Constructors
 | Name | Description
Public method | HttpClientInitializers | Initializes a new instance of the HttpClientInitializers class
Top
Properties
 | Name | Description
Public property | AutoUploadFolder |
Public property | BaseAddress |
Public property | PublicApiToken |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
 | lst_detail |
 | status |
Public field | TimeoutSeconds |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


HttpClientInitializers Constructor

Initializes a new instance of the HttpClientInitializers class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public HttpClientInitializers()
Public Sub New
public:
HttpClientInitializers()
new : unit -> HttpClientInitializers
public HttpClientInitializers()
Wasp.Cloud.Inventory.Example.HttpClientInitializers = function();
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers Properties

The HttpClientInitializers type exposes the following members.

Properties
 | Name | Description
Public property | AutoUploadFolder |
Public property | BaseAddress |
Public property | PublicApiToken |
Top
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers.AutoUploadFolder Property

HttpClientInitializersAutoUploadFolder Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string AutoUploadFolder { get; protected set; }
Public Property AutoUploadFolder As String
    Get
    Protected Set
public:
property String^ AutoUploadFolder {
    String^ get ();
    protected: void set (String^ value);
}
member AutoUploadFolder : string with get, set

/** @property */
public String get_AutoUploadFolder()
/** @property */
public void set_AutoUploadFolder(String value)

function get_AutoUploadFolder();
function set_AutoUploadFolder(value);

Property Value

Type: String
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers.BaseAddress Property

HttpClientInitializersBaseAddress Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Uri BaseAddress { get; protected set; }
Public Property BaseAddress As Uri
    Get
    Protected Set
public:
property Uri^ BaseAddress {
    Uri^ get ();
    protected: void set (Uri^ value);
}
member BaseAddress : Uri with get, set

/** @property */
public Uri get_BaseAddress()
/** @property */
public void set_BaseAddress(Uri value)

function get_BaseAddress();
function set_BaseAddress(value);

Property Value

Type: Uri
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers.PublicApiToken Property

HttpClientInitializersPublicApiToken Property

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string PublicApiToken { get; protected set; }
Public Property PublicApiToken As String
    Get
    Protected Set
public:
property String^ PublicApiToken {
    String^ get ();
    protected: void set (String^ value);
}
member PublicApiToken : string with get, set

/** @property */
public String get_PublicApiToken()
/** @property */
public void set_PublicApiToken(String value)

function get_PublicApiToken();
function set_PublicApiToken(value);

Property Value

Type: String
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers Methods

The HttpClientInitializers type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers Fields

The HttpClientInitializers type exposes the following members.

Fields
 | Name | Description
 | lst_detail |
 | status |
Public field | TimeoutSeconds |
Top
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers.lst_detail Field

HttpClientInitializerslst_detail Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static List<string> lst_detail
Public Shared lst_detail As List(Of String)
public:
static List<String^>^ lst_detail
static val mutable lst_detail: List<string>
public static List<String> lst_detail
var Wasp.Cloud.Inventory.Example.HttpClientInitializers.lst_detail

Field Value

Type: List String
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers.status Field

HttpClientInitializersstatus Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static int status
Public Shared status As Integer
public:
static int status
static val mutable status: int
public static int status
var Wasp.Cloud.Inventory.Example.HttpClientInitializers.status

Field Value

Type: Int32
See Also

Reference

HttpClientInitializers Class


HttpClientInitializers.TimeoutSeconds Field

HttpClientInitializersTimeoutSeconds Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int TimeoutSeconds
Public TimeoutSeconds As Integer
public:
int TimeoutSeconds
val mutable TimeoutSeconds: int
public int TimeoutSeconds
var TimeoutSeconds

Field Value

Type: Int32
See Also

Reference

HttpClientInitializers Class


PublicApiClientBase Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExamplePublicApiClientBase
Wasp.Cloud.Inventory.ExampleCSharpPublicApiExampleProgramApiItemsPublicApiClients

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class PublicApiClientBase
Public Class PublicApiClientBase
public ref class PublicApiClientBase
type PublicApiClientBase =  class end
public class PublicApiClientBase
Wasp.Cloud.Inventory.Example.PublicApiClientBase = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.PublicApiClientBase');

The PublicApiClientBase type exposes the following members.

Constructors
 | Name | Description
 | PublicApiClientBase |
Public method | PublicApiClientBase | Initializes a new instance of the PublicApiClientBase class
Top
Methods
 | Name | Description
Protected method | CreateHttpClientAsync |
Protected method | CreateHttpRequestMessageAsync |
Public method | DecodeAsyncT |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetOverloadSleepTimeSpan |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserAgent |
 | InvokeHttpAsync |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) |
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) |
Protected method | ProcessResponse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateJsonSerializerSettings |
Top
Fields
Name | Description
AssemblyUserAgent |
WaspOverloadHeader |
WWWAuthenticateHeader |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


PublicApiClientBase Constructor

Initializes a new instance of the PublicApiClientBase class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public PublicApiClientBase()
Public Sub New
public:
PublicApiClientBase()
new : unit -> PublicApiClientBase
public PublicApiClientBase()
Wasp.Cloud.Inventory.Example.PublicApiClientBase = function();
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase Constructor

Initializes the static fields of the PublicApiClientBase class

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
static PublicApiClientBase()
Shared Sub New
private:
static PublicApiClientBase()
new : unit -> PublicApiClientBase
J# does not support static constructors.
Wasp.Cloud.Inventory.Example.PublicApiClientBase = function();
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase Methods

The PublicApiClientBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateHttpClientAsync |
Protected method | CreateHttpRequestMessageAsync |
Public method | DecodeAsyncT |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetOverloadSleepTimeSpan |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserAgent |
 | InvokeHttpAsync |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) |
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) |
Protected method | ProcessResponse |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | UpdateJsonSerializerSettings |
Top
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.CreateHttpClientAsync Method

PublicApiClientBaseCreateHttpClientAsync Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual Task<HttpClient> CreateHttpClientAsync(
    CancellationToken cancellationToken
)
Protected Overridable Function CreateHttpClientAsync (
    cancellationToken As CancellationToken
) As Task(Of HttpClient)
protected:
virtual Task<HttpClient^>^ CreateHttpClientAsync(
    CancellationToken cancellationToken
)
abstract CreateHttpClientAsync :
        cancellationToken : CancellationToken -> Task<HttpClient>
override CreateHttpClientAsync :
        cancellationToken : CancellationToken -> Task<HttpClient>
protected Task<HttpClient> CreateHttpClientAsync(
    CancellationToken cancellationToken
)
function CreateHttpClientAsync(cancellationToken);

Parameters

cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task HttpClient
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.CreateHttpRequestMessageAsync Method

PublicApiClientBaseCreateHttpRequestMessageAsync Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual Task<HttpRequestMessage> CreateHttpRequestMessageAsync(
    CancellationToken cancellationToken
)
Protected Overridable Function CreateHttpRequestMessageAsync (
    cancellationToken As CancellationToken
) As Task(Of HttpRequestMessage)
protected:
virtual Task<HttpRequestMessage^>^ CreateHttpRequestMessageAsync(
    CancellationToken cancellationToken
)
abstract CreateHttpRequestMessageAsync :
        cancellationToken : CancellationToken -> Task<HttpRequestMessage>
override CreateHttpRequestMessageAsync :
        cancellationToken : CancellationToken -> Task<HttpRequestMessage>
protected Task<HttpRequestMessage> CreateHttpRequestMessageAsync(
    CancellationToken cancellationToken
)
function CreateHttpRequestMessageAsync(cancellationToken);

Parameters

cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task HttpRequestMessage
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.DecodeAsync(T) Method

PublicApiClientBaseDecodeAsyncT Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public virtual Task<T> DecodeAsync<T>(
    Func<Task<T>> task
)

Public Overridable Function DecodeAsync(Of T) (
    task As Func(Of Task(Of T))
) As Task(Of T)
public:
generic<typename T>
virtual Task<T>^ DecodeAsync(
    Func<Task<T>^>^ task
)
abstract DecodeAsync :
        task : Func<Task<'T>> -> Task<'T>
override DecodeAsync :
        task : Func<Task<'T>> -> Task<'T>
J# supports the use of generic APIs, but not the declaration of new ones.
JavaScript does not support generic types or methods.

Parameters

task
Type: SystemFunc Task T

Type Parameters

T

Return Value

Type: Task T
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.GetOverloadSleepTimeSpan Method

PublicApiClientBaseGetOverloadSleepTimeSpan Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static TimeSpan GetOverloadSleepTimeSpan(
    SwaggerException innerEx
)
Private Shared Function GetOverloadSleepTimeSpan (
    innerEx As SwaggerException
) As TimeSpan
private:
static TimeSpan GetOverloadSleepTimeSpan(
    SwaggerException^ innerEx
)
private static member GetOverloadSleepTimeSpan :
        innerEx : SwaggerException -> TimeSpan

private static TimeSpan GetOverloadSleepTimeSpan(
    SwaggerException innerEx
)
Wasp.Cloud.Inventory.Example.PublicApiClientBase.GetOverloadSleepTimeSpan = function(innerEx);

Parameters

innerEx
Type: SwaggerException

Return Value

Type: TimeSpan
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.GetUserAgent Method

PublicApiClientBaseGetUserAgent Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static ProductInfoHeaderValue GetUserAgent()
Private Shared Function GetUserAgent As ProductInfoHeaderValue
private:
static ProductInfoHeaderValue^ GetUserAgent()
private static member GetUserAgent : unit -> ProductInfoHeaderValue

private static ProductInfoHeaderValue GetUserAgent()
Wasp.Cloud.Inventory.Example.PublicApiClientBase.GetUserAgent = function();

Return Value

Type: ProductInfoHeaderValue
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.InvokeHttpAsync Method

PublicApiClientBaseInvokeHttpAsync Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static Task<Object> InvokeHttpAsync(
    string verb,
    string baseAddress,
    string api,
    string json,
    string bearerToken,
    string mediaType,
    Action<HttpClient, HttpRequestMessage, HttpContentHeaders> preInvocationCallback,
    Action<HttpResponseMessage, string, Exception> invocationCompletedCallback,
    Nullable<CancellationToken> cancellationToken = null
)
Public Shared Function InvokeHttpAsync (
    verb As String,
    baseAddress As String,
    api As String,
    json As String,
    bearerToken As String,
    mediaType As String,
    preInvocationCallback As Action(Of HttpClient, HttpRequestMessage, HttpContentHeaders),
    invocationCompletedCallback As Action(Of HttpResponseMessage, String, Exception),
    Optional cancellationToken As Nullable(Of CancellationToken) = Nothing
) As Task(Of Object)
public:
static Task<Object^>^ InvokeHttpAsync(
    String^ verb,
    String^ baseAddress,
    String^ api,
    String^ json,
    String^ bearerToken,
    String^ mediaType,
    Action<HttpClient^, HttpRequestMessage^, HttpContentHeaders^>^ preInvocationCallback,
    Action<HttpResponseMessage^, String^, Exception^>^ invocationCompletedCallback,
    Nullable<CancellationToken> cancellationToken = nullptr
)
static member InvokeHttpAsync :
        verb : string *
        baseAddress : string *
        api : string *
        json : string *
        bearerToken : string *
        mediaType : string *
        preInvocationCallback : Action<HttpClient, HttpRequestMessage, HttpContentHeaders> *
        invocationCompletedCallback : Action<HttpResponseMessage, string, Exception> *
        ?cancellationToken : Nullable<CancellationToken>
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<Object>

public static Task<Object> InvokeHttpAsync(
    String verb,
    String baseAddress,
    String api,
    String json,
    String bearerToken,
    String mediaType,
    Action<HttpClient, HttpRequestMessage, HttpContentHeaders> preInvocationCallback,
    Action<HttpResponseMessage, String, Exception> invocationCompletedCallback,
    Nullable<CancellationToken> cancellationToken = null
)
Wasp.Cloud.Inventory.Example.PublicApiClientBase.InvokeHttpAsync = function(verb, baseAddress, api, json, bearerToken, mediaType, preInvocationCallback, invocationCompletedCallback, cancellationToken);

Parameters

verb
Type: SystemString
baseAddress
Type: SystemString
api
Type: SystemString
json
Type: SystemString
bearerToken
Type: SystemString
mediaType
Type: SystemString
preInvocationCallback
Type: SystemAction HttpClient, HttpRequestMessage, HttpContentHeaders
invocationCompletedCallback
Type: SystemAction HttpResponseMessage, String, Exception
cancellationToken (Optional)
Type: SystemNullable CancellationToken

Return Value

Type: Task Object
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.PrepareRequest Method

PublicApiClientBasePrepareRequest Method

Overload List
 | Name | Description
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) |
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) |
Top
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.PrepareRequest Method (HttpClient, HttpRequestMessage, String)

PublicApiClientBasePrepareRequest Method (HttpClient, HttpRequestMessage, String)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    string url
)
Protected Overridable Sub PrepareRequest (
    client As HttpClient,
    request As HttpRequestMessage,
    url As String
)
protected:
virtual void PrepareRequest(
    HttpClient^ client,
    HttpRequestMessage^ request,
    String^ url
)
abstract PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        url : string -> unit
override PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        url : string -> unit
protected void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    String url
)
function PrepareRequest(client, request, url);

Parameters

client
Type: System.Net.HttpHttpClient
request
Type: System.Net.HttpHttpRequestMessage
url
Type: SystemString
See Also

Reference

PublicApiClientBase Class
PrepareRequest Overload


PublicApiClientBase.PrepareRequest Method (HttpClient, HttpRequestMessage, StringBuilder)

PublicApiClientBasePrepareRequest Method (HttpClient, HttpRequestMessage, StringBuilder)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    StringBuilder urlBuilder
)
Protected Overridable Sub PrepareRequest (
    client As HttpClient,
    request As HttpRequestMessage,
    urlBuilder As StringBuilder
)
protected:
virtual void PrepareRequest(
    HttpClient^ client,
    HttpRequestMessage^ request,
    StringBuilder^ urlBuilder
)
abstract PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        urlBuilder : StringBuilder -> unit
override PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        urlBuilder : StringBuilder -> unit
protected void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    StringBuilder urlBuilder
)
function PrepareRequest(client, request, urlBuilder);

Parameters

client
Type: System.Net.HttpHttpClient
request
Type: System.Net.HttpHttpRequestMessage
urlBuilder
Type: System.TextStringBuilder
See Also

Reference

PublicApiClientBase Class
PrepareRequest Overload


PublicApiClientBase.ProcessResponse Method

PublicApiClientBaseProcessResponse Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void ProcessResponse(
    HttpClient client,
    HttpResponseMessage response
)
Protected Overridable Sub ProcessResponse (
    client As HttpClient,
    response As HttpResponseMessage
)
protected:
virtual void ProcessResponse(
    HttpClient^ client,
    HttpResponseMessage^ response
)
abstract ProcessResponse :
        client : HttpClient *
        response : HttpResponseMessage -> unit
override ProcessResponse :
        client : HttpClient *
        response : HttpResponseMessage -> unit
protected void ProcessResponse(
    HttpClient client,
    HttpResponseMessage response
)
function ProcessResponse(client, response);

Parameters

client
Type: System.Net.HttpHttpClient
response
Type: System.Net.HttpHttpResponseMessage
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.UpdateJsonSerializerSettings Method

PublicApiClientBaseUpdateJsonSerializerSettings Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void UpdateJsonSerializerSettings(
    JsonSerializerSettings settings
)
Protected Overridable Sub UpdateJsonSerializerSettings (
    settings As JsonSerializerSettings
)
protected:
virtual void UpdateJsonSerializerSettings(
    JsonSerializerSettings^ settings
)
abstract UpdateJsonSerializerSettings :
        settings : JsonSerializerSettings -> unit
override UpdateJsonSerializerSettings :
        settings : JsonSerializerSettings -> unit
protected void UpdateJsonSerializerSettings(
    JsonSerializerSettings settings
)
function UpdateJsonSerializerSettings(settings);

Parameters

settings
Type: JsonSerializerSettings
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase Fields

The PublicApiClientBase type exposes the following members.

Fields
Name | Description
AssemblyUserAgent |
WaspOverloadHeader |
WWWAuthenticateHeader |
Top
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.AssemblyUserAgent Field

PublicApiClientBaseAssemblyUserAgent Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static Lazy<ProductInfoHeaderValue> AssemblyUserAgent
Public Shared AssemblyUserAgent As Lazy(Of ProductInfoHeaderValue)
public:
static Lazy<ProductInfoHeaderValue^>^ AssemblyUserAgent
static val mutable AssemblyUserAgent: Lazy<ProductInfoHeaderValue>
public static Lazy<ProductInfoHeaderValue> AssemblyUserAgent
var Wasp.Cloud.Inventory.Example.PublicApiClientBase.AssemblyUserAgent

Field Value

Type: Lazy ProductInfoHeaderValue
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.WaspOverloadHeader Field

PublicApiClientBaseWaspOverloadHeader Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private const string WaspOverloadHeader = "Wasp-OverloadProtection-Reset "
Private Const WaspOverloadHeader As String = "Wasp-OverloadProtection-Reset "
private:
literal String^ WaspOverloadHeader = "Wasp-OverloadProtection-Reset "
static val mutable private WaspOverloadHeader: string
private static final String WaspOverloadHeader
var Wasp.Cloud.Inventory.Example.PublicApiClientBase.WaspOverloadHeader

Field Value

Type: String
See Also

Reference

PublicApiClientBase Class


PublicApiClientBase.WWWAuthenticateHeader Field

PublicApiClientBaseWWWAuthenticateHeader Field

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private const string WWWAuthenticateHeader = "WWW-Authenticate"
Private Const WWWAuthenticateHeader As String = "WWW-Authenticate"
private:
literal String^ WWWAuthenticateHeader = "WWW-Authenticate"
static val mutable private WWWAuthenticateHeader: string
private static final String WWWAuthenticateHeader
var Wasp.Cloud.Inventory.Example.PublicApiClientBase.WWWAuthenticateHeader

Field Value

Type: String
See Also

Reference

PublicApiClientBase Class


TConverter Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Inventory.ExampleTConverter

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static class TConverter
Public NotInheritable Class TConverter
public ref class TConverter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TConverter =  class end
public final class TConverter
Wasp.Cloud.Inventory.Example.TConverter = function();

Type.createClass(
    'Wasp.Cloud.Inventory.Example.TConverter');

The TConverter type exposes the following members.

Methods
Name | Description
ChangeType(Type, Object) |
ChangeTypeT(Object) |
RegisterTypeConverterT, TC |
Top
See Also

Reference

Wasp.Cloud.Inventory.Example Namespace


TConverter Methods

The TConverter type exposes the following members.

Methods
Name | Description
ChangeType(Type, Object) |
ChangeTypeT(Object) |
RegisterTypeConverterT, TC |
Top
See Also

Reference

TConverter Class


TConverter.ChangeType Method

TConverterChangeType Method

Overload List
Name | Description
ChangeTypeT(Object) |
ChangeType(Type, Object) |
Top
See Also

Reference

TConverter Class


TConverter.ChangeType(T) Method (Object)

TConverterChangeTypeT Method (Object)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static T ChangeType<T>(
    Object value
)

Public Shared Function ChangeType(Of T) (
    value As Object
) As T
public:
generic<typename T>
static T ChangeType(
    Object^ value
)
static member ChangeType :
        value : Object -> 'T

J# supports the use of generic APIs, but not the declaration of new ones.
JavaScript does not support generic types or methods.

Parameters

value
Type: SystemObject

Type Parameters

T

Return Value

Type: T
See Also

Reference

TConverter Class
ChangeType Overload


TConverter.ChangeType Method (Type, Object)

TConverterChangeType Method (Type, Object)

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static Object ChangeType(
    Type t,
    Object value
)
Public Shared Function ChangeType (
    t As Type,
    value As Object
) As Object
public:
static Object^ ChangeType(
    Type^ t,
    Object^ value
)
static member ChangeType :
        t : Type *
        value : Object -> Object

public static Object ChangeType(
    Type t,
    Object value
)
Wasp.Cloud.Inventory.Example.TConverter.ChangeType = function(t, value);

Parameters

t
Type: SystemType
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

TConverter Class
ChangeType Overload


TConverter.RegisterTypeConverter(T, TC) Method

TConverterRegisterTypeConverterT, TC Method

Namespace: Wasp.Cloud.Inventory.Example
Assembly: Wasp.InventoryControl.PublicApiExample (in Wasp.InventoryControl.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static void RegisterTypeConverter<T, TC>()
where TC : TypeConverter

Public Shared Sub RegisterTypeConverter(Of T, TC As TypeConverter)
public:
generic<typename T, typename TC>
where TC : TypeConverter
static void RegisterTypeConverter()
static member RegisterTypeConverter : unit -> unit  when 'TC : TypeConverter

J# supports the use of generic APIs, but not the declaration of new ones.
JavaScript does not support generic types or methods.

Type Parameters

T
TC
See Also

Reference

TConverter Class